On Tue, 10 Feb 2004, Klaus Singvogel wrote:

> Even when using samba-2.x some of the compilation errors are still
> present. I think that the ntlm_auth_popups.patch is removing to much
> information for still having an error free compilation, e.g. the
> "typedef HLPSONEQ" is removed.


This is only used internally in Squid, not by the helpers.

I have no problem compiling the Samba-2.2.X winbind helpers here.

> --with-samba-sources=/usr/include/samba \


The path should be to the top of the Samba source tree. The helpers uses
Samba internal headers not installed when you install Samba, only
available in the Samba source tree. See the Squid release notes.

Also you should not really need to specify --with-samba-sources if using a
current Samba-2.2.X release I think, but I have not verified if this still
applies. The squid sources include a copy of the relevant headers as
shipped with Samba 2.2.7a. Correcly specifying --with-samba-sources=... is
always a safe bet.

Regards
Henrik