Which indicates a code level issue rather than environmental or config.
I also insured packet forwarding is on. I'll dig around some BSD
resources and see if I can find additional info. Of course if anyone has
a working WCCP config with FreeBSD 4.9-S please speak up.


-----Original Message-----
From: Henrik Nordstrom [mailto:hno@squid-cache.org]
Sent: Saturday, February 07, 2004 11:18 AM
To: Cam
Cc: squid-users@squid-cache.org
Subject: Re: [squid-users] FreeBSD 4.9-Stable and WCCP not Working


On Sat, 7 Feb 2004, Cam wrote:

> After much testing and pondering, my attempts to get this working have


> failed. I have FreeBSD 4.9-Stable and a 2611 router. This used to work


> perfectly with FreeBSD 4.6. Once I get the GRE tunnel up I can ping
> between the hosts no problem. When I activate WCCP it sees squid and
> forwards packets, but that's where I am stuck. I am not getting any
> hits on my IPFW redirect. When I point the browser directly to the gre


> interface, port 80, it works though. Here is what a failed WCCP req
> looks like at the proxy interface...



Have you verified the 4.9-Stable GRE module supports WCCP without any
special configuration?

Maybe they have added support for WCCPv2 to the kernel, in which case
some
configuration may be required to indicate if WCCPv2 or WCCPv1 is used.
Both use the same protocol number in GRE but are fundamentally different

in the frame format.

Quick check.. no it does not look like FreeBSD 4.9 has support for
WCCPv2.
WCCPv1 should just work assuming there is a matching tunnel defined.

The WCCP control channel between Squid and the router seems to work
fine.
It is just the decapsulation of the redirected WCCP/GRE packets which
does not work and it is this aspect of WCCP you need to focus on
solving.

Regards
Henrik