My squid.conf looks like:
###########################################
icp_port 0
http_port 8080
httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on
httpd_accel_single_host off
hierarchy_stoplist cgi-bin ?
#ACLs
acl QUERY urlpath_regex cgi-bin \?
no_cache deny QUERY
acl localnet1 src 10.00.0.0/255.255.255.0
acl localhost src 127.0.0.1/255.255.255.255
acl Safe_ports port 80 443 210 21 1025-65535
acl CONNECT method CONNECT
acl snmp_server src 10.0.0.3/255.255.255.255
acl public_snmp snmp_community stats
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
#end ACLs

#SNMP ACCESS
snmp_access allow localhost
snmp_access allow snmp_server
snmp_access deny !snmp_server
#end SNMP ACCESS

no_cache deny QUERY
cache_mem 100 MB
cache_replacement_policy heap LFUDA
memory_replacement_policy heap GDSF

#CACHE DIRS
cache_dir ufs /squid1 5000 16 256
cache_dir ufs /squid2 5000 16 256
#end CACHE DIRS

#HTTP ACCESS
http_access allow localnet1
http_access allow localhost
http_access deny !Safe_ports
http_access deny CONNECT
http_access deny all
#HTTP ACCESS

#CACHE
cache_mgr webmaster
cache_effective_user squid
cache_effective_group squid
#opcje logowania:
cache_access_log /dysk_3/squid/access.log
cache_log /dysk_3/squid/cache.log
cache_store_log /dysk_3/squid/store.log
cache_swap_log /dysk_3/squid/cache_swap.log
cache_swap_low 80
cache_swap_high 100
emulate_httpd_log on

#cache_store_log none
cachemgr_passwd tajne_haslo all
#

#LOG
logfile_rotate 1
log_icp_queries off
buffered_logs on
visible_hostname my.domain.com
maximum_object_size 8192 KB
minimum_object_size 5 KB
request_header_max_size 20 KB
connect_timeout 100 seconds
half_closed_clients off
#############################

Max file discriptors=16000
It works as transparent proxy.
When squid takes approx. 40 MB in RAM it hangs. Sometimes it takes 100% of
CUP. It's not possible to get connect to any site via http (not all clients
are forced to see pages by squid) neither by squid nor direct. When I stop
squid, and start it again, everything is going back to normal.
btw. squid 2.5.STABLE4-20040121
Any sugesstions ?
T.

my linux machine is: dell poweredge 2600, 1GB RAM, 2xP4 Xeon HT, kernel
2.6.1
log file errors: show sometimes warnings: ctx0 and header keep alive problem
for few sites