After couple of day lost in OS and Squid tuning,
today i have disabled Write and Read cache into the Perc3/Di RAID
Controller (128MB onboard),

cache disabled
client_http.requests = 152.155593/sec
cpu_usage = 76.142118%

cache enabled
client_http.requests = 153.641384/sec
cpu_usage = 99.619241%

this is very strange, but i found the issue

Giulio Cervera ha scritto:

> The problem is the following:
> We have approximately 700Reqs/sec distributed on
>
> 4 x Dell 2650 (sibling with digest) after a load balancer
> each one with
> 2 x Xeon 1.8Ghz (HT disabled)
> 2GB Ram
> PERC3/Di RAID controller
> 5 x 36GB HD SCSI 10k (2 RAID1 for os and swap, 3 for cache)
> 3 NIC, 1 internet, 1 intranet, 1 proxy lan (digest and proxy
> comunication)
>
> 52Mbit link
>
> Slackware 8.1
> Squid 2.5.STABLE4
>
> some line of fstab
> /dev/sdb1 /var/cache/spool/0 reiserfs noatime,notail 1 2
> /dev/sdc1 /var/cache/spool/1 reiserfs noatime,notail 1 2
> /dev/sdd1 /var/cache/spool/2 reiserfs noatime,notail 1 2
>
>
> configure options:
> --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin
> --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid
> --localstatedir=/var --with-aufs-threads=48 --with-pthreads --with-aio
> --enable-async-io --enable-storeio=diskd,aufs --disable-wccp
> --enable-default-err-language=English --enable-err-languages=English
> --disable-ident-lookups --enable-underscores
> --enable-removal-policies=heap,lru --enable-snmp
> --enable-cache-digests --enable-gnuregex
>
> and actually configuration:
>
> cache_mem 64 MB
> cache_swap_low 85
> cache_swap_high 90
> maximum_object_size 65536 KB
> maximum_object_size_in_memory 24 KB
> cache_replacement_policy heap LFUDA
> memory_replacement_policy heap GDSF
> cache_dir diskd /var/cache/spool/0 28000 96 256 Q1=72 Q2=64
> cache_dir diskd /var/cache/spool/1 28000 96 256 Q1=72 Q2=64
> cache_dir diskd /var/cache/spool/2 28000 96 256 Q1=72 Q2=64
> memory_pools_limit 50 MB
> cache_access_log /var/cache/log/access.log
> cache_log /var/cache/log/cache.log
> buffered_logs on
>
> Squid sames to work fine, but cpu usage after ~60Req/Sec on each
> server is always 100%
> I have tried many changes to squid.conf with no results.
>
> Last question
> I have also to upgrade our os to RedHat AS3, any experience with it?
>
> thanks




--

*Giulio Cervera*

EDS PA SpA
Via Atanasio Soldati 80
00155 Roma (Italy)
tel: +39 06 22739 270
fax: +39 06 22739 233
e-mail: giulio.cervera@edspa.it