Hi all...

I was doing some tests with all the recommendations you sent me...
and I can make to work the server correctly... I was filtering spam with
no problems and my performances troubles dissapeard...

I just configured 5 procs for amavis and postfix content filter and
I turn off the network tests... the server can filter a lot of spam and
delivery quickly... but now appears another problem

Until today morning... I was filtering and deliverying fine, but
suddenly I received these messages and the delivery is sooo slow and
the mail queue just is growing and growing....


Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: mail for
[127.0.0.1]:10024 is using up 4001 of 4004 active queue entries
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: you may need to
reduce smtp-amavis connect and helo timeouts
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: so that Postfix
quickly skips unavailable hosts
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: you may need to
increase the main.cf minimal_backoff_time and maximal_backoff_time
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: so that Postfix
wastes less time on undeliverable mail
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: you may need to
increase the master.cf smtp-amavis process limit
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: please avoid
flushing the whole queue when you have
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: lots of deferred
mail, that is bad for performance
Nov 5 12:51:23 mailgw postfix/qmgr[14251]: warning: to turn off these
warnings specify: qmgr_clog_warn_time = 0


I have researched and I have founded to increase the
minimal_backoff_time and another parameters but nothing works...

Anybody have resolved someday this problem ?

thanks... Regards.

On Wed, 2008-10-29 at 14:59 +0000, Ned Slider wrote:

> Luis Croker wrote:
> > How can I tunr off the Network tests (RBLs) ??? Just to probe if it
> > can make the delivery faster.
> >

>
> In /etc/amavisd.conf, find the following line:
>
> $sa_local_tests_only = 0; # only tests which do not require internet
> access?
>
> and change the setting to = 1
>
> then restart amavisd
>
>