On Friday October 17 2008 14:01:15 Mark Martinec wrote:
> The 3.3 is currently fully backwards and forwards compatible with 3.2.5,
> so you can switch back to a ports-based 3.2.5 at any time if you chose so
> (just pkg_delete the directly installed SA, and reinstall SA from ports).


One detail I forgot to mention: the following change to amavisd-new-2.6.1
is needed for it to be compatible with the current SA 3.3 (and the 3.2.5):

--- amavisd-2.6.1.ori~ 2008-10-17 14:14:33.000000000 +0200
+++ amavisd-2.6.1.ori 2008-10-17 14:17:12.000000000 +0200
@@ -20295,3 +20295,3 @@
my($which_section) = 'SA prepare';
- my($data_representation) = 'GLOB'; # pass data to SA as ARRAY or a GLOB
+ my($data_representation) = 'ARRAY'; # pass data to SA as ARRAY or a GLOB
my($saved_umask) = umask; my($saved_pid) = $$;

(a cleaner fix, supplying the missing method, will be in 2.6.2).

Mark