can't verify that bayes is working - SpamAssassin

This is a discussion on can't verify that bayes is working - SpamAssassin ; I've got the rest of the rules based stuff working fine, but I can't seem to get the bayesian stuff scoring. When I run sa-learn --debug magic, you can see that there are lots of graded messages 0.000 0 1224 ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: can't verify that bayes is working

  1. can't verify that bayes is working


    I've got the rest of the rules based stuff working fine, but I can't seem to
    get the bayesian stuff scoring.
    When I run sa-learn --debug magic, you can see that there are lots of graded
    messages

    0.000 0 1224 0 non-token data: nspam
    0.000 0 1280 0 non-token data: nham

    and there are no errors in the syslog.

    spamd and spampd report no errors to syslog (it took a while to get the
    complaints about writing the bayes lock to be fixed)

    There are no bayes releated scores in either spam or ham in the users mail
    boxes.

    in the /etc/default/spamassassin
    ENABLED=1

    and /etc/spamassassin says
    use_bayes 1

    I don't know what else to do to get it working.
    Thanks
    Pat

    Debian etch 32 bit
    SpamAssassin version 3.2.3
    running on Perl version 5.8.8
    postfix
    --
    View this message in context: http://www.nabble.com/can%27t-verify...p18802329.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  2. Re: can't verify that bayes is working

    Fishtop_records wrote:
    > I've got the rest of the rules based stuff working fine, but I can't seem to
    > get the bayesian stuff scoring.
    > When I run sa-learn --debug magic, you can see that there are lots of graded
    > messages
    >
    > 0.000 0 1224 0 non-token data: nspam
    > 0.000 0 1280 0 non-token data: nham
    >

    What user did you run that as? Are you sure its the same user that's
    invoking spamc? (and also not root.. spamd never scans mail as root)
    > and there are no errors in the syslog.
    >
    > spamd and spampd report no errors to syslog (it took a while to get the
    > complaints about writing the bayes lock to be fixed)



  3. Re: can't verify that bayes is working



    Matt Kettler-3 wrote:
    >
    > What user did you run that as? Are you sure its the same user that's
    > invoking spamc? (and also not root.. spamd never scans mail as root)
    >


    Thanks, that's the trick. I had the filters setup for a user of filter, but
    spamd was running as spamd

    --
    View this message in context: http://www.nabble.com/can%27t-verify...p18803978.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


+ Reply to Thread