Pyzor not working? - SpamAssassin

This is a discussion on Pyzor not working? - SpamAssassin ; Howdy all, Have I gone insane or has Pyzor stopped working? My last successful hit was yesterday ~7am GMT-7. mail:~# cat /etc/spamassassin/.pyzor/servers 82.94.255.100:24441 --------------- mail:~# pyzor --homedir=/etc/spamassassin/ ping Traceback (most recent call last): File "/usr/bin/pyzor", line 8, in ? pyzor.client.run() ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Pyzor not working?

  1. Pyzor not working?

    Howdy all,

    Have I gone insane or has Pyzor stopped working?

    My last successful hit was yesterday ~7am GMT-7.

    mail:~# cat /etc/spamassassin/.pyzor/servers
    82.94.255.100:24441

    ---------------

    mail:~# pyzor --homedir=/etc/spamassassin/ ping
    Traceback (most recent call last):
    File "/usr/bin/pyzor", line 8, in ?
    pyzor.client.run()
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 1003, in run
    ExecCall().run()
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 184, in run
    self.servers = self.get_servers(servers_fn)
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 409,
    in get_servers
    servers.read(open(servers_fn))
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 117, in read
    self.append(pyzor.Address.from_str(line))
    File "/var/lib/python-support/python2.4/pyzor/__init__.py", line
    458, in from_str
    fields[1] = int(fields[1])
    IndexError: list index out of range

    ---------------

    mail:/var/log# nmap -p 22,25,80,24441 82.94.255.100

    Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-08-01 21:03 MST
    Interesting ports on eva.i-block.com (82.94.255.100):
    PORT STATE SERVICE
    22/tcp open ssh
    25/tcp open smtp
    80/tcp open http
    24441/tcp closed unknown

    Nmap finished: 1 IP address (1 host up) scanned in 1.187 seconds

    ---------------

    mail:/var/log# spamassassin -D < /usr/share/spamassassin/
    .....
    [25405] dbg: plugin: loading Mail::SpamAssassin::Plugin::Pyzor from @INC
    [25405] dbg: pyzor: network tests on, attempting Pyzor
    .....
    [25405] dbg: pyzor: pyzor is available: /usr/bin/pyzor
    [25405] dbg: info: entering helper-app run mode
    [25405] dbg: pyzor: opening pipe: /usr/bin/pyzor --homedir
    /etc/spamassassin check < /tmp/.spamassassin25405u3mLLntmp
    [25406] dbg: util: setuid: ruid=0 euid=0
    [25405] dbg: pyzor: [25406] finished: exit=0x0100
    [25405] dbg: pyzor: got response: Traceback (most recent call last):\n
    File "/usr/bin/pyzor", line 8, in ?\n pyzor.client.run()\n File
    "/var/lib/python-support/python2.4/pyzor/client.py", line 1003, in
    run\n ExecCall().run()\n File
    "/var/lib/python-support/python2.4/pyzor/client.py", line 184, in
    run\n self.servers = self.get_servers(servers_fn)\n File
    "/var/lib/python-support/python2.4/pyzor/client.py", line 409, in
    get_servers\n servers.read(open(servers_fn))\n File
    "/var/lib/python-support/python2.4/pyzor/client.py", line 117, in
    read\n self.append(pyzor.Address.from_str(line))\n File
    "/var/lib/python-support/python2.4/pyzor/__init__.py", line 458, in
    from_str\n fields[1] = int(fields[1])\nIndexError: list index out of
    range
    [25405] dbg: info: leaving helper-app run mode
    [25405] warn: pyzor: check failed: internal error
    ......

    ---------------

    Any ideas?

    Thanks,
    Jake


  2. Re: Pyzor not working?

    jakemaul@gmail.com ("Jake Maul") writes:

    > Howdy all,
    >
    > Have I gone insane or has Pyzor stopped working?
    >
    > My last successful hit was yesterday ~7am GMT-7.
    >
    > mail:~# cat /etc/spamassassin/.pyzor/servers
    > 82.94.255.100:24441


    Pyzor discover seems to be broken.

    pyzor ping works if you give it a homedir with the servers file:

    % pyzor --homedir /etc/mail/spamassassin ping
    82.94.255.100:24441 (200, 'OK')
    % cat /etc/mail/spamassassin/servers
    82.94.255.100:24441

    I get an error when I don't use homedir

    % pyzor ping
    Traceback (most recent call last):
    File "/usr/bin/pyzor", line 8, in ?
    pyzor.client.run()
    File "/usr/lib/site-python/pyzor/client.py", line 1003, in run
    ExecCall().run()
    File "/usr/lib/site-python/pyzor/client.py", line 184, in run
    self.servers = self.get_servers(servers_fn)
    File "/usr/lib/site-python/pyzor/client.py", line 409, in get_servers
    servers.read(open(servers_fn))
    File "/usr/lib/site-python/pyzor/client.py", line 117, in read
    self.append(pyzor.Address.from_str(line))
    File "/usr/lib/site-python/pyzor/__init__.py", line 458, in from_str
    fields[1] = int(fields[1])
    IndexError: list index out of range

    -jeff

  3. RE: Pyzor not working?

    Hi,
    I have the same problem. Can't make pyzor work.
    Is this a generall issue or just my server not working anymore?


    Regards


    Peter Sorensen/University of Southern Denmark/mail: maspsr@sdu.dk


    -----Oprindelig meddelelse-----
    Fra: Jake Maul [mailto:jakemaul@gmail.com]
    Sendt: 2. august 2008 06:05
    Til: users@spamassassin.apache.org
    Emne: Pyzor not working?

    Howdy all,

    Have I gone insane or has Pyzor stopped working?

    My last successful hit was yesterday ~7am GMT-7.

    mail:~# cat /etc/spamassassin/.pyzor/servers
    82.94.255.100:24441

    ---------------

    mail:~# pyzor --homedir=/etc/spamassassin/ ping Traceback (most recent call last):
    File "/usr/bin/pyzor", line 8, in ?
    pyzor.client.run()
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 1003, in run
    ExecCall().run()
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 184, in run
    self.servers = self.get_servers(servers_fn)
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 409, in get_servers
    servers.read(open(servers_fn))
    File "/var/lib/python-support/python2.4/pyzor/client.py", line 117, in read
    self.append(pyzor.Address.from_str(line))
    File "/var/lib/python-support/python2.4/pyzor/__init__.py", line 458, in from_str
    fields[1] = int(fields[1])
    IndexError: list index out of range

    ---------------

    mail:/var/log# nmap -p 22,25,80,24441 82.94.255.100

    Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-08-01 21:03 MST Interesting ports on eva.i-block.com (82.94.255.100):
    PORT STATE SERVICE
    22/tcp open ssh
    25/tcp open smtp
    80/tcp open http
    24441/tcp closed unknown

    Nmap finished: 1 IP address (1 host up) scanned in 1.187 seconds

    ---------------

    mail:/var/log# spamassassin -D < /usr/share/spamassassin/ ....
    [25405] dbg: plugin: loading Mail::SpamAssassin::Plugin::Pyzor from @INC [25405] dbg: pyzor: network tests on, attempting Pyzor ....
    [25405] dbg: pyzor: pyzor is available: /usr/bin/pyzor [25405] dbg: info: entering helper-app run mode [25405] dbg: pyzor: opening pipe: /usr/bin/pyzor --homedir /etc/spamassassin check < /tmp/.spamassassin25405u3mLLntmp [25406] dbg: util: setuid: ruid=0 euid=0 [25405] dbg: pyzor: [25406] finished: exit=0x0100 [25405] dbg: pyzor: got response: Traceback (most recent call last):\n File "/usr/bin/pyzor", line 8, in ?\n pyzor.client.run()\n File "/var/lib/python-support/python2.4/pyzor/client.py", line 1003, in run\n ExecCall().run()\n File "/var/lib/python-support/python2.4/pyzor/client.py", line 184, in run\n self.servers = self.get_servers(servers_fn)\n File "/var/lib/python-support/python2.4/pyzor/client.py", line 409, in get_servers\n servers.read(open(servers_fn))\n File "/var/lib/python-support/python2.4/pyzor/client.py", line 117, in read\n self.append(pyzor.Address.from_str(line))\n File "/var/lib/python-support/python2.4/pyzor/__init__.py", line 458, in from_str\n fields[1] = int(fields[1])\nIndexError: list index out of range [25405] dbg: info: leaving helper-app run mode [25405] warn: pyzor: check failed: internal error .....

    ---------------

    Any ideas?

    Thanks,
    Jake


  4. Re: Pyzor not working?

    On Wednesday 06 August 2008 3:50 am, Peter Sørensen wrote:
    > Hi,
    > I have the same problem. Can't make pyzor work.
    > Is this a generall issue or just my server not working anymore?
    >
    >
    > Regards
    >
    >
    > Peter Sorensen/University of Southern Denmark/mail: maspsr@sdu.dk
    >

    Looks to be ok

    [chris@cpollock ~]$ pyzor ping
    82.94.255.100:24441 (200, 'OK')

    --
    Chris
    KeyID 0xE372A7DA98E6705C

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.9 (GNU/Linux)

    iEYEABECAAYFAkiZi0EACgkQ43Kn2pjmcFzpfwCdEfx0n9YoIV TWuE2xkYnWuQVA
    kx8AnRDctq66HwWndAiMIL+/ld9aslAO
    =AlG4
    -----END PGP SIGNATURE-----


+ Reply to Thread