Hello list.
I want to start using URIBL tests, so I added

urirhssub URIBL_BLACK multi.uribl.com. A 2
body URIBL_BLACK eval:check_uridnsbl('URIBL_BLACK')
describe URIBL_BLACK Contains an URL listed in the URIBL blacklist
tflags URIBL_BLACK net
score URIBL_BLACK 3.0

urirhssub URIBL_GREY multi.uribl.com. A 4
body URIBL_GREY eval:check_uridnsbl('URIBL_GREY')
describe URIBL_GREY Contains an URL listed in the URIBL greylist
tflags URIBL_GREY net
score URIBL_GREY 0.25


....to my local configuration (as instructed in
http://www.uribl.com/usage.shtml), and removed the -L switch (local
tests only) to spamd startup,
and a warning appeared with each incoming mail:

warn: Use of uninitialized value in pack at
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi/Net/DNS/Question.pm
line 172.

Is that anything to worry about? How can I solve it?
I realize Perl version (5.8.1) is not the newest. Haven't got around to
updating it.
By the way, I disabled SA's URIDNSBL plugin in init.pre. It would be
redundant, somewhat, right?

The other question is, where can I see a list of all the network tests
that SA can perform, or performs by default?
I ask this because the only network tests I want are URIBL and Spamhaus,
and Spamhaus checks are done by rblsmtp before SA or qmail get their
hands on mail.
After enabling network tests the scan times went from less than 0.5 sec.
per mail, to 3-5 seconds (sort of unacceptable, to me) and that's
without DCC, Pyzor, Razor2, clamav and SpamCop.

Setup is SA 3.2.4 <-> simscan <-> qmail.
Thanks in advance for any help.
Regards.
/Diego