prefork error - SpamAssassin

This is a discussion on prefork error - SpamAssassin ; i started getting these errors recently spamd[28248]: prefork: child states: BBBBBBBBBBBBBBB spamd[28248]: prefork: server reached --max-children setting, consider raising it spamd[9708]: spamd: connection from localhost [127.0.0.1] at port 47029 spamd[9708]: spamd: setuid to parts succeeded spamd[9491]: bayes: cannot open bayes ...

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 21

Thread: prefork error

  1. prefork error


    i started getting these errors recently

    spamd[28248]: prefork: child states: BBBBBBBBBBBBBBB
    spamd[28248]: prefork: server reached --max-children setting, consider
    raising it
    spamd[9708]: spamd: connection from localhost [127.0.0.1] at port 47029
    spamd[9708]: spamd: setuid to parts succeeded
    spamd[9491]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists
    spamd[4093]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists

    What I did was edit etc/sysconfig/spamassassin and up the max from 8 to 10
    now that worked for a while but now the error has returned. What could be
    causing the server not to be able to handle all the processes?

    Thanks again
    --
    View this message in context: http://www.nabble.com/prefork-error-...p17989187.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  2. Re: prefork error


    On Wed, June 18, 2008 20:36, raulbe wrote:

    > What I did was edit etc/sysconfig/spamassassin and up the max from 8 to 10
    > now that worked for a while but now the error has returned. What could be
    > causing the server not to be able to handle all the processes?


    problem might be that you mta accepts to much spam, or even to much
    connections that your spamd cant handle at once :/

    tell us what mta you use


    Benny Pedersen
    Need more webspace ? http://www.servage.net/?coupon=cust37098


  3. Re: prefork error


    I am using sendmail as my mta


    # rpm -q sendmail
    sendmail-8.13.1-3.2.el4


    What wierd is that the error clears up and then starts again after a while.
    Also I noticed we are getting hit with a considerable amount of spam. Plus I
    think our spamassassin version is old

    # rpm -q spamassassin
    spamassassin-3.1.9-1.el4







    Benny Pedersen wrote:
    >
    >
    > On Wed, June 18, 2008 20:36, raulbe wrote:
    >
    >> What I did was edit etc/sysconfig/spamassassin and up the max from 8 to
    >> 10
    >> now that worked for a while but now the error has returned. What could be
    >> causing the server not to be able to handle all the processes?

    >
    > problem might be that you mta accepts to much spam, or even to much
    > connections that your spamd cant handle at once :/
    >
    > tell us what mta you use
    >
    >
    > Benny Pedersen
    > Need more webspace ? http://www.servage.net/?coupon=cust37098
    >
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18013023.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  4. Re: prefork error


    I also notice this error in the maillog

    spamd: still running as root: user not specified with -u, not found, or set
    to root, falling back to nobody






    raulbe wrote:
    >
    > I am using sendmail as my mta
    >
    >
    > # rpm -q sendmail
    > sendmail-8.13.1-3.2.el4
    >
    >
    > What wierd is that the error clears up and then starts again after a
    > while. Also I noticed we are getting hit with a considerable amount of
    > spam. Plus I think our spamassassin version is old
    >
    > # rpm -q spamassassin
    > spamassassin-3.1.9-1.el4
    >
    >
    >
    >
    >
    >
    >
    > Benny Pedersen wrote:
    >>
    >>
    >> On Wed, June 18, 2008 20:36, raulbe wrote:
    >>
    >>> What I did was edit etc/sysconfig/spamassassin and up the max from 8 to
    >>> 10
    >>> now that worked for a while but now the error has returned. What could
    >>> be
    >>> causing the server not to be able to handle all the processes?

    >>
    >> problem might be that you mta accepts to much spam, or even to much
    >> connections that your spamd cant handle at once :/
    >>
    >> tell us what mta you use
    >>
    >>
    >> Benny Pedersen
    >> Need more webspace ? http://www.servage.net/?coupon=cust37098
    >>
    >>
    >>

    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18013025.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  5. Re: prefork error


    On Torsdag, 19/6 2008, 18:36, raulbe wrote:
    >
    > I am using sendmail as my mta


    http://www.sendmail.org/m4/tweaking_config.html

    adjust

    confQUEUE_LA
    confREFUSE_LA
    confDELAY_LA

    delay is default 0, but in your case it should be little more then what time
    spamd uses pr scan msgs

    all the abouve settings help on the specifik problem you have that sendmail
    accepts to much msgs at once so migh need to be adjusted

    and i use postfix so my advice can be bogus, but i belive it this


    Benny Pedersen
    Need more webspace ? http://www.servage.net/?coupon=cust37098


  6. Re: prefork error


    On Torsdag, 19/6 2008, 18:37, raulbe wrote:

    > I also notice this error in the maillog
    > spamd: still running as root: user not specified with -u, not found, or set
    > to root, falling back to nobody


    make a bug on this issue to your distro, its not really a bug but it could be
    solved in the rpm file


    Benny Pedersen
    Need more webspace ? http://www.servage.net/?coupon=cust37098


  7. Re: prefork error

    On Thu, 19 Jun 2008, raulbe wrote:

    >
    > I am using sendmail as my mta
    >
    >
    > # rpm -q sendmail
    > sendmail-8.13.1-3.2.el4
    >
    >
    > What wierd is that the error clears up and then starts again after a while.
    > Also I noticed we are getting hit with a considerable amount of spam. Plus I
    > think our spamassassin version is old
    >
    > # rpm -q spamassassin
    > spamassassin-3.1.9-1.el4


    Try using round-robin rather than prefork scheduling with your SA.
    ( add the "--round-robin" command line option to your spamd startup).
    We had similar prefork issues with our installation and switching to
    round-robin fixed it.


    --
    Dave Funk University of Iowa
    College of Engineering
    319/335-5751 FAX: 319/384-0549 1256 Seamans Center
    Sys_admin/Postmaster/cell_admin Iowa City, IA 52242-1527
    #include
    Better is not better, 'standard' is better. B{


  8. Re: prefork error


    were do I find these lines?

    adjust

    confQUEUE_LA
    confREFUSE_LA
    confDELAY_LA


    I looked in both the sendmail.cf file and the sendmail.mc file and didnt
    see them?


    thanks

    Benny Pedersen wrote:
    >
    >
    > On Torsdag, 19/6 2008, 18:36, raulbe wrote:
    >>
    >> I am using sendmail as my mta

    >
    > http://www.sendmail.org/m4/tweaking_config.html
    >
    > adjust
    >
    > confQUEUE_LA
    > confREFUSE_LA
    > confDELAY_LA
    >
    > delay is default 0, but in your case it should be little more then what
    > time
    > spamd uses pr scan msgs
    >
    > all the abouve settings help on the specifik problem you have that
    > sendmail
    > accepts to much msgs at once so migh need to be adjusted
    >
    > and i use postfix so my advice can be bogus, but i belive it this
    >
    >
    > Benny Pedersen
    > Need more webspace ? http://www.servage.net/?coupon=cust37098
    >
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18017921.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  9. Re: prefork error

    On 19.06.08 13:54, raulbe wrote:
    > were do I find these lines?


    > confQUEUE_LA
    > confREFUSE_LA
    > confDELAY_LA


    > I looked in both the sendmail.cf file and the sendmail.mc file and didnt
    > see them?


    you'll see them in cf.README(.gz) and you can add them to sendmail.mc
    --
    Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    Warning: I wish NOT to receive e-mail advertising to this address.
    Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    Saving Private Ryan...
    Private Ryan exists. Overwrite? (Y/N)


  10. Re: prefork error


    So should the entry look like this?


    confQUEUE_LA=1
    confREFUSE_LA=1
    confDELAY_LA =1





    Matus UHLAR - fantomas wrote:
    >
    > On 19.06.08 13:54, raulbe wrote:
    >> were do I find these lines?

    >
    >> confQUEUE_LA
    >> confREFUSE_LA
    >> confDELAY_LA

    >
    >> I looked in both the sendmail.cf file and the sendmail.mc file and didnt
    >> see them?

    >
    > you'll see them in cf.README(.gz) and you can add them to sendmail.mc
    > --
    > Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    > Warning: I wish NOT to receive e-mail advertising to this address.
    > Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    > Saving Private Ryan...
    > Private Ryan exists. Overwrite? (Y/N)
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18031229.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  11. Re: prefork error

    On 20.06.08 07:55, raulbe wrote:
    > So should the entry look like this?
    >
    >
    > confQUEUE_LA=1
    > confREFUSE_LA=1
    > confDELAY_LA =1


    as you wish, I have those higher. My machine can handle load of 1.0 very
    well and so I expect yours. I have those set to (3,5,unset).

    instead of DELAY_LA I use

    FEATURE(`greet_pause', `10000')dnl 10 seconds

    which delays connections for 10 seconds (can be whitelisted in access DB).
    I also use ident which delays them more for some firewalls on user machines



    > Matus UHLAR - fantomas wrote:
    > >
    > > On 19.06.08 13:54, raulbe wrote:
    > >> were do I find these lines?

    > >
    > >> confQUEUE_LA
    > >> confREFUSE_LA
    > >> confDELAY_LA

    > >
    > >> I looked in both the sendmail.cf file and the sendmail.mc file and didnt
    > >> see them?

    > >
    > > you'll see them in cf.README(.gz) and you can add them to sendmail.mc


    --
    Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    Warning: I wish NOT to receive e-mail advertising to this address.
    Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    Eagles may soar, but weasels don't get sucked into jet engines.


  12. Re: prefork error


    THanks so much for the help


    Now if I can figure out why I keep getting the bayes.lock error any clues?


    bayes: cannot open bayes databases /home/nuonce/spamassassin/bayes_* R/W:
    lock failed: File exists
    Jun 20 11:02:41 ws096 spamd[20261]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists
    Jun 20 11:02:42 ws096 spamd[20262]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists
    Jun 20 11:02:42 ws096 spamd[20260]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists
    Jun 20 11:02:42 ws096 spamd[20259]: bayes: cannot open bayes databases
    /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists




    Matus UHLAR - fantomas wrote:
    >
    > On 20.06.08 07:55, raulbe wrote:
    >> So should the entry look like this?
    >>
    >>
    >> confQUEUE_LA=1
    >> confREFUSE_LA=1
    >> confDELAY_LA =1

    >
    > as you wish, I have those higher. My machine can handle load of 1.0 very
    > well and so I expect yours. I have those set to (3,5,unset).
    >
    > instead of DELAY_LA I use
    >
    > FEATURE(`greet_pause', `10000')dnl 10 seconds
    >
    > which delays connections for 10 seconds (can be whitelisted in access DB).
    > I also use ident which delays them more for some firewalls on user
    > machines
    >
    >
    >
    >> Matus UHLAR - fantomas wrote:
    >> >
    >> > On 19.06.08 13:54, raulbe wrote:
    >> >> were do I find these lines?
    >> >
    >> >> confQUEUE_LA
    >> >> confREFUSE_LA
    >> >> confDELAY_LA
    >> >
    >> >> I looked in both the sendmail.cf file and the sendmail.mc file and

    >> didnt
    >> >> see them?
    >> >
    >> > you'll see them in cf.README(.gz) and you can add them to sendmail.mc

    >
    > --
    > Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    > Warning: I wish NOT to receive e-mail advertising to this address.
    > Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    > Eagles may soar, but weasels don't get sucked into jet engines.
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18031812.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  13. Re: prefork error

    On 20.06.08 08:18, raulbe wrote:
    > Now if I can figure out why I keep getting the bayes.lock error any clues?


    > Jun 20 11:02:41 ws096 spamd[20261]: bayes: cannot open bayes databases
    > /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists


    do you have autolearning turned on? what about journal?
    (settings bayes_auto_learn and bayes_learn_to_journal).
    the default settings (1 and 0) can cause such problems. Try turning on the
    latter or off the former
    --
    Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    Warning: I wish NOT to receive e-mail advertising to this address.
    Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    I drive way too fast to worry about cholesterol.


  14. Re: prefork error


    On Fredag, 20/6 2008, 16:55, raulbe wrote:
    > So should the entry look like this?
    > confQUEUE_LA=1
    > confREFUSE_LA=1


    this is based on load avage

    > confDELAY_LA =1


    this is based on deley secunds (keep this litte more then your scan time pr mail)

    with 1 you scan every email/spam in just one sec, and sendmail accept new spam
    in that time


    see the page i linked to in the first place :/


    Benny Pedersen
    Need more webspace ? http://www.servage.net/?coupon=cust37098


  15. Re: prefork error


    What I did was turn off auto_learn and that cleared up the error. So would
    doing this would it affect how bayes works or?

    Also doing the editing in

    confQUEUE_LA
    confREFUSE_LA
    confDELAY_LA

    totaly cleared up the prefork: server reached --max-children setting,
    consider raising it error i was getting.

    So all thats left is this error

    spamd[29330]: prefork: child states: BBBBBIBI


    any ideas to clear that one up?

    Thanks for the help.



    Matus UHLAR - fantomas wrote:
    >
    > On 20.06.08 08:18, raulbe wrote:
    >> Now if I can figure out why I keep getting the bayes.lock error any
    >> clues?

    >
    >> Jun 20 11:02:41 ws096 spamd[20261]: bayes: cannot open bayes databases
    >> /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists

    >
    > do you have autolearning turned on? what about journal?
    > (settings bayes_auto_learn and bayes_learn_to_journal).
    > the default settings (1 and 0) can cause such problems. Try turning on the
    > latter or off the former
    > --
    > Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    > Warning: I wish NOT to receive e-mail advertising to this address.
    > Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    > I drive way too fast to worry about cholesterol.
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18035422.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  16. Re: prefork error


    Couple new errors now

    config: cannot write to /var/spool/uucp/.spamassassin/user_prefs: No such
    file or directory


    spamd[19476]: spamd: processing message <01c8d312$d0710900$f7aac051@9k7>
    for uucp:10







    Matus UHLAR - fantomas wrote:
    >
    > On 20.06.08 08:18, raulbe wrote:
    >> Now if I can figure out why I keep getting the bayes.lock error any
    >> clues?

    >
    >> Jun 20 11:02:41 ws096 spamd[20261]: bayes: cannot open bayes databases
    >> /home/nuonce/spamassassin/bayes_* R/W: lock failed: File exists

    >
    > do you have autolearning turned on? what about journal?
    > (settings bayes_auto_learn and bayes_learn_to_journal).
    > the default settings (1 and 0) can cause such problems. Try turning on the
    > latter or off the former
    > --
    > Matus UHLAR - fantomas, uhlar@fantomas.sk ; http://www.fantomas.sk/
    > Warning: I wish NOT to receive e-mail advertising to this address.
    > Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
    > I drive way too fast to worry about cholesterol.
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18036734.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  17. Re: prefork error

    raulbe wrote:
    > What I did was turn off auto_learn and that cleared up the error. So would
    > doing this would it affect how bayes works or?


    Well, yes. All Bayes training will now have to be done manually.

    What's usually a slightly better idea for a global Bayes database is to
    set these Bayes options:

    bayes_learn_to_journal 1
    bayes_auto_expire 0

    and make sure to set up a cron job to run "sa-learn --sync
    --force-expire" periodically (I've been finding daily is a good idea; YMMV).

    > So all thats left is this error
    >
    > spamd[29330]: prefork: child states: BBBBBIBI


    This isn't an error, it's an informational message telling you what
    spamd's children are doing.

    If you really want to get rid of it, you'll either have to shift the
    logging threshold for the "mail" facility in syslog until it goes away
    (thus likely losing a great deal of valuable log data from both SA and
    other sources) or fiddle the SA source so that those messages get sent
    with a "debug" priority, and set syslog to not log debug-priority messages.

    Unless you're *really* horribly short on disk (I can recall a few
    systems I might have considered that on), it's not worth worrying about.

    -kgd


  18. Re: prefork error


    Were can i find these settings?

    would it be in spamassassin.bayes_rules or
    23_bayes.cf


    Thanks




    Kris Deugau wrote:
    >
    > raulbe wrote:
    >> What I did was turn off auto_learn and that cleared up the error. So
    >> would
    >> doing this would it affect how bayes works or?

    >
    > Well, yes. All Bayes training will now have to be done manually.
    >
    > What's usually a slightly better idea for a global Bayes database is to
    > set these Bayes options:
    >
    > bayes_learn_to_journal 1
    > bayes_auto_expire 0
    >
    > and make sure to set up a cron job to run "sa-learn --sync
    > --force-expire" periodically (I've been finding daily is a good idea;
    > YMMV).
    >
    >> So all thats left is this error
    >>
    >> spamd[29330]: prefork: child states: BBBBBIBI

    >
    > This isn't an error, it's an informational message telling you what
    > spamd's children are doing.
    >
    > If you really want to get rid of it, you'll either have to shift the
    > logging threshold for the "mail" facility in syslog until it goes away
    > (thus likely losing a great deal of valuable log data from both SA and
    > other sources) or fiddle the SA source so that those messages get sent
    > with a "debug" priority, and set syslog to not log debug-priority
    > messages.
    >
    > Unless you're *really* horribly short on disk (I can recall a few
    > systems I might have considered that on), it's not worth worrying about.
    >
    > -kgd
    >
    >


    --
    View this message in context: http://www.nabble.com/prefork-error-...p18037020.html
    Sent from the SpamAssassin - Users mailing list archive at Nabble.com.


  19. Re: prefork error

    raulbe wrote:
    > Were can i find these settings?
    >
    > would it be in spamassassin.bayes_rules or
    > 23_bayes.cf


    As with all site-local settings, the Bayes options should go in a .cf
    file in your site config dir - typically either /etc/mail/spamassassin/
    or /etc/spamassassin/. local.cf is usually convenient.

    I'm not sure what you're referring to with "spamassassin.bayes_rules".

    -kgd


  20. Re: prefork error


    On Fri, June 20, 2008 22:38, raulbe wrote:

    > Were can i find these settings?


    perldoc Mail::SpamAssassin::Conf
    perldoc Mail::SpamAssassin::Plugin::Bayes

    plenty of info there

    > would it be in spamassassin.bayes_rules or
    > 23_bayes.cf


    no in local.cf or user_prefs


    Benny Pedersen
    Need more webspace ? http://www.servage.net/?coupon=cust37098


+ Reply to Thread
Page 1 of 2 1 2 LastLast