sa-update, dostech, / RHEL5 question - SpamAssassin

This is a discussion on sa-update, dostech, / RHEL5 question - SpamAssassin ; Hi, I'm in the process of converting to sa-update on rhel5, spamassassin 3.2.4, to replace a rules_du_jour installation. I'm trying to use the dostech sa-update channels. Ultimately I'm looking to use a channel file, but for now I'm trying to ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: sa-update, dostech, / RHEL5 question

  1. sa-update, dostech, / RHEL5 question

    Hi,

    I'm in the process of converting to sa-update on rhel5, spamassassin
    3.2.4, to replace a rules_du_jour installation. I'm trying to use the
    dostech sa-update channels.

    Ultimately I'm looking to use a channel file, but for now I'm trying to
    get just one channel to work. I'm getting this error when I run with
    debugging:


    [20790] dbg: dns: query failed:
    4.2.3.72_sare_bml_post25x.cf.sare.sa-update.dostech.net => NOERROR


    Thanks for any suggestions....

    - Aaron Bennett


    Here's the complete output of the sa-update:


    [root@mothra ~]# sa-update --channel
    72_sare_bml_post25x.cf.sare.sa-update.dostech.net -D --gpgkey 856AA88A
    [20790] dbg: logger: adding facilities: all
    [20790] dbg: logger: logging level is DBG
    [20790] dbg: generic: SpamAssassin version 3.2.4
    [20790] dbg: config: score set 0 chosen.
    [20790] dbg: dns: no ipv6
    [20790] dbg: dns: is Net:NS::Resolver available? yes
    [20790] dbg: dns: Net:NS version: 0.63
    [20790] dbg: generic: sa-update version svn607589
    [20790] dbg: generic: using update directory: /var/lib/spamassassin/3.002004
    [20790] dbg: diag: perl platform: 5.008008 linux
    [20790] dbg: diag: module installed: Digest::SHA1, version 2.11
    [20790] dbg: diag: module installed: HTML::Parser, version 3.56
    [20790] dbg: diag: module installed: Net:NS, version 0.63
    [20790] dbg: diag: module installed: MIME::Base64, version 3.07
    [20790] dbg: diag: module installed: DB_File, version 1.814
    [20790] dbg: diag: module installed: Net::SMTP, version 2.29
    [20790] dbg: diag: module not installed: Mail::SPF ('require' failed)
    [20790] dbg: diag: module installed: Mail::SPF::Query, version 1.999001
    [20790] dbg: diag: module installed: IP::Country::Fast, version 604.001
    [20790] dbg: diag: module not installed: Razor2::Client::Agent
    ('require' failed)
    [20790] dbg: diag: module not installed: Net::Ident ('require' failed)
    [20790] dbg: diag: module not installed: IO::Socket::INET6 ('require'
    failed)
    [20790] dbg: diag: module installed: IO::Socket::SSL, version 1.13
    [20790] dbg: diag: module installed: Compress::Zlib, version 2.01
    [20790] dbg: diag: module installed: Time::HiRes, version 1.86
    [20790] dbg: diag: module installed: Mail:omainKeys, version 1.0
    [20790] dbg: diag: module not installed: Mail:KIM ('require' failed)
    [20790] dbg: diag: module installed: DBI, version 1.604
    [20790] dbg: diag: module installed: Getopt::Long, version 2.35
    [20790] dbg: diag: module installed: LWP::UserAgent, version 2.033
    [20790] dbg: diag: module installed: HTTP:ate, version 1.47
    [20790] dbg: diag: module installed: Archive::Tar, version 1.38
    [20790] dbg: diag: module installed: IO::Zlib, version 1.09
    [20790] dbg: diag: module not installed: Encode:etect ('require' failed)
    [20790] dbg: gpg: adding key id 856AA88A
    [20790] dbg: gpg: Searching for 'gpg'
    [20790] dbg: util: current PATH is:
    /usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
    [20790] dbg: util: executable for gpg was found at /usr/bin/gpg
    [20790] dbg: gpg: found /usr/bin/gpg
    [20790] dbg: gpg: release trusted key id list:
    5E541DC959CB8BAC7C78DFDC4056A61A5244EC45
    26C900A46DD40CD5AD24F6D7DEE01987265FA05B
    0C2B1D7175B852C64B3CDC716C55397824F434CE 856AA88A
    [20790] dbg: channel: attempting channel
    72_sare_bml_post25x.cf.sare.sa-update.dostech.net
    [20790] dbg: channel: update directory
    /var/lib/spamassassin/3.002004/72_sare_bml_post25x_cf_sare_sa-update_dostech_net
    [20790] dbg: channel: channel cf file
    /var/lib/spamassassin/3.002004/72_sare_bml_post25x_cf_sare_sa-update_dostech_net.cf
    [20790] dbg: channel: channel pre file
    /var/lib/spamassassin/3.002004/72_sare_bml_post25x_cf_sare_sa-update_dostech_net.pre
    [20790] dbg: dns: query failed:
    4.2.3.72_sare_bml_post25x.cf.sare.sa-update.dostech.net => NOERROR
    [20790] dbg: channel: no updates available, skipping channel
    [20790] dbg: diag: updates complete, exiting with code 1
    [root@mothra ~]#


  2. Re: sa-update, dostech, / RHEL5 question

    On 06/06/2008 4:43 PM, Aaron Bennett wrote:
    > Hi,
    >
    > I'm in the process of converting to sa-update on rhel5, spamassassin
    > 3.2.4, to replace a rules_du_jour installation. I'm trying to use the
    > dostech sa-update channels.
    >
    > Ultimately I'm looking to use a channel file, but for now I'm trying to
    > get just one channel to work. I'm getting this error when I run with
    > debugging:
    >
    >
    > [20790] dbg: dns: query failed:
    > 4.2.3.72_sare_bml_post25x.cf.sare.sa-update.dostech.net => NOERROR


    Is this still happening? It seems to be working for me...

    [dos@cyan ~]$ dig +short txt
    4.2.3.72_sare_bml_post25x.cf.sare.sa-update.dostech.net
    "200705210700"
    [dos@cyan ~]$


+ Reply to Thread