Hi Mike,

Thanks again for the advice. I've just managed to miss-configure Postfix by
restarting SpamAssasin ( Don't know why is sending spam from my account
now, it's like bouncing it with my address as "From". Probably will do the
Virtual Machine reharsal for the upgrade.

Best regards,

/Hiram


Michael Hutchinson-3 wrote:
>
> Hello Hiram,
>
> It's not scary, you have to step up and own it - be prepared. The best
> way might be to replicate the situation/scenario in a Virtual
> environment, and attempt upgrading in there first, to see what might go
> wrong, and how you can avoid problems on your live server.
>
> VMWare is great for this, for me. You might find some other
> Virtualization software suits you, but it is much better to use that
> than to "learn" Spamassassin on your live server(s).
>
> Doing something on a live server that you haven't done before at all,
> will get you labelled as a loose cannon.
>
> Cheers,
> Mike
>
>
>> -----Original Message-----
>> From: hiram [mailto:hiramegl@yahoo.com]
>> Sent: 14 April 2008 9:04 p.m.
>> To: users@spamassassin.apache.org
>> Subject: RE: Upgrading
>>
>>
>> Hi Mike,
>>
>> That sounds on the limit to scarry.
>> I will rethink it before upgrading then.
>> Thanks for the advice and the information!
>>
>> Best regards,
>>
>> /Hiram
>>
>>
>> Michael Hutchinson-3 wrote:
>> >
>> >> -----Original Message-----
>> >
>> > Sir,
>> >
>> > You or someone else, has managed to break apt-get's info about S.A.

> Im
>> > not going into fixing that, that is a Debian question.
>> >
>> > You need to download the package manually with 'wget'.
>> > You can "apt-get install wget" if you don't have it.
>> > Use wget to get the package.
>> > Example "wget http://somefileyouwant.deb"
>> >
>> > After that use dpkg -i to install the package just as if you'd used
>> > apt-get.
>> > "dpkg -i somefileyouwant.deb"
>> >
>> > That will install your Spamassassin package. Just remember you're
>> > opening a can of worms by using anything later than S.A. version

> 3.1.7
>> > on Debian Sarge. The newer versions are reported to run fine on

> Debian
>> > Etch.
>> >
>> > I botched an upgrade from 3.1.4 -> 3.2.3 on Sarge a while ago, and

> it
>> > caused a MASSIVE headache with incorrect dependencies, wrong perl
>> > modules being installed, and config being installed in new/different
>> > locations, which ended up with an INSANE installation - more than

> one
>> > version existing in binaries or config on one singular computer. Not

> a
>> > good look.
>> >
>> > It took a long time to fix. (well, it seemed like a very long time)
>> >
>> > You'd be better off arranging some downtime. Copying out your

> current
>> > S.A config, and completely removing S.A altogether, including

> manually
>> > hunting down every config file and binary. Then and only then would

> I
>> > consider installing the 3.2.4 package, and restoring the config.
>> >
>> > HTH,
>> > Mike
>> >
>> >

>>
>> --
>> View this message in context: http://www.nabble.com/Upgrading-
>> tp16630332p16674214.html
>> Sent from the SpamAssassin - Users mailing list archive at Nabble.com.

>
>
>


--
View this message in context: http://www.nabble.com/Upgrading-tp16...p16697333.html
Sent from the SpamAssassin - Users mailing list archive at Nabble.com.