> -----Original Message-----
> From: hiram [mailto:hiramegl@yahoo.com]
> Sent: 14 April 2008 4:32 p.m.
> To: users@spamassassin.apache.org
> Subject: Re: Upgrading
>=20
>=20
> Hi again!
>=20
> Sorry, that's what my wife means when she says: "you hear but you

don't
> listen" :-((. Thanks for the answers.
>=20
> Still, I cannot manage to upgrade spam assassin. Does anyone have any

idea
> what the problem could be?
> in debian-sarge:
>=20
> apt-get install spamassassin
>=20
> /Hiram



Sir,=20

You or someone else, has managed to break apt-get's info about S.A. Im
not going into fixing that, that is a Debian question.

You need to download the package manually with 'wget'.
You can "apt-get install wget" if you don't have it.
Use wget to get the package.
Example "wget http://somefileyouwant.deb"

After that use dpkg -i to install the package just as if you'd used
apt-get.=20
"dpkg -i somefileyouwant.deb"

That will install your Spamassassin package. Just remember you're
opening a can of worms by using anything later than S.A. version 3.1.7
on Debian Sarge. The newer versions are reported to run fine on Debian
Etch.=20

I botched an upgrade from 3.1.4 -> 3.2.3 on Sarge a while ago, and it
caused a MASSIVE headache with incorrect dependencies, wrong perl
modules being installed, and config being installed in new/different
locations, which ended up with an INSANE installation - more than one
version existing in binaries or config on one singular computer. Not a
good look.=20

It took a long time to fix. (well, it seemed like a very long time)

You'd be better off arranging some downtime. Copying out your current
S.A config, and completely removing S.A altogether, including manually
hunting down every config file and binary. Then and only then would I
consider installing the 3.2.4 package, and restoring the config.


HTH,
Mike