Is there an ETA for 3.2.2 yet?

-----Original Message-----
From: Matt Kettler [mailto:mkettler_sa@verizon.net]=20
Sent: Monday, July 23, 2007 8:08 AM
To: Balzi Andrea
Cc: users@spamassassin.apache.org
Subject: Re: Upgrade problem from 3.1.7 to 3.2.1

Balzi Andrea wrote:
> Hi
>
> In to my smtp-relay (debian dabsed) I've installed spamassassin from
> debian-package and after upgrade it by the follow command:
>
> /usr/bin/cpan Mail::SpamAssassin
>
> Now when I trying to upgrade spamassassin v3.1.7 to v3.2.1 with the

same
> command I saw the following messages:



> At the follow error I've stop all.
> Which is it the problem? Lack some library? Can You suggest how can
> solve it?
> =20


Known bug in SA 3.2.1 and 3.1.8. Due to a bug in the test scripts, it
will always fail if make test is run as root.

There's a trick to get CPAN to do a make-test as non-root (which I
forget what is)..

The other alternatives would be:
use a source-tarball and manually build/test it as a non-root user
then su to root for the make install stage
tell CPAN to force install
wait for 3.2.2 to be released, which fixes this issue.