I am so frustrated.. updated cpanel the other day to
WHM 11.2.0 cPanel 11.6.0-C15032
FEDORA 4 i686 - WHM X v3.1.0
Exim 4.66 on a Linux box

This in turn updated SA to 3.002001 (3.2.1 I guess)
I have run sa-update, restarted exim.. and SA runs and it definitely catches
spam.. no question there..
Exim statistics from 2007-07-15 04:06:11 to 2007-07-17 22:06:20
Received 5871
Delivered 7195
Rejects 48228
thats 66 hours and 48k spam received.. and trashed

But I am still getting way to many spams.. more than I did before the
update -- cialis, viagra, all kinds of meds, all scoring between 0.6 and 3.5

How can these mails score that low?

I used to be able to see the rules it hit on, but can no longer see this..
Also I see that since the upgrade local delivered mails are not being
scanned at all.. not that those really matter IMHO.. they come from my
forums or forms.. The SA version header is also gone from the headers..

Other settings

Reject mail at SMTP time if the spam score from spamassassin is greater than
10.0. [Ticked ON]
Reject messages with potentially dangerous attachments. [Ticked ON]
Rewrite messages SpamAssassin marks as spam with ***SPAM*** at the beginning
of the subject line. [Ticked ON]

OH WAIT.. Turn on SpamAssassin for all accounts (Global ON). is NOT
checked... and neither is use old transport system.. am I just being dumb
blond here??
But if the global is not ON.. how is SA running? OK so I am really confused
now


I did turn SA ON globally and am tailing the mail logs right now.. what I
saw when SA restarted:
Jul 17 22:30:18 server spamd[7755]: rules: meta test FM_DDDD_TIMES_2 has
dependency 'FH_HOST_EQ_D_D_D_D' with a zero score
Jul 17 22:30:18 server spamd[7755]: rules: meta test FM_SEX_HOSTDDDD has
dependency 'FH_HOST_EQ_D_D_D_D' with a zero score
Jul 17 22:30:18 server spamd[7755]: rules: meta test HS_PHARMA_1 has
dependency 'HS_SUBJ_ONLINE_PHARMACEUTICAL' with a zero score

how do I fix that??

And mails created locally from my forum and forms are still not getting
scanned, but in the past 2+ hours the spam level of those that got through
has decreased somewhat

The server also seems to be running at slightly higher loads (.90 - 1.50%)
than before.. my forum is quite busy this time of night though so it is hard
to say where that lies
thanks