On Tue, 3 Jul 2007 carnold5@nc.rr.com wrote:

> I downloaded the traball and made a rpm; which created
> perl-spamassassin.rpm and mail-spamassassin.rpm. I installed
> perl-spamassassin first using yast and then spamassassin using
> yast. The spamassassin rpm failed to installed but when i do a rpm
> -qa spamassassin it shows both 3.1 and 3.2 installed.


I assume you provided the "upgrade" option on the command line? You
can install multiple versions of the same package if you're not
careful.

This should do it:

rpm -Uvh *spamassassin*3.2*.rpm

> I look in /etc/mail/spamassassin and all the 3.1 files are still
> there along with 3.2pre file.


What does "spamassassin --debug --lint" say about the version?

> Should i uninstall and then reinstall and if i do this, what will
> happen to all the existing rules and what-not?


You should know what custom rules you've installed. They should be
copied somewhere safe and/or checked into revision control (learn
RCS. live RCS.) and should be easy to reinstall if needed.

It won't hurt to uninstall all of the SA RPMs and reinstall just the
latest one.

The rites of initiation continue...

--
John Hardin KA7OHZ http://www.impsec.org/~jhardin/
jhardin@impsec.org FALaholic #11174 pgpk -a jhardin@impsec.org
key: 0xB8732E79 -- 2D8C 34F4 6411 F507 136C AF76 D822 E6E6 B873 2E79
-----------------------------------------------------------------------
It there a Special Olympics for terrorists going on in the UK this
week? -- Bruce Schneier, 07/02/2007
-----------------------------------------------------------------------
Tomorrow: The 231st anniversary of the Declaration of Independence