Joerg Reisslein wrote:
>
> Hi List.
>
>
>
> I’d like to upgrade our running SA to the latest version 3.2.1, using
> cpan Mail::SpamAssassin.
>
>
>
> Install fails, see the output below:
>
>


>
>
>
>
>
> Any ideas what is going wrong?
>

This looks to be a known bug in 3.2.1, make test fails when run as root,
which inherently breaks all CPAN installs.

http://issues.apache.org/SpamAssassi...ug.cgi?id=5510

As a workaround, you can either:

1) download the tarball, and do your build and make test as a non-root
user, then su to do the final make install as root.

2) do a force install in cpan (less desirable, as it overlooks any other
possible problems, but easier)