This is a multi-part message in MIME format.

------_=_NextPart_001_01C7AE57.5382BA36
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

Possibly related to
=20
http://issues.apache.org/SpamAssassi....cgi?id=3D5511
=20
as discussed in the "DNS tests getting aborted" thread?
=20
Cheers,
=20
Phil

--
Phil Randal
Network Engineer
Herefordshire Council
Hereford, UK=20

=20


________________________________

From: Rosenbaum, Larry M. [mailto:rosenbaumlm@ornl.gov]=20
Sent: 13 June 2007 22:01
To: users@spamassassin.apache.org
Subject: "make test" dnsbl tests sporadically fail
=09
=09

When I run "make test" for v3.2.1, why do some of the dnsbl
tests sporadically fail? For instance:

=20

t/dnsbl..................... Not found: P_2 =3D
[127.0.0.4]

# Failed test 1 in t/SATest.pm at line 635

Not found: P_7 =3D


# Failed test 2 in t/SATest.pm at line 635 fail #2

Not found: P_4 =3D
[127.0.0.1]

t/dnsbl.....................NOK 1# Failed test 3 in t/SATest.pm
at line 635 fail #3

Not found: P_3 =3D
[127.0.0.12]

# Failed test 4 in t/SATest.pm at line 635 fail #4

Not found: P_5 =3D
[127.0.0.1]

# Failed test 5 in t/SATest.pm at line 635 fail #5

t/dnsbl.....................NOK 2 Not found: P_1 =3D
[127.0.0.2]

# Failed test 6 in t/SATest.pm at line 635 fail #6

Not found: P_6 =3D
[127.0.0.2]

# Failed test 7 in t/SATest.pm at line 635 fail #7

Not found: P_15 =3D DNSBL_RHS

t/dnsbl.....................NOK 3# Failed test 8 in t/SATest.pm
at line 635 fail #8

Not found: P_17 =3D DNSBL_SB_FLOAT

t/dnsbl.....................NOK 4# Failed test 9 in t/SATest.pm
at line 635 fail #9

Not found: P_18 =3D DNSBL_SB_STR

# Failed test 10 in t/SATest.pm at line 635 fail #10

Not found: P_16 =3D DNSBL_SB_TIME

# Failed test 11 in t/SATest.pm at line 635 fail #11

t/dnsbl.....................NOK 5 Not found: P_10 =3D
DNSBL_TEST_DYNAMIC

# Failed test 12 in t/SATest.pm at line 635 fail #12

Not found: P_12 =3D DNSBL_TEST_RELAY

# Failed test 13 in t/SATest.pm at line 635 fail #13

t/dnsbl.....................NOK 6 Not found: P_11 =3D
DNSBL_TEST_SPAM

# Failed test 14 in t/SATest.pm at line 635 fail #14

Not found: P_8 =3D DNSBL_TEST_TOP

# Failed test 15 in t/SATest.pm at line 635 fail #15

Not found: P_9 =3D DNSBL_TEST_WHITELIST

t/dnsbl.....................NOK 7# Failed test 16 in t/SATest.pm
at line 635 fail #16

Not found: P_14 =3D DNSBL_TXT_RE

# Failed test 17 in t/SATest.pm at line 635 fail #17

Not found: P_13 =3D DNSBL_TXT_TOP

t/dnsbl.....................NOK 8# Failed test 18 in t/SATest.pm
at line 635 fail #18

t/dnsbl.....................NOK 9Output can be examined in:
log/d.dns/1

t/dnsbl.....................FAILED tests 1-18

Failed 18/23 tests, 21.74% okay

=20

If I run t/dnsbl.t later, a smaller number of the subtests fail.
If I repeat it later, a different set of dnsbl subtests fail.

=20

There is nothing obviously wrong with the DNS server. What
causes this problem?


------_=_NextPart_001_01C7AE57.5382BA36
Content-Type: text/html;
charset="us-ascii"
Content-Transfer-Encoding: quoted-printable


"urn:schemas-microsoft-com:vml" xmlns =3D=20
"urn:schemas-microsoft-comfficeffice" xmlns:w =3D=20
"urn:schemas-microsoft-comffice:word" xmlns:m =3D=20
"http://schemas.microsoft.com/office/2004/12/omml">
charset=3Dus-ascii">




size=3D2> class=3D810014007-14062007>Possibly related to

size=3D2> class=3D810014007-14062007> 

size=3D2> class=3D810014007-14062007>  href=3D"http://issues.apache.org/SpamAssassin/show_bug.cgi?id=3D5511">htt=
p://issues.apache.org/SpamAssassin/show_bug.cgi?id=3D5511 T>

size=3D2> class=3D810014007-14062007> 

size=3D2> class=3D810014007-14062007>as discussed in the "DNS tests getting =
aborted"=20
thread?

size=3D2> class=3D810014007-14062007> 

size=3D2> class=3D810014007-14062007>Cheers,

size=3D2> class=3D810014007-14062007> 

size=3D2> class=3D810014007-14062007>Phil

--
Phil Randal
Network Engineer
Herefordshire =

Council
Hereford, UK


 


style=3D"PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px =
solid; MARGIN-RIGHT: 0px">



From: Rosenbaum, Larry M.=20
[mailto:rosenbaumlm@ornl.gov]
Sent: 13 June 2007=20
22:01
To: users@spamassassin.apache.org
Subject: =
"make=20
test" dnsbl tests sporadically fail




When I run “make test” for v3.2.1, =
why do some of the dnsbl=20
tests sporadically fail?  For instance:>>


>


style=3D"FONT-FAMILY: 'Courier =
New'">t/dnsbl.....................   =20
Not found: P_2 =3D  =
<dns:134.88.73.210.dnsbltest.spamassassin.org>=2 0
[127.0.0.4]>>


# =
Failed test 1 in=20
t/SATest.pm at line 635>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_7 =3D =20
=
<dns:134.88.73.210.sb.dnsbltest.spamassassin.org?t ype=3DTXT>> o>


# =
Failed test 2 in=20
t/SATest.pm at line 635 fail #2>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_4 =3D  =
<dns:14.35.17.212.dnsbltest.spamassassin.org>=20
[127.0.0.1]>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
1# Failed=20
test 3 in t/SATest.pm at line 635 fail #3>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_3 =3D  =
<dns:18.13.119.61.dnsbltest.spamassassin.org>=20
[127.0.0.12]>>


# =
Failed test 4 in=20
t/SATest.pm at line 635 fail #4>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_5 =3D  =
<dns:226.149.120.193.dnsbltest.spamassassin.org>=2 0
[127.0.0.1]>>


# =
Failed test 5 in=20
t/SATest.pm at line 635 fail #5>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK=20
2       Not found: P_1 =3D =20
<dns:98.3.137.144.dnsbltest.spamassassin.org>=20
[127.0.0.2]>>


# =
Failed test 6 in=20
t/SATest.pm at line 635 fail #6>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_6 =3D  =
<dns:example.com.dnsbltest.spamassassin.org>=20
[127.0.0.2]>>


# =
Failed test 7 in=20
t/SATest.pm at line 635 fail #7>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_15 =3D  DNSBL_RHS>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
3# Failed=20
test 8 in t/SATest.pm at line 635 fail #8>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_17 =3D  DNSBL_SB_FLOAT>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
4# Failed=20
test 9 in t/SATest.pm at line 635 fail #9>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_18 =3D  DNSBL_SB_STR>>


# =
Failed test 10=20
in t/SATest.pm at line 635 fail #10>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_16 =3D  DNSBL_SB_TIME>>


# =
Failed test 11=20
in t/SATest.pm at line 635 fail #11>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK=20
5       Not found: P_10 =3D =20
DNSBL_TEST_DYNAMIC>>


# =
Failed test 12=20
in t/SATest.pm at line 635 fail #12>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_12 =3D  DNSBL_TEST_RELAY>>


# =
Failed test 13=20
in t/SATest.pm at line 635 fail #13>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK=20
6       Not found: P_11 =3D =20
DNSBL_TEST_SPAM>>


# =
Failed test 14=20
in t/SATest.pm at line 635 fail #14>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_8 =3D  DNSBL_TEST_TOP>>


# =
Failed test 15=20
in t/SATest.pm at line 635 fail #15>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_9 =3D  DNSBL_TEST_WHITELIST>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
7# Failed=20
test 16 in t/SATest.pm at line 635 fail #16>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_14 =3D  DNSBL_TXT_RE>>


# =
Failed test 17=20
in t/SATest.pm at line 635 fail #17>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Not found: P_13 =3D  DNSBL_TXT_TOP>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
8# Failed=20
test 18 in t/SATest.pm at line 635 fail #18>>


style=3D"FONT-FAMILY: 'Courier New'">t/dnsbl.....................NOK =
9Output can=20
be examined in: log/d.dns/1>>


style=3D"FONT-FAMILY: 'Courier =
New'">t/dnsbl.....................FAILED tests=20
1-18>>


style=3D"FONT-FAMILY: 'Courier =
New'">       =20
Failed 18/23 tests, 21.74% okay>>


>


If I run t/dnsbl.t later, a smaller number of the =
subtests=20
fail.  If I repeat it later, a different set of dnsbl subtests=20
fail.>>


>


There is nothing obviously wrong with the DNS =
server. =20
What causes this =
problem?>>



------_=_NextPart_001_01C7AE57.5382BA36--