sound - Solaris

This is a discussion on sound - Solaris ; I want to use some multimedia applications on opensolaris. I installed oss and executed the osstest procedure. At first I could listen the test sound on the right channel and afterward on the left channel. Then the test where repeated ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: sound

  1. sound

    I want to use some multimedia applications on opensolaris. I installed
    oss and executed the osstest procedure. At first I could listen the test
    sound on the right channel and afterward on the left channel. Then the
    test where repeated with encreasing loudness.

    After the third circle the procedure stopped with an error message. I
    couldn't also modify the volume with the volume control panel.

    I could read the messages, that /dev/oss/hdaudio0/pcm0 is busy. I can
    not find out which process.

    uname-a:
    SunOS pc10062 5.11 snv_98 i86pc i386 i86pc Solaris

    Package Info:
    bz3203@pc10062:/var/adm# pkginfo | grep oss
    GNOME2 SUNWflac An Open Source lossless
    audio codec
    GNOME2 SUNWflac-devel An Open Source lossless
    audio codec - development files
    driver oss Open Sound System

    OSS testinng:
    bz3203@pc10062:/var/adm# osstest
    Sound subsystem and version: OSS 4.0 (b1016/200806171344) (0x00040003)
    Platform: SunOS/i86pc 5.11 snv_98

    *** Scanning sound adapter #-1 ***
    /dev/oss/hdaudio0/pcm0 (audio engine 0): HD Audio play front
    Note! Device is in use (by PID 0/SADA) but will try anyway
    - Performing audio playback test... /dev/oss/hdaudio0/pcm0: Device busy
    The device is busy. There is some other application
    using it.
    Can't open the device
    /dev/oss/hdaudio0/pcm1 (audio engine 1): HD Audio play headphone
    - Performing audio playback test...
    OK OK OK

    *** Some errors were detected during the tests ***

    Protocol in /vvar/adm/messages:
    Oct 9 12:00:11 pc10062 sadasupport: [ID 517056 kern.warning] WARNING:
    ldi_open_by_name("/dev/dsp") failed, errno=13
    Oct 9 12:02:07 pc10062 osscommon: [ID 505123 kern.warning] WARNING:
    Failed to open vmix engine 7, err=-13

    Stefan

  2. Re: sound

    On Thu, 09 Oct 2008 12:25:05 +0200, Stefan Sprungk wrote:

    > After the third circle the procedure stopped with an error message. I
    > couldn't also modify the volume with the volume control panel.


    Kill that volume control and remove it from the panel.

    > I could read the messages, that /dev/oss/hdaudio0/pcm0 is busy. I can
    > not find out which process.


    The volume control.

    > Oct 9 12:00:11 pc10062 sadasupport: [ID 517056 kern.warning] WARNING:
    > ldi_open_by_name("/dev/dsp") failed, errno=13


    cd /dev
    ln -s /dev/oss/hdaudio0/pcm0 dsp
    ln -s ../devices/pseudo/osscore@0:mixer mixer

    > Oct 9 12:02:07 pc10062 osscommon: [ID 505123 kern.warning] WARNING:
    > Failed to open vmix engine 7, err=-13


    Get rid of that GNOME volume control. OSS uses its own mixer. Try
    /usr/bin/ossxmix


  3. Re: sound

    Dave Uhring wrote:
    > On Thu, 09 Oct 2008 12:25:05 +0200, Stefan Sprungk wrote:
    >
    >> After the third circle the procedure stopped with an error message. I
    >> couldn't also modify the volume with the volume control panel.

    >
    > Kill that volume control and remove it from the panel.
    >
    >> I could read the messages, that /dev/oss/hdaudio0/pcm0 is busy. I can
    >> not find out which process.

    >
    > The volume control.
    >
    >> Oct 9 12:00:11 pc10062 sadasupport: [ID 517056 kern.warning] WARNING:
    >> ldi_open_by_name("/dev/dsp") failed, errno=13

    >
    > cd /dev
    > ln -s /dev/oss/hdaudio0/pcm0 dsp
    > ln -s ../devices/pseudo/osscore@0:mixer mixer
    >
    >> Oct 9 12:02:07 pc10062 osscommon: [ID 505123 kern.warning] WARNING:
    >> Failed to open vmix engine 7, err=-13

    >
    > Get rid of that GNOME volume control. OSS uses its own mixer. Try
    > /usr/bin/ossxmix
    >


    Thanks a lot! The sound works now.

    Stefann

+ Reply to Thread