How to execute (?) p600-GA2-TRIAL.img on Solaris 10 - Solaris

This is a discussion on How to execute (?) p600-GA2-TRIAL.img on Solaris 10 - Solaris ; Hello Everyone, I am a complete Solaris novice having never seen it till today, so suspect this question could be laughable. I need to setup Solaris 10 then install IBM WebSphere MQ Server 6 on it. I seem to have ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: How to execute (?) p600-GA2-TRIAL.img on Solaris 10

  1. How to execute (?) p600-GA2-TRIAL.img on Solaris 10

    Hello Everyone,

    I am a complete Solaris novice having never seen it till today, so suspect
    this question could be laughable.

    I need to setup Solaris 10 then install IBM WebSphere MQ Server 6 on it. I
    seem to have succeeded in setting up Solaris but can't see how to install
    MQ.

    In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    execute to start the install. However if I double click this from the
    Explorer type interface absolutely nothing appears to happen and if I try to
    run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not found"
    is returned even though ls shows it present.

    Although this file appears to have execute permission I don't know if it
    should be executable, or if it requires a separate install package (as per
    msi files in Windows).

    Any help will be very gratefully appreciated.

    BTW I am logged on as root.

    Thanks, Paul



  2. Re: How to execute (?) p600-GA2-TRIAL.img on Solaris 10

    On Tue, 19 Jun 2007 19:31:14 GMT, Paul Jones wrote:
    > Hello Everyone,
    >
    > I am a complete Solaris novice having never seen it till today, so suspect
    > this question could be laughable.
    >
    > I need to setup Solaris 10 then install IBM WebSphere MQ Server 6 on it. I
    > seem to have succeeded in setting up Solaris but can't see how to install
    > MQ.
    >
    > In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    > execute to start the install. However if I double click this from the
    > Explorer type interface absolutely nothing appears to happen and if I try to
    > run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not found"
    > is returned even though ls shows it present.
    >
    > Although this file appears to have execute permission I don't know if it
    > should be executable, or if it requires a separate install package (as per
    > msi files in Windows).
    >
    > Any help will be very gratefully appreciated.
    >
    > BTW I am logged on as root.


    Is this a CD/DVD image?

    Try the following commands:

    lofiadm -a /full/path/to/p600-GA2-TRIAL.img
    mkdir /tmp/test
    mount -F hsfs -o ro /dev/lofi/1 /tmp/test

    (when done, assuming the commands above worked, undo them in the reverse
    order:
    umount /tmp/test
    lofiadm -d /dev/lofi/1)

    A bientot
    Paul


  3. Re: How to execute (?) p600-GA2-TRIAL.img on Solaris 10


    "Paul Floyd" wrote in message
    news:slrnf7gd0u.18u.root@bourbiere.local...
    > On Tue, 19 Jun 2007 19:31:14 GMT, Paul Jones wrote:
    >> Hello Everyone,
    >>
    >> I am a complete Solaris novice having never seen it till today, so
    >> suspect
    >> this question could be laughable.
    >>
    >> I need to setup Solaris 10 then install IBM WebSphere MQ Server 6 on it.
    >> I
    >> seem to have succeeded in setting up Solaris but can't see how to install
    >> MQ.
    >>
    >> In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    >> execute to start the install. However if I double click this from the
    >> Explorer type interface absolutely nothing appears to happen and if I try
    >> to
    >> run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not
    >> found"
    >> is returned even though ls shows it present.
    >>
    >> Although this file appears to have execute permission I don't know if it
    >> should be executable, or if it requires a separate install package (as
    >> per
    >> msi files in Windows).
    >>
    >> Any help will be very gratefully appreciated.
    >>
    >> BTW I am logged on as root.

    >
    > Is this a CD/DVD image?
    >
    > Try the following commands:
    >
    > lofiadm -a /full/path/to/p600-GA2-TRIAL.img
    > mkdir /tmp/test
    > mount -F hsfs -o ro /dev/lofi/1 /tmp/test
    >
    > (when done, assuming the commands above worked, undo them in the reverse
    > order:
    > umount /tmp/test
    > lofiadm -d /dev/lofi/1)
    >
    > A bientot
    > Paul
    >


    Thanks for the reply Paul

    When I execute lofiadm -a /full/path/to/p600-GA2-TRIAL.img, the following is
    returned:
    lofiadm: size of /usr/MQ6/p600-GA2-TRIAL.img is not a multiple of 512.
    On checking the file size, this is a correct statement.

    The package came in a file "WMQv601TrialSolaris_x86-64.tar.Z" which I
    downloaded using the "IBM Download Director" to a Windows machine before
    copying it to Solaris. When I could not get Solaris to to anything with the
    file I unzipped it on the Windows machine then copied the contents
    (including p600-GA2-TRIAL.img) to /usr/MQ6 on Solaris.

    The size of the file on the Windows machine is the same as that on Solaris.

    Thanks, Matthew



  4. Re: How to execute (?) p600-GA2-TRIAL.img on Solaris 10

    oops I put my 2nd name in there.
    "Paul Jones" wrote in message
    news:9oXdi.1886$%Z3.471@newsfe3-gui.ntli.net...
    >
    > "Paul Floyd" wrote in message
    > news:slrnf7gd0u.18u.root@bourbiere.local...
    >> On Tue, 19 Jun 2007 19:31:14 GMT, Paul Jones wrote:
    >>> Hello Everyone,
    >>>
    >>> I am a complete Solaris novice having never seen it till today, so
    >>> suspect
    >>> this question could be laughable.
    >>>
    >>> I need to setup Solaris 10 then install IBM WebSphere MQ Server 6 on it.
    >>> I
    >>> seem to have succeeded in setting up Solaris but can't see how to
    >>> install
    >>> MQ.
    >>>
    >>> In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    >>> execute to start the install. However if I double click this from the
    >>> Explorer type interface absolutely nothing appears to happen and if I
    >>> try to
    >>> run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not
    >>> found"
    >>> is returned even though ls shows it present.
    >>>
    >>> Although this file appears to have execute permission I don't know if it
    >>> should be executable, or if it requires a separate install package (as
    >>> per
    >>> msi files in Windows).
    >>>
    >>> Any help will be very gratefully appreciated.
    >>>
    >>> BTW I am logged on as root.

    >>
    >> Is this a CD/DVD image?
    >>
    >> Try the following commands:
    >>
    >> lofiadm -a /full/path/to/p600-GA2-TRIAL.img
    >> mkdir /tmp/test
    >> mount -F hsfs -o ro /dev/lofi/1 /tmp/test
    >>
    >> (when done, assuming the commands above worked, undo them in the reverse
    >> order:
    >> umount /tmp/test
    >> lofiadm -d /dev/lofi/1)
    >>
    >> A bientot
    >> Paul
    >>

    >
    > Thanks for the reply Paul
    >
    > When I execute lofiadm -a /full/path/to/p600-GA2-TRIAL.img, the following
    > is returned:
    > lofiadm: size of /usr/MQ6/p600-GA2-TRIAL.img is not a multiple of 512.
    > On checking the file size, this is a correct statement.
    >
    > The package came in a file "WMQv601TrialSolaris_x86-64.tar.Z" which I
    > downloaded using the "IBM Download Director" to a Windows machine before
    > copying it to Solaris. When I could not get Solaris to to anything with
    > the file I unzipped it on the Windows machine then copied the contents
    > (including p600-GA2-TRIAL.img) to /usr/MQ6 on Solaris.
    >
    > The size of the file on the Windows machine is the same as that on
    > Solaris.
    >
    > Thanks, Matthew
    >





  5. Re: How to execute (?) p600-GA2-TRIAL.img on Solaris 10

    Paul Jones wrote:
    > In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    > execute to start the install. However if I double click this from the
    > Explorer type interface absolutely nothing appears to happen and if I try to
    > run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not found"
    > is returned even though ls shows it present.


    Try the "file" command, it should tell you what kind of file it is.

    file p600-GA2-TRIAL.img

    if it says "package datastream" then you install it with

    pkgadd -d p600-GA2-TRIAL.img

    I have no idea why they would use .img for packages (it is usually .pkg)
    but the installation manual, page 59, uses pkgadd with a .img file

    http://publibfp.boulder.ibm.com/epubs/pdf/amqdac08.pdf



  6. Re: How to execute (?) p600-GA2-TRIAL.img on Solaris 10


    "Oscar del Rio" wrote in message
    news:f59il9$8us$1@news.mie...
    > Paul Jones wrote:
    >> In the MQ package the file p600-GA2-TRIAL.img seems the obvious file to
    >> execute to start the install. However if I double click this from the
    >> Explorer type interface absolutely nothing appears to happen and if I try
    >> to run it from a terminal/command prompt then "p600-GA2-TRIAL.img: not
    >> found" is returned even though ls shows it present.

    >
    > Try the "file" command, it should tell you what kind of file it is.
    >
    > file p600-GA2-TRIAL.img
    >
    > if it says "package datastream" then you install it with
    >
    > pkgadd -d p600-GA2-TRIAL.img
    >
    > I have no idea why they would use .img for packages (it is usually .pkg)
    > but the installation manual, page 59, uses pkgadd with a .img file
    >
    > http://publibfp.boulder.ibm.com/epubs/pdf/amqdac08.pdf
    >
    >


    Thanks for that Oscar, it has got me started. There now seems to be other
    problems, but I am trying to work my way through them.



+ Reply to Thread