jumpstart - Solaris

This is a discussion on jumpstart - Solaris ; Hi, I am currently trying to configure my x86 machine as a jumpstart server, when running the ./add_install_client command I have seen examples of the output as Adding Ethernet number for client.intra-connect.net to /etc/ethers making /tftpboot enabling tftp in /etc/inetd.conf ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: jumpstart

  1. jumpstart

    Hi,

    I am currently trying to configure my x86 machine as a jumpstart server,
    when running the ./add_install_client command I have seen examples of the
    output as

    Adding Ethernet number for client.intra-connect.net to /etc/ethers
    making /tftpboot
    enabling tftp in /etc/inetd.conf
    starting rarpd
    starting bootparamd
    updating /etc/bootparams
    copying inetboot to /tftpboot
    how mine looks like

    jumpstart> ./add_install_client \
    -e 8:0:20:a8:d4:22 \
    -s jumpstart:/export/install/s9x_0904 \
    -c jumpstart:/export/install/jumpstart \
    -p jumpstart:/export/install/jumpstart \
    client \
    i86pc
    Adding Ethernet number for client.intra-connect.net to /etc/ethers
    making /tftpboot
    updating /etc/bootparams


    My concern is that in the tftp directory there are no files, what am I doing
    wrong ? I guess its something to do with the line "copying inetboot to
    /tftpboot"



    Regards

    Paul



  2. Re: jumpstart

    On Sat, 13 May 2006 23:11:55 +0100, p@p.com wrote:

    > Hi,
    >
    > I am currently trying to configure my x86 machine as a jumpstart server,
    > when running the ./add_install_client command I have seen examples of the
    > output as
    >
    > Adding Ethernet number for client.intra-connect.net to /etc/ethers
    > making /tftpboot
    > enabling tftp in /etc/inetd.conf
    > starting rarpd
    > starting bootparamd
    > updating /etc/bootparams
    > copying inetboot to /tftpboot
    > how mine looks like
    >
    > jumpstart> ./add_install_client \
    > -e 8:0:20:a8:d4:22 \
    > -s jumpstart:/export/install/s9x_0904 \
    > -c jumpstart:/export/install/jumpstart \
    > -p jumpstart:/export/install/jumpstart \
    > client \
    > i86pc
    > Adding Ethernet number for client.intra-connect.net to /etc/ethers
    > making /tftpboot
    > updating /etc/bootparams
    >
    >
    > My concern is that in the tftp directory there are no files, what am I doing
    > wrong ? I guess its something to do with the line "copying inetboot to
    > /tftpboot"
    >


    Welcome to the world of JumpStart and the extra fun of PXE boot (as it
    looks like you are trying to do an x86 build).

    Its been a while since I played/debugged the add_install_client stuff for
    PXE boot.

    The hard way is to read up at http://docs.sun.com or , if you just want to
    get up and working then I can recommend JET (JumpStart Enterprise Toolkit)
    available at http://www.sun.com/downloads (under J :-) ) with a handy FAQ
    site at http://jet.maui.co.uk


    HTH

    --
    Bruce

    "The internet is a huge and diverse community and
    not every one is friendly"
    http://www.ytc1.co.uk


  3. Re: jumpstart

    Thanks for your reply bruce.

    I have things working alot better, the rules, profile and sysidcfg files are
    all filled in nearly 100% correctly, the only thing is I'm still prompted
    about manually ejecting cd/dvd and agreeing to the licenses agreement.

    any clues anyone ?

    Thanks

    Paul
    "Bruce Porter" wrote in message
    newsan.2006.05.15.18.19.19.385081@ytc1NOARGEYSPAM.co.u k...
    > On Sat, 13 May 2006 23:11:55 +0100, p@p.com wrote:
    >
    >> Hi,
    >>
    >> I am currently trying to configure my x86 machine as a jumpstart server,
    >> when running the ./add_install_client command I have seen examples of the
    >> output as
    >>
    >> Adding Ethernet number for client.intra-connect.net to /etc/ethers
    >> making /tftpboot
    >> enabling tftp in /etc/inetd.conf
    >> starting rarpd
    >> starting bootparamd
    >> updating /etc/bootparams
    >> copying inetboot to /tftpboot
    >> how mine looks like
    >>
    >> jumpstart> ./add_install_client \
    >> -e 8:0:20:a8:d4:22 \
    >> -s jumpstart:/export/install/s9x_0904 \
    >> -c jumpstart:/export/install/jumpstart \
    >> -p jumpstart:/export/install/jumpstart \
    >> client \
    >> i86pc
    >> Adding Ethernet number for client.intra-connect.net to /etc/ethers
    >> making /tftpboot
    >> updating /etc/bootparams
    >>
    >>
    >> My concern is that in the tftp directory there are no files, what am I
    >> doing
    >> wrong ? I guess its something to do with the line "copying inetboot to
    >> /tftpboot"
    >>

    >
    > Welcome to the world of JumpStart and the extra fun of PXE boot (as it
    > looks like you are trying to do an x86 build).
    >
    > Its been a while since I played/debugged the add_install_client stuff for
    > PXE boot.
    >
    > The hard way is to read up at http://docs.sun.com or , if you just want to
    > get up and working then I can recommend JET (JumpStart Enterprise Toolkit)
    > available at http://www.sun.com/downloads (under J :-) ) with a handy FAQ
    > site at http://jet.maui.co.uk
    >
    >
    > HTH
    >
    > --
    > Bruce
    >
    > "The internet is a huge and diverse community and
    > not every one is friendly"
    > http://www.ytc1.co.uk
    >




  4. Re: jumpstart

    On Tue, 16 May 2006 23:33:17 +0100, p@p.com wrote:

    > Thanks for your reply bruce.
    >
    > I have things working alot better, the rules, profile and sysidcfg files are
    > all filled in nearly 100% correctly, the only thing is I'm still prompted
    > about manually ejecting cd/dvd and agreeing to the licenses agreement.
    >
    > any clues anyone ?
    >


    It sounds like something major wrong with your JumpStart set.

    Did you run

    setup_install_server from the 1st CD ?

    > Thanks
    >
    > Paul
    > "Bruce Porter" wrote in message
    > newsan.2006.05.15.18.19.19.385081@ytc1NOARGEYSPAM.co.u k...
    >> On Sat, 13 May 2006 23:11:55 +0100, p@p.com wrote:
    >>
    >>> Hi,
    >>>
    >>> I am currently trying to configure my x86 machine as a jumpstart server,
    >>> when running the ./add_install_client command I have seen examples of the
    >>> output as
    >>>
    >>> Adding Ethernet number for client.intra-connect.net to /etc/ethers
    >>> making /tftpboot
    >>> enabling tftp in /etc/inetd.conf
    >>> starting rarpd
    >>> starting bootparamd
    >>> updating /etc/bootparams
    >>> copying inetboot to /tftpboot
    >>> how mine looks like
    >>>
    >>> jumpstart> ./add_install_client \
    >>> -e 8:0:20:a8:d4:22 \
    >>> -s jumpstart:/export/install/s9x_0904 \
    >>> -c jumpstart:/export/install/jumpstart \
    >>> -p jumpstart:/export/install/jumpstart \
    >>> client \
    >>> i86pc
    >>> Adding Ethernet number for client.intra-connect.net to /etc/ethers
    >>> making /tftpboot
    >>> updating /etc/bootparams
    >>>
    >>>
    >>> My concern is that in the tftp directory there are no files, what am I
    >>> doing
    >>> wrong ? I guess its something to do with the line "copying inetboot to
    >>> /tftpboot"
    >>>

    >>
    >> Welcome to the world of JumpStart and the extra fun of PXE boot (as it
    >> looks like you are trying to do an x86 build).
    >>
    >> Its been a while since I played/debugged the add_install_client stuff for
    >> PXE boot.
    >>
    >> The hard way is to read up at http://docs.sun.com or , if you just want to
    >> get up and working then I can recommend JET (JumpStart Enterprise Toolkit)
    >> available at http://www.sun.com/downloads (under J :-) ) with a handy FAQ
    >> site at http://jet.maui.co.uk
    >>
    >>
    >> HTH
    >>
    >> --
    >> Bruce
    >>
    >> "The internet is a huge and diverse community and
    >> not every one is friendly"
    >> http://www.ytc1.co.uk
    >>


    --
    Bruce

    "The internet is a huge and diverse community and
    not every one is friendly"
    http://www.ytc1.co.uk


+ Reply to Thread