solaris 10 1/06 in qemu 0.8.0 runnin on linux - Solaris

This is a discussion on solaris 10 1/06 in qemu 0.8.0 runnin on linux - Solaris ; ive been trying several times to install solaris 10 1/06 in qemu 0.8.0 runnin on suse linux 10. i select 'solaris interactive (console mode)' during the initial phase. copying of files completes and then reboots. after the reboot, 90 smf ...

+ Reply to Thread
Results 1 to 12 of 12

Thread: solaris 10 1/06 in qemu 0.8.0 runnin on linux

  1. solaris 10 1/06 in qemu 0.8.0 runnin on linux

    ive been trying several times to install solaris 10 1/06 in qemu 0.8.0
    runnin on suse linux 10. i select 'solaris interactive (console mode)'
    during the initial phase. copying of files completes and then reboots.
    after the reboot, 90 smf services are registered and then i get a
    SIGSEV from a java related process and the message that solaris install
    encountered an error. i press any key to reboot and on the next boot i
    get a console prompt. but the installation is not complete i believe.
    any suggestions
    thanx


  2. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    On Mon, 08 May 2006 06:07:36 -0700, e_risha wrote:

    > ive been trying several times to install solaris 10 1/06 in qemu 0.8.0
    > runnin on suse linux 10. i select 'solaris interactive (console mode)'
    > during the initial phase. copying of files completes and then reboots.
    > after the reboot, 90 smf services are registered and then i get a
    > SIGSEV from a java related process and the message that solaris install
    > encountered an error. i press any key to reboot and on the next boot i
    > get a console prompt. but the installation is not complete i believe.
    > any suggestions


    What sort of console prompt ?
    What makes you think it has not completed.

    Must admit, never occured to me to run Solaris under qemu on my Solaris
    laptop.... hmmmm :-)

    --
    Bruce

    "The internet is a huge and diverse community and
    not every one is friendly"
    http://www.ytc1.co.uk


  3. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    Bruce Porter napisaƂ(a):
    > On Mon, 08 May 2006 06:07:36 -0700, e_risha wrote:


    > Must admit, never occured to me to run Solaris under qemu on my Solaris
    > laptop.... hmmmm :-)
    >


    Yes , for example Solaris 7/8/9 in emulator on Solaris 10.


  4. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    i ran the installation once again so that i can find out the exact
    error message i got. here are the steps which i though were important
    in the installation leading up to the error

    after boot from cd
    -selected option 4 solaris interactive text (console)
    in select products
    -solaris documentation
    -solaris software companion

    after that
    -selected "end user system support" package group modifying it a little
    for size
    with the packages i selected it showed the installation size around
    3.5G

    install begins
    at start it shows around 1.3G of packages waiting to be copied
    progress bar reaches between 20 and 40% with around 350Mb copied it
    'installs boot information' and then updates boot_archive then shows
    'install of cd1 complete'

    then shows solaris installation complete and i get a prompt like below
    #
    i shutdown the system using the shutdown command and then reboot
    it shows 'loading smf service descriptions' 89 of them
    after succesfully configuring X.org the following messages are
    displayed

    Starting solaris intall launcher in console mode
    an unexpectd error has been detected by hotspot virtual machine

    SIGSEGV (0xb) at pc=0xd2af09f9, pid=619, tid=8

    Java VM: Java HotSpot(TM) Client VM (1.5.0_06-b05 mixed mode, sharing)
    ..
    ..
    ..
    Abort - core dumped
    The Solaris INstall Launcher has terminated unexpectedly
    press return key and system reboot will take place

    clearly the whole of the 3.5Gb selected during the install hasnt been
    copied.

    hope the info above helps
    thanx


  5. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    On Tue, 09 May 2006 12:43:41 -0700, rishad wrote:

    > i ran the installation once again so that i can find out the exact
    > error message i got. here are the steps which i though were important
    > in the installation leading up to the error
    >
    > after boot from cd
    > -selected option 4 solaris interactive text (console)
    > in select products
    > -solaris documentation
    > -solaris software companion
    >
    > after that
    > -selected "end user system support" package group modifying it a little
    > for size
    > with the packages i selected it showed the installation size around
    > 3.5G
    >
    > install begins
    > at start it shows around 1.3G of packages waiting to be copied
    > progress bar reaches between 20 and 40% with around 350Mb copied it
    > 'installs boot information' and then updates boot_archive then shows
    > 'install of cd1 complete'
    >
    > then shows solaris installation complete and i get a prompt like below
    > #
    > i shutdown the system using the shutdown command and then reboot
    > it shows 'loading smf service descriptions' 89 of them
    > after succesfully configuring X.org the following messages are
    > displayed
    >
    > Starting solaris intall launcher in console mode
    > an unexpectd error has been detected by hotspot virtual machine
    >
    > SIGSEGV (0xb) at pc=0xd2af09f9, pid=619, tid=8
    >
    > Java VM: Java HotSpot(TM) Client VM (1.5.0_06-b05 mixed mode, sharing)
    > .
    > .
    > .
    > Abort - core dumped
    > The Solaris INstall Launcher has terminated unexpectedly
    > press return key and system reboot will take place
    >
    > clearly the whole of the 3.5Gb selected during the install hasnt been
    > copied.
    >
    > hope the info above helps


    You're right, it doesn't sound good.

    Can you try an install from DVD instead ? It may be an issue with the 1st
    CD being corrupt in some way.

    Have you tried a plain install from CD without using Qemu ?

    --
    Bruce

    "The internet is a huge and diverse community and
    not every one is friendly"
    http://www.ytc1.co.uk


  6. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    After some googling around i found atleast one other post of the same
    problem. someone mentioned it might be a sun java issue while running
    in qemu. is there anyway to install solaris without invoking the java
    VM. But i guess the installer itself is java based which would make
    that impossible.

    >Can you try an install from DVD instead ? It may be an issue with the 1st
    >CD being corrupt in some way.


    i dont think the cds might be corrupt coz i downloaded the images using
    the sun download manager which i believe verifies the images during
    download. i verified the cds too after burning them.

    >Have you tried a plain install from CD without using Qemu ?


    Well i think ill do that but the reason i wanted to install in qemu is
    coz i dont want to put the effort of repartitioning my realtively small
    (40G) hard drive which already has a linux and windows installation. i
    just did that a month ago when i removed my freebsd installation and
    put it in qemu. plus im installing to learn solaris. well..maybe ill
    get rid of windows. but if it works on qemu that would be ideal.

    thanx


  7. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    the previous post was from me rishad. i logged in using another
    account. sorry...

    -rishad


  8. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    On Wed, 10 May 2006 02:42:04 -0700, ershaad. wrote:

    > After some googling around i found atleast one other post of the same
    > problem. someone mentioned it might be a sun java issue while running
    > in qemu. is there anyway to install solaris without invoking the java
    > VM. But i guess the installer itself is java based which would make
    > that impossible.


    The reason I suggested using the DVD is because your problem has occured
    after the 1st CD has been copied

    >install begins
    >at start it shows around 1.3G of packages waiting to be copied
    >progress bar reaches between 20 and 40% with around 350Mb copied it
    >'installs boot information' and then updates boot_archive then shows
    >'install of cd1 complete'
    >


    If you use the DVD then it will not reboot and try for a second disk.

    I think it is worth you trying

    >>Can you try an install from DVD instead ? It may be an issue with the 1st
    >>CD being corrupt in some way.

    >
    > i dont think the cds might be corrupt coz i downloaded the images using
    > the sun download manager which i believe verifies the images during
    > download. i verified the cds too after burning them.
    >
    >>Have you tried a plain install from CD without using Qemu ?

    >
    > Well i think ill do that but the reason i wanted to install in qemu is
    > coz i dont want to put the effort of repartitioning my realtively small
    > (40G) hard drive which already has a linux and windows installation. i
    > just did that a month ago when i removed my freebsd installation and
    > put it in qemu. plus im installing to learn solaris. well..maybe ill
    > get rid of windows. but if it works on qemu that would be ideal.
    >
    > thanx


    --
    Bruce

    "The internet is a huge and diverse community and
    not every one is friendly"
    http://www.ytc1.co.uk


  9. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    i think ill try installing it natively without qemu first. i dont have
    access to the dvd right now.

    -rishad


  10. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    ershaad.a@gmail.com writes:

    > After some googling around i found atleast one other post of the same
    > problem. someone mentioned it might be a sun java issue while running
    > in qemu. is there anyway to install solaris without invoking the java
    > VM. But i guess the installer itself is java based which would make
    > that impossible.


    Try to reduce the amount of memory that you allocate for the qemu
    guest OS. If there is less than 512MB (?) of memory available at
    Solaris x86 installation time, a curses based installer will be used
    instead of the java installer. "qemu -m 384 ..." might work well.


    When everything is installed, you can try to run Solaris as a qemu
    guest with more memory allocated for the Solaris guest OS.

  11. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    Juergen Keil wrote:
    >Try to reduce the amount of memory that you allocate for the qemu
    >guest OS. If there is less than 512MB (?) of memory available at
    >Solaris x86 installation time, a curses based installer will be used
    >instead of the java installer. "qemu -m 384 ..." might work well.


    >When everything is installed, you can try to run Solaris as a qemu
    >guest with more memory allocated for the Solaris guest OS.


    Actually i did do that ( since i got 512Mb of physical memory) and the
    installer does mention that there is not enough memory to start the
    graphical installer and continues with the text based installer. but
    the same error pops up in the java VM. like i mentioned in my previous
    post, the error occurs after the first reboot.

    -rishad


  12. Re: solaris 10 1/06 in qemu 0.8.0 runnin on linux

    Its been a while since my post. i procrastinated on repartitioning my
    drive. but it turned out to be a waste of time. i tried installin
    solaris natively on my acer aspire 3002 laptop but it turned out it has
    a lot of hardware incompatibilities. and i dont have the knowledge in
    solaris to fix it. following which i tried intalling solaris using
    VMware-Player. i created an image using qemu. It turns out solaris 10
    01/06 runs fine in VMware-Player on my suse 10 install. so the issue is
    definitely one with qemu 0.8.0. i hope a fix comes soon for that.

    -rishad


+ Reply to Thread