Solaris wont boot from hdd-faqs dont help - Solaris

This is a discussion on Solaris wont boot from hdd-faqs dont help - Solaris ; Hello I've installed solaris 10 on a pc with 3 hdds. I set the first to be the boot hdd, but every time I reboot from the boot cd in the install procedure I get the following: "Can't find PBR" ...

+ Reply to Thread
Results 1 to 9 of 9

Thread: Solaris wont boot from hdd-faqs dont help

  1. Solaris wont boot from hdd-faqs dont help

    Hello

    I've installed solaris 10 on a pc with 3 hdds. I set the first to be the
    boot hdd, but every time I reboot from the boot cd in the install
    procedure I get the following:

    "Can't find PBR"

    I then have to reinsert cd1 and select hdd as the software source, and
    not the cd, so that it will continue with install.

    I've installed it 3 times this way, trying different things.

    I know once finished, the entire solaris os is on the hdd, but it will
    not boot from hdd.

    Several Web sites have explained a few things, but none work.

    To me it sounds like the mbr (or equivalent) is not on the right disk.

    Can someone offer any advice as to what to do next?

    I can boot into single-user mode no problem by booting off the cd and at
    the Select Boot Mode screen (if that's what its called) I type in "b -s".

    From there I can ls to my hearts content. Can I start the CDE from
    here, or do I have to use a different command to boot?

    Any advice would be greatly appreciated, as I've tried everything that
    google returns, with no luck.:-(

  2. Re: Solaris wont boot from hdd-faqs dont help

    GreyCloud wrote:

    > Spidy wrote:
    >
    >> Hello
    >>
    >> I've installed solaris 10 on a pc with 3 hdds. I set the first to be
    >> the boot hdd, but every time I reboot from the boot cd in the install
    >> procedure I get the following:
    >>
    >> "Can't find PBR"
    >>
    >> I then have to reinsert cd1 and select hdd as the software source, and
    >> not the cd, so that it will continue with install.
    >>
    >> I've installed it 3 times this way, trying different things.
    >>
    >> I know once finished, the entire solaris os is on the hdd, but it will
    >> not boot from hdd.
    >>
    >> Several Web sites have explained a few things, but none work.
    >>
    >> To me it sounds like the mbr (or equivalent) is not on the right disk.
    >>
    >> Can someone offer any advice as to what to do next?
    >>
    >> I can boot into single-user mode no problem by booting off the cd and
    >> at the Select Boot Mode screen (if that's what its called) I type in
    >> "b -s".
    >>
    >> From there I can ls to my hearts content. Can I start the CDE from
    >> here, or do I have to use a different command to boot?
    >>
    >> Any advice would be greatly appreciated, as I've tried everything that
    >> google returns, with no luck.:-(

    >
    >
    > During the install, did you come to the hard drive layout section and
    > create a Solaris partition? If not you won't get a bootable hard drive.
    >
    >



    I'm a complete newbie to solaris, but I did make sure I had solaris
    partitions. 1st one was an x86 Boot, then a solaris partition, disk 2
    only has a solaris partition, and disk 3 also has a solaris partition.

    All this was done at setup, how can I check if I have valid partitions
    after setup, ie. by using the cd to boot with b -s, what command will
    display the partitions?

  3. Re: Solaris wont boot from hdd-faqs dont help

    Spidy wrote:
    > GreyCloud wrote:
    >
    >> Spidy wrote:
    >>
    >>> Hello
    >>>
    >>> I've installed solaris 10 on a pc with 3 hdds. I set the first to be
    >>> the boot hdd, but every time I reboot from the boot cd in the install
    >>> procedure I get the following:
    >>>
    >>> "Can't find PBR"
    >>>
    >>> I then have to reinsert cd1 and select hdd as the software source,
    >>> and not the cd, so that it will continue with install.
    >>>
    >>> I've installed it 3 times this way, trying different things.
    >>>
    >>> I know once finished, the entire solaris os is on the hdd, but it
    >>> will not boot from hdd.
    >>>
    >>> Several Web sites have explained a few things, but none work.
    >>>
    >>> To me it sounds like the mbr (or equivalent) is not on the right disk.
    >>>
    >>> Can someone offer any advice as to what to do next?
    >>>
    >>> I can boot into single-user mode no problem by booting off the cd and
    >>> at the Select Boot Mode screen (if that's what its called) I type in
    >>> "b -s".
    >>>
    >>> From there I can ls to my hearts content. Can I start the CDE from
    >>> here, or do I have to use a different command to boot?
    >>>
    >>> Any advice would be greatly appreciated, as I've tried everything
    >>> that google returns, with no luck.:-(

    >>
    >>
    >>
    >> During the install, did you come to the hard drive layout section and
    >> create a Solaris partition? If not you won't get a bootable hard drive.
    >>
    >>

    >
    >
    > I'm a complete newbie to solaris, but I did make sure I had solaris
    > partitions. 1st one was an x86 Boot, then a solaris partition, disk 2
    > only has a solaris partition, and disk 3 also has a solaris partition.
    >

    What type of system and what type of drive?

    Which version of Solaris 10?

    Did you try creating just a Solaris fdisk partition on the first drive?

    --
    Ian Collins.

  4. Re: Solaris wont boot from hdd-faqs dont help

    Ian Collins wrote:

    > Spidy wrote:
    >
    >> GreyCloud wrote:
    >>
    >>> Spidy wrote:
    >>>
    >>>> Hello
    >>>>
    >>>> I've installed solaris 10 on a pc with 3 hdds. I set the first to be
    >>>> the boot hdd, but every time I reboot from the boot cd in the
    >>>> install procedure I get the following:
    >>>>
    >>>> "Can't find PBR"
    >>>>
    >>>> I then have to reinsert cd1 and select hdd as the software source,
    >>>> and not the cd, so that it will continue with install.
    >>>>
    >>>> I've installed it 3 times this way, trying different things.
    >>>>
    >>>> I know once finished, the entire solaris os is on the hdd, but it
    >>>> will not boot from hdd.
    >>>>
    >>>> Several Web sites have explained a few things, but none work.
    >>>>
    >>>> To me it sounds like the mbr (or equivalent) is not on the right disk.
    >>>>
    >>>> Can someone offer any advice as to what to do next?
    >>>>
    >>>> I can boot into single-user mode no problem by booting off the cd
    >>>> and at the Select Boot Mode screen (if that's what its called) I
    >>>> type in "b -s".
    >>>>
    >>>> From there I can ls to my hearts content. Can I start the CDE from
    >>>> here, or do I have to use a different command to boot?
    >>>>
    >>>> Any advice would be greatly appreciated, as I've tried everything
    >>>> that google returns, with no luck.:-(
    >>>
    >>>
    >>>
    >>>
    >>> During the install, did you come to the hard drive layout section and
    >>> create a Solaris partition? If not you won't get a bootable hard drive.
    >>>
    >>>

    >>
    >>
    >> I'm a complete newbie to solaris, but I did make sure I had solaris
    >> partitions. 1st one was an x86 Boot, then a solaris partition, disk 2
    >> only has a solaris partition, and disk 3 also has a solaris partition.
    >>

    > What type of system and what type of drive?
    >
    > Which version of Solaris 10?
    >
    > Did you try creating just a Solaris fdisk partition on the first drive?
    >



    I tried everything.

    Someone suggested I use the 2nd cd to install, bypassing the boot cd.

    I thought that was strange, especially since disk 2 of solaris 10 isn't
    bootable. I found an old version of solaris 8 floating about, and sure
    enough, that worked.

    As soon as I upgraded to solaris 10 however, upon the first reboot, same
    thing.:-(

  5. Re: Solaris wont boot from hdd-faqs dont help

    Spidy wrote:
    >>>
    >>>
    >>> I'm a complete newbie to solaris, but I did make sure I had solaris
    >>> partitions. 1st one was an x86 Boot, then a solaris partition, disk 2
    >>> only has a solaris partition, and disk 3 also has a solaris partition.
    >>>

    >> What type of system and what type of drive?
    >>
    >> Which version of Solaris 10?
    >>
    >> Did you try creating just a Solaris fdisk partition on the first drive?
    >>

    >
    >
    > I tried everything.
    >
    > Someone suggested I use the 2nd cd to install, bypassing the boot cd.
    >

    That's bad advice for Solaris 10.

    > I thought that was strange, especially since disk 2 of solaris 10 isn't
    > bootable. I found an old version of solaris 8 floating about, and sure
    > enough, that worked.
    >
    > As soon as I upgraded to solaris 10 however, upon the first reboot, same
    > thing.:-(


    You still haven't answered my questions.

    --
    Ian Collins.

  6. Re: Solaris wont boot from hdd-faqs dont help

    Spidy wrote:
    > Ian Collins wrote:
    >
    >> Spidy wrote:
    >>
    >>> GreyCloud wrote:
    >>>
    >>>> Spidy wrote:
    >>>>
    >>>>> Hello
    >>>>>
    >>>>> I've installed solaris 10 on a pc with 3 hdds. I set the first to
    >>>>> be the boot hdd, but every time I reboot from the boot cd in the
    >>>>> install procedure I get the following:
    >>>>>
    >>>>> "Can't find PBR"
    >>>>>
    >>>>> I then have to reinsert cd1 and select hdd as the software source,
    >>>>> and not the cd, so that it will continue with install.
    >>>>>
    >>>>> I've installed it 3 times this way, trying different things.
    >>>>>
    >>>>> I know once finished, the entire solaris os is on the hdd, but it
    >>>>> will not boot from hdd.
    >>>>>
    >>>>> Several Web sites have explained a few things, but none work.
    >>>>>
    >>>>> To me it sounds like the mbr (or equivalent) is not on the right disk.
    >>>>>
    >>>>> Can someone offer any advice as to what to do next?
    >>>>>
    >>>>> I can boot into single-user mode no problem by booting off the cd
    >>>>> and at the Select Boot Mode screen (if that's what its called) I
    >>>>> type in "b -s".
    >>>>>
    >>>>> From there I can ls to my hearts content. Can I start the CDE from
    >>>>> here, or do I have to use a different command to boot?
    >>>>>
    >>>>> Any advice would be greatly appreciated, as I've tried everything
    >>>>> that google returns, with no luck.:-(
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> During the install, did you come to the hard drive layout section
    >>>> and create a Solaris partition? If not you won't get a bootable
    >>>> hard drive.
    >>>>
    >>>>
    >>>
    >>>
    >>> I'm a complete newbie to solaris, but I did make sure I had solaris
    >>> partitions. 1st one was an x86 Boot, then a solaris partition, disk 2
    >>> only has a solaris partition, and disk 3 also has a solaris partition.
    >>>

    >> What type of system and what type of drive?
    >>
    >> Which version of Solaris 10?
    >>
    >> Did you try creating just a Solaris fdisk partition on the first drive?
    >>

    >
    >
    > I tried everything.
    >
    > Someone suggested I use the 2nd cd to install, bypassing the boot cd.
    >
    > I thought that was strange, especially since disk 2 of solaris 10 isn't
    > bootable. I found an old version of solaris 8 floating about, and sure
    > enough, that worked.
    >
    > As soon as I upgraded to solaris 10 however, upon the first reboot, same
    > thing.:-(

    It sounds like you're building s Solaris only system.

    What works for me (4 disk system) is the following:

    Install from the first CD to the first disk only!
    Initial install.
    At the select disk screen, pick the first one.
    When it asks for disk layout you want custom if it asks.
    The default layout is not good so:
    1. Delete the /home directory fields (the unused should jump up!)
    2. Change /swap to the smaller of1 GB or double the memory size.
    3. Change the / to the whole disk.
    4. Finish the install.
    Do not create a separate boot partition! This would reposition GRUB
    and move the boot pieces around. You should have a /,swap, and overlap
    partitions only for now. GRUB and the boot pieces will be installed in
    their default places and match the docs...

    After the install is complete, you can add you other drives/filesystems.
    http://www.sun.drydog.com/faq/6.html

    I set up my real /home partition on another disk during this step using
    a modified version of the FAQ. Follow along below...

    Proceed as in the FAQ, but create the entry in vfstab to mount it using
    "newhome" as the mount name, remember to create the mount point first.

    mount the drive, and copy the contents of the current /home to /newboot
    and check/change the permissions to match the original /home.

    Now you can umount /newhome, change the name of /home (keeping the
    contents around for recovery in case you have problems!) to oldhome,
    change the vfstab entry's /newhome to /home, then mount it|all, then
    create your users. After everything is good/tested you can remove the
    oldhome dir.

    You can use the same procedure to move or create other filesystems.

    /var is a special case-you CANNOT follow the same procedure to change it
    on-the-fly. /var has to be mounted at all times. It's better to create a
    separate /var at install time if you know have to have /var in it's own
    filesystem.
    I've moved it before, but only by doing a reboot to mount the new /var
    over the /var, which makes the space of the original /var lost to the
    system. You might be able to do it by just booting the miniroot, or
    booting the install disk again, stopping the install at the disk setup
    (which insures you that all the commands are available to doit are in
    memory), opening a terminal window, and then mounting the boot disk and
    change it's vfstab for the new mount. A /a mount point is there to mount
    to. I haven't read up on the diag or failsafe mode yet... (I've been
    away for a few years!)

    Gary

    Gary

  7. Re: Solaris wont boot from hdd-faqs dont help

    gary drummond wrote:
    > Spidy wrote:
    >> Ian Collins wrote:
    >>
    >>> Spidy wrote:
    >>>
    >>>> GreyCloud wrote:
    >>>>
    >>>>> Spidy wrote:
    >>>>>
    >>>>>> Hello
    >>>>>>
    >>>>>> I've installed solaris 10 on a pc with 3 hdds. I set the first to
    >>>>>> be the boot hdd, but every time I reboot from the boot cd in the
    >>>>>> install procedure I get the following:
    >>>>>>
    >>>>>> "Can't find PBR"
    >>>>>>
    >>>>>> I then have to reinsert cd1 and select hdd as the software source,
    >>>>>> and not the cd, so that it will continue with install.
    >>>>>>
    >>>>>> I've installed it 3 times this way, trying different things.
    >>>>>>
    >>>>>> I know once finished, the entire solaris os is on the hdd, but it
    >>>>>> will not boot from hdd.
    >>>>>>
    >>>>>> Several Web sites have explained a few things, but none work.
    >>>>>>
    >>>>>> To me it sounds like the mbr (or equivalent) is not on the right
    >>>>>> disk.
    >>>>>>
    >>>>>> Can someone offer any advice as to what to do next?
    >>>>>>
    >>>>>> I can boot into single-user mode no problem by booting off the cd
    >>>>>> and at the Select Boot Mode screen (if that's what its called) I
    >>>>>> type in "b -s".
    >>>>>>
    >>>>>> From there I can ls to my hearts content. Can I start the CDE
    >>>>>> from here, or do I have to use a different command to boot?
    >>>>>>
    >>>>>> Any advice would be greatly appreciated, as I've tried everything
    >>>>>> that google returns, with no luck.:-(
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>> During the install, did you come to the hard drive layout section
    >>>>> and create a Solaris partition? If not you won't get a bootable
    >>>>> hard drive.
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>> I'm a complete newbie to solaris, but I did make sure I had solaris
    >>>> partitions. 1st one was an x86 Boot, then a solaris partition, disk
    >>>> 2 only has a solaris partition, and disk 3 also has a solaris
    >>>> partition.
    >>>>
    >>> What type of system and what type of drive?
    >>>
    >>> Which version of Solaris 10?
    >>>
    >>> Did you try creating just a Solaris fdisk partition on the first drive?
    >>>

    >>
    >>
    >> I tried everything.
    >>
    >> Someone suggested I use the 2nd cd to install, bypassing the boot cd.
    >>
    >> I thought that was strange, especially since disk 2 of solaris 10
    >> isn't bootable. I found an old version of solaris 8 floating about,
    >> and sure enough, that worked.
    >>
    >> As soon as I upgraded to solaris 10 however, upon the first reboot,
    >> same thing.:-(

    > It sounds like you're building s Solaris only system.
    >
    > What works for me (4 disk system) is the following:
    >
    > Install from the first CD to the first disk only!
    > Initial install.
    > At the select disk screen, pick the first one.
    > When it asks for disk layout you want custom if it asks.
    > The default layout is not good so:
    > 1. Delete the /home directory fields (the unused should jump up!)
    > 2. Change /swap to the smaller of1 GB or double the memory size.
    > 3. Change the / to the whole disk.
    > 4. Finish the install.
    > Do not create a separate boot partition! This would reposition GRUB and
    > move the boot pieces around. You should have a /,swap, and overlap
    > partitions only for now. GRUB and the boot pieces will be installed in
    > their default places and match the docs...
    >
    > After the install is complete, you can add you other drives/filesystems.
    > http://www.sun.drydog.com/faq/6.html
    >
    > I set up my real /home partition on another disk during this step using
    > a modified version of the FAQ. Follow along below...
    >
    > Proceed as in the FAQ, but create the entry in vfstab to mount it using
    > "newhome" as the mount name, remember to create the mount point first.
    >
    > mount the drive, and copy the contents of the current /home to /newboot
    > and check/change the permissions to match the original /home.
    >
    > Now you can umount /newhome, change the name of /home (keeping the
    > contents around for recovery in case you have problems!) to oldhome,
    > change the vfstab entry's /newhome to /home, then mount it|all, then
    > create your users. After everything is good/tested you can remove the
    > oldhome dir.
    >
    > You can use the same procedure to move or create other filesystems.
    >
    > /var is a special case-you CANNOT follow the same procedure to change it
    > on-the-fly. /var has to be mounted at all times. It's better to create a
    > separate /var at install time if you know have to have /var in it's own
    > filesystem.
    > I've moved it before, but only by doing a reboot to mount the new /var
    > over the /var, which makes the space of the original /var lost to the
    > system. You might be able to do it by just booting the miniroot, or
    > booting the install disk again, stopping the install at the disk setup
    > (which insures you that all the commands are available to doit are in
    > memory), opening a terminal window, and then mounting the boot disk and
    > change it's vfstab for the new mount. A /a mount point is there to mount
    > to. I haven't read up on the diag or failsafe mode yet... (I've been
    > away for a few years!)
    >
    > Gary
    >
    > Gary

    I blew it!
    In #2 I shouldn't have put a "/" on swap.
    "newboot" should have been newhome!

    Also, if the first disk, or the one you want as boot, is a large disk
    (>70GB) you probably can just go with it. You could if you want, make
    the root 60-100GB and leave the rest of the disk unused-reserved for
    future use. My 200GB boot drive had a small /swap, and a /home of
    180GB+ allocated by Sun's default installation setup before I changed
    it! With so much to play with, I made / 80GB, swap, and let the rest of
    the disk be /home which is probably too much!

    /var grows over time with patchs and other things. If it's left in the
    root filesystem it is limited to what's left in the / to grow. If /home
    (or some other directory) grows too big (/ is running out of space) you
    can move it to it's own filesystem like I showed with /home. With a new
    release I set mine up like the previous paragraph. After I find out how
    much things change in size (du command), I can backup to a different
    disk (unused), reformat/fdisk the boot disk and setup separate
    filesystems, and restore to the new structure using several different
    methods.

    Gary

  8. Re: Solaris wont boot from hdd-faqs dont help

    Ian Collins wrote:
    > Spidy wrote:
    >
    >>>>
    >>>>
    >>>> I'm a complete newbie to solaris, but I did make sure I had solaris
    >>>> partitions. 1st one was an x86 Boot, then a solaris partition, disk
    >>>> 2 only has a solaris partition, and disk 3 also has a solaris
    >>>> partition.
    >>>>
    >>> What type of system and what type of drive?
    >>>
    >>> Which version of Solaris 10?
    >>>
    >>> Did you try creating just a Solaris fdisk partition on the first drive?
    >>>

    >>
    >>
    >> I tried everything.
    >>
    >> Someone suggested I use the 2nd cd to install, bypassing the boot cd.
    >>

    > That's bad advice for Solaris 10.
    >
    >> I thought that was strange, especially since disk 2 of solaris 10
    >> isn't bootable. I found an old version of solaris 8 floating about,
    >> and sure enough, that worked.
    >>
    >> As soon as I upgraded to solaris 10 however, upon the first reboot,
    >> same thing.:-(

    >
    >
    > You still haven't answered my questions.
    >

    I don't know what exact version os solaris 10 I have, it came from a
    magazine cd as everytime I tried to download the iso images from Sun,
    winzip kept giving errors on the images, so I bought the magazine instead.

    As far as my system is concerned, it's an old pc of mine, 200MHz MMX cpu
    128 Mg ram Diamond stealth video. I know it's a low spec machine, but
    it's still within the bare minimum.

  9. Re: Solaris wont boot from hdd-faqs dont help

    gary drummond wrote:

    > Spidy wrote:
    >
    >> Ian Collins wrote:
    >>
    >>> Spidy wrote:
    >>>
    >>>> GreyCloud wrote:
    >>>>
    >>>>> Spidy wrote:
    >>>>>
    >>>>>> Hello
    >>>>>>
    >>>>>> I've installed solaris 10 on a pc with 3 hdds. I set the first to
    >>>>>> be the boot hdd, but every time I reboot from the boot cd in the
    >>>>>> install procedure I get the following:
    >>>>>>
    >>>>>> "Can't find PBR"
    >>>>>>
    >>>>>> I then have to reinsert cd1 and select hdd as the software source,
    >>>>>> and not the cd, so that it will continue with install.
    >>>>>>
    >>>>>> I've installed it 3 times this way, trying different things.
    >>>>>>
    >>>>>> I know once finished, the entire solaris os is on the hdd, but it
    >>>>>> will not boot from hdd.
    >>>>>>
    >>>>>> Several Web sites have explained a few things, but none work.
    >>>>>>
    >>>>>> To me it sounds like the mbr (or equivalent) is not on the right
    >>>>>> disk.
    >>>>>>
    >>>>>> Can someone offer any advice as to what to do next?
    >>>>>>
    >>>>>> I can boot into single-user mode no problem by booting off the cd
    >>>>>> and at the Select Boot Mode screen (if that's what its called) I
    >>>>>> type in "b -s".
    >>>>>>
    >>>>>> From there I can ls to my hearts content. Can I start the CDE
    >>>>>> from here, or do I have to use a different command to boot?
    >>>>>>
    >>>>>> Any advice would be greatly appreciated, as I've tried everything
    >>>>>> that google returns, with no luck.:-(
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>> During the install, did you come to the hard drive layout section
    >>>>> and create a Solaris partition? If not you won't get a bootable
    >>>>> hard drive.
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>> I'm a complete newbie to solaris, but I did make sure I had solaris
    >>>> partitions. 1st one was an x86 Boot, then a solaris partition, disk
    >>>> 2 only has a solaris partition, and disk 3 also has a solaris
    >>>> partition.
    >>>>
    >>> What type of system and what type of drive?
    >>>
    >>> Which version of Solaris 10?
    >>>
    >>> Did you try creating just a Solaris fdisk partition on the first drive?
    >>>

    >>
    >>
    >> I tried everything.
    >>
    >> Someone suggested I use the 2nd cd to install, bypassing the boot cd.
    >>
    >> I thought that was strange, especially since disk 2 of solaris 10
    >> isn't bootable. I found an old version of solaris 8 floating about,
    >> and sure enough, that worked.
    >>
    >> As soon as I upgraded to solaris 10 however, upon the first reboot,
    >> same thing.:-(

    >
    > It sounds like you're building s Solaris only system.
    >
    > What works for me (4 disk system) is the following:
    >
    > Install from the first CD to the first disk only!
    > Initial install.
    > At the select disk screen, pick the first one.
    > When it asks for disk layout you want custom if it asks.
    > The default layout is not good so:
    > 1. Delete the /home directory fields (the unused should jump up!)
    > 2. Change /swap to the smaller of1 GB or double the memory size.
    > 3. Change the / to the whole disk.
    > 4. Finish the install.
    > Do not create a separate boot partition! This would reposition GRUB and
    > move the boot pieces around. You should have a /,swap, and overlap
    > partitions only for now. GRUB and the boot pieces will be installed in
    > their default places and match the docs...
    >
    > After the install is complete, you can add you other drives/filesystems.
    > http://www.sun.drydog.com/faq/6.html
    >
    > I set up my real /home partition on another disk during this step using
    > a modified version of the FAQ. Follow along below...
    >
    > Proceed as in the FAQ, but create the entry in vfstab to mount it using
    > "newhome" as the mount name, remember to create the mount point first.
    >
    > mount the drive, and copy the contents of the current /home to /newboot
    > and check/change the permissions to match the original /home.
    >
    > Now you can umount /newhome, change the name of /home (keeping the
    > contents around for recovery in case you have problems!) to oldhome,
    > change the vfstab entry's /newhome to /home, then mount it|all, then
    > create your users. After everything is good/tested you can remove the
    > oldhome dir.
    >
    > You can use the same procedure to move or create other filesystems.
    >
    > /var is a special case-you CANNOT follow the same procedure to change it
    > on-the-fly. /var has to be mounted at all times. It's better to create a
    > separate /var at install time if you know have to have /var in it's own
    > filesystem.
    > I've moved it before, but only by doing a reboot to mount the new /var
    > over the /var, which makes the space of the original /var lost to the
    > system. You might be able to do it by just booting the miniroot, or
    > booting the install disk again, stopping the install at the disk setup
    > (which insures you that all the commands are available to doit are in
    > memory), opening a terminal window, and then mounting the boot disk and
    > change it's vfstab for the new mount. A /a mount point is there to mount
    > to. I haven't read up on the diag or failsafe mode yet... (I've been
    > away for a few years!)
    >
    > Gary
    >
    > Gary


    That's the problem. Installing from the first disk alway errs when it
    come to the point of rebooting the system and continuing to disk 2 of
    the install. I choose the first disk as boot disk, it has an x86 Boot
    partition which is small, and the rest is a Solaris partition.

    But, for some reason, everytime the machine reboots to continue
    installation, it give the following error in the POST "Can't find PBR".

+ Reply to Thread