If you've installed RHEL 5.x 64-bit, you would have experienced a problem when trying to install webstack 1.5


[root@redwood webstack]# ./install apache
sun-apache22-2.2.11-b09.i386.rpm...
sun-apache22-sed-1.0-b09.i386.rpm...
sun-apache22-security2-2.5.9-b09.i386.rpm...
sun-apache22-jk-1.2.27-b09.i386.rpm...
sun-apache22-fcgid-2.2-b09.i386.rpm...
sun-apache22-perl-2.0.2-b09.i386.rpm...
WS011 Installation of package sun-apache22-perl-2.0.2-b09.i386.rpm failed with
Preparing packages for installation...
error: Failed dependencies :
perl >= 5.8.8 is needed by sun-apache22-perl-2.0.2-b09
error: %pre(sun-apache22-perl-2.0.2-b09.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping sun-apache22-perl-2.0.2-b09

[root@redwood webstack]# ./install lighttpd
sun-lighttpd14-1.4.21-b09.i386.rpm...
WS011 Installation of package sun-lighttpd14-1.4.21-b09.i386.rpm failed with
Preparing packages for installation...
error: Failed dependencies :
pcre >= 3.1 is needed by sun-lighttpd-1.4.21-b09
error: %pre(sun-lighttpd14-1.4.21-b09.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping sun-lighttpd14-1.4.21-b09

[root@redwood webstack]# ./install memcached
sun-memcached-1.2.5-b09.i386.rpm...
WS011 Installation of package sun-memcached-1.2.5-b09.i386.rpm failed with
Preparing packages for installation...
error: Failed dependencies :
libevent >= 1.1a is needed by sun-memcached-1.2.5-b09
error: %pre(sun-memcached-1.2.5-b09.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping sun-memcached-1.2.5-b09

What you need to do is to install 32-bit of perl, pcre and libevent









More...