snmpwalk not working on redhat 9 (interface) - SNMP

This is a discussion on snmpwalk not working on redhat 9 (interface) - SNMP ; Hello, I recently upgraded a workstation on my home network from redhat 72 to redhat 9. I have a debian server which polls the other machines for the interface traffic and uses mrtg to graph the data (behind a firewall) ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: snmpwalk not working on redhat 9 (interface)

  1. snmpwalk not working on redhat 9 (interface)

    Hello,

    I recently upgraded a workstation on my home network from redhat 72 to
    redhat 9. I have a debian server which polls the other machines for the
    interface traffic and uses mrtg to graph the data (behind a firewall)
    which I can view with a browser. The redhat 9 machine is running
    net-snmp-5.0.6-17. I can run from the debian server or localhost
    "snmpwalk -v 1 -c public hostname system" and it works fine. When I try
    "snmpwalk -v 1 -c public hostname interface" I get no output and the
    shell returns to the prompt. Or change "interface" to "ip" and again no
    data. Here is part of my snmpd.conf file with all the changes I have made:

    ####
    # First, map the community name "public" into a "security name"

    # sec.name source community
    com2sec notConfigUser default public

    ####
    # Second, map the security name into a group name:

    # groupName securityModel securityName
    group notConfigGroup v1 notConfigUser
    group notConfigGroup v2c notConfigUser

    ####
    # Third, create a view for us to let the group have rights to:

    # Make at least snmpwalk -v 1 localhost -c public system fast again.
    # name incl/excl subtree mask(optional)
    view systemview included .1.3.6.1.2.1.1
    view systemview included .1.3.6.1.2.1.25.1.1

    ####
    # Finally, grant the group read-only access to the systemview view.

    # group context sec.model sec.level prefix read write
    notif
    access notConfigGroup "" any noauth exact systemview
    none none

    #
    -----------------------------------------------------------------------------

    # Here is a commented out example configuration that allows less
    # restrictive access.

    # YOU SHOULD CHANGE THE "COMMUNITY" TOKEN BELOW TO A NEW KEYWORD ONLY
    # KNOWN AT YOUR SITE. YOU *MUST* CHANGE THE NETWORK TOKEN BELOW TO
    # SOMETHING REFLECTING YOUR LOCAL NETWORK ADDRESS SPACE.

    ## sec.name source community
    #com2sec local localhost COMMUNITY
    com2sec mynetwork 192.168.100.0/24 public

    ## group.name sec.model sec.name
    #group MyRWGroup any local
    group MyROGroup any mynetwork
    #
    #group MyRWGroup any otherv3user
    #...

    ## incl/excl subtree mask
    view all included .1 80

    ## -or just the mib2 tree-

    #view mib2 included .iso.org.dod.internet.mgmt.mib-2 fc


    ## context sec.model sec.level prefix read write notif
    access MyROGroup "" any noauth 0 all none none
    #access MyRWGroup "" any noauth 0 all all all

    ################################################## #############################
    # System contact information
    #

    # It is also possible to set the sysContact and sysLocation system
    # variables through the snmpd.conf file:

    syslocation Lab1
    syscontact Root

    # Example output of snmpwalk:
    # % snmpwalk -v 1 localhost -c public system
    # system.sysDescr.0 = "SunOS name sun4c"
    # system.sysObjectID.0 = OID: enterprises.ucdavis.ucdSnmpAgent.sunos4
    # system.sysUpTime.0 = Timeticks: (595637548) 68 days, 22:32:55
    # system.sysContact.0 = "Me "
    # system.sysName.0 = "name"
    # system.sysLocation.0 = "Right here, right now."
    # system.sysServices.0 = 72


    #
    -----------------------------------------------------------------------------
    Any help or comments will be greatly welcomed and appreciated.

    Best regards,

    ################################################## ############################



  2. Re: snmpwalk not working on redhat 9 (interface)

    ral wrote:
    > Hello,
    >
    > I recently upgraded a workstation on my home network from redhat 72 to
    > redhat 9. I have a debian server which polls the other machines for the
    > interface traffic and uses mrtg to graph the data (behind a firewall)
    > which I can view with a browser. The redhat 9 machine is running
    > net-snmp-5.0.6-17. I can run from the debian server or localhost
    > "snmpwalk -v 1 -c public hostname system" and it works fine. When I try
    > "snmpwalk -v 1 -c public hostname interface" I get no output and the
    > shell returns to the prompt. Or change "interface" to "ip" and again no
    > data. Here is part of my snmpd.conf file with all the changes I have made:
    >


    > Any help or comments will be greatly welcomed and appreciated.
    >






    I created a custom snmpd.conf file with snmpconf -g basic_setup [man
    pages -> snmpd.conf].
    All okay now. The interface traffic is being sent to the debian server.
    I guess what confused me is that I have been able to just edit the
    default /etc/snmpd.conf files on 2 platforms with 4 different OS
    versions without any problems . Hopefully I learned something from this
    experience.

    Best regards,





  3. Re: snmpwalk not working on redhat 9 (interface)

    Hi ral,

    I am with the same problem. I am using Centos 5.1.

    How is your snmpd.conf now? can you post it?

    Thanks,
    Anderson

+ Reply to Thread