PoWah Wong wrote:
> I compiled my source code with net-snmp-5.0.9 on FC6 and got the following compile errors.
> Please help to fix them.
>
> gcc -I../include -I../include -I.. -I./.. -I./../snmplib -I. -I. -I./mibgroup -Imibgroup -g -O2 -Dlinux -c snmpd.c -fPIC -DPIC -o .libs/snmpd.lo
> gcc -I../include -I../include -I.. -I./.. -I./../snmplib -I. -I. -I./mibgroup -Imibgroup -g -O2 -Dlinux -c snmpd.c -o snmpd.o >/dev/null 2>&1
> mv -f .libs/snmpd.lo snmpd.lo
> /bin/sh ../libtool --mode=link gcc -g -O2 -Dlinux -o snmpd snmpd.lo -L//lib libnetsnmpagent.la libnetsnmpmibs.la helpers/libnetsnmphelpers.la ../snmplib/libnetsnmp.la -ldl -lcrypto -lelf -lm /usr/local/lib/libsensors.a
> gcc -g -O2 -Dlinux -o .libs/snmpd snmpd.o -L//lib ./.libs/libnetsnmpagent.so ./.libs/libnetsnmpmibs.so helpers/.libs/libnetsnmphelpers.so ../snmplib/.libs/libnetsnmp.so -ldl -lcrypto -lelf -lm /usr/local/lib/libsensors.a -Wl,--rpath -Wl,/usr/local/lib
> /usr/local/lib/libsensors.a(sysfs.ao): In function `sensors_read_one_sysfs_chip':
> (.text+0x2f): undefined reference to `sysfs_get_device_attr'


That looks like a problem with your local installation of libsensors
rather than a net-snmp issue. Is there a good reason why you have your
own libsensors build instead of the one provided by Fedora?


+Thomas

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.p...r_id=100&url=/
_______________________________________________
Net-snmp-users mailing list
Net-snmp-users@lists.sourceforge.net
Please see the following page to unsubscribe or change other options:
https://lists.sourceforge.net/lists/...net-snmp-users