Hi,

I need Your Help,

I'm using net-snmp 5.4.1

I try init my modules by that way:


Init_agent ("Myapp");

Init_mymodule1();
Init_mymodule2();
.......

Init_snmp("Myapp");
....
....
...


While(1)
{
Agent_check_and_process(1);
}

And working fine for me.

But if I try init some new modules in another function later:

Func1()
{
Init_mymodule11();
Init_mymodule12();
..........

}

I get next error :

registering pdu failed: 263!

P.S.
My Modules I register in that way:

Static oid mymodule1_oid[] = {1,.........};
Netsnmp_register_scalar (netsnmp_create_handler_registration (......));

Best Regards,
Leon.

The information in this e-mail transmission contains proprietary and business
sensitive information. Unauthorized interception of this e-mail may constitute
a violation of law. If you are not the intended recipient, you are hereby
notified that any review, dissemination, distribution or duplication of this
communication is strictly prohibited. You are also asked to contact the sender
by reply email and immediately destroy all copies of the original message.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.p...r_id=100&url=/
_______________________________________________
Net-snmp-users mailing list
Net-snmp-users@lists.sourceforge.net
Please see the following page to unsubscribe or change other options:
https://lists.sourceforge.net/lists/...net-snmp-users