I've been trying to configure Net SNMP to compile for a Coldfire processor
running a linux kernel 2.6.10. I'm able to get it to compile and install
without issue but the executables just give me a "bus error" message.

I'm using the following configuration settings:

../configure
CC=/opt/mtwk/usr/local/m68k-linux/gcc-3.4.0-glibc-2.3.2-v4e/bin/m68k-linux-gcc
CFLAGS=-mcfv4e --with-endianness=big
--prefix=/home/jkimble/MCF5484/ltib-mcf547x_8x-20070107/rootfs/usr/local
--host m68k-linux

Running strace ./snmpstatus gives the message:

================================================== ========================
open("/etc/ld.so.preload", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/home/jkimble/MCF5484/ltib-mcf547x_8x-20070107/rootfs/usr/local/lib/libnetsnmp.so.10"
, O_RDONLY) = -1 ENOENT (No such file or directory)
stat64("/home/jkimble/MCF5484/ltib-mcf547x_8x-20070107/rootfs/usr/local/lib",
0xbffff206) =
-1 ENOENT (No such file or directory)
|
|
bus error
================================================== =========================

Which suggests to me that the system is trying to find the lib files in
the directory they're found on my build system not on the host system it's
being run on. Not sure how to correct that. Tried --exec-prefix and
--prefix but didn't seem to help.

Any help/suggestions very much appreciated...




-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.p...r_id=100&url=/
_______________________________________________
Net-snmp-coders mailing list
Net-snmp-coders@lists.sourceforge.net
https://lists.sourceforge.net/lists/...et-snmp-coders