Hello,

I have to use smux to work with quagga's ospfd. Unfortunately I'm
running into problems getting net-snmp 5.4.1 running with smux
support. I've searched the net and found that it's a known problem at
elast as far as others have experienced it, but haven't found a
solution so far.

snmpd was compiled with (only) --with-mib-modules=smux

The following line is in snmpd.conf:

smuxpeer .1.3.6.1.4.1.3317.1.2.5 quagga_ospfd

ospfd does not run when I launch snmpd.

I get this:

[M1> ./snmpd -H 2>&1 | grep smux
/usr/local/share/snmp/snmpd.conf: line 14: Warning: Unknown token: smux.

Otherwise launched without any options yields the following in the
log file:

[M1> cat /var/log/snmpd.log
netsnmp_assert !"registration != duplicate" failed agent_registry.c:535 netsnmp_subtree_load()
netsnmp_assert !"registration != duplicate" failed agent_registry.c:535 netsnmp_subtree_load()
netsnmp_assert !"registration != duplicate" failed agent_registry.c:535 netsnmp_subtree_load()
/usr/local/share/snmp/snmpd.conf: line 14: Warning: Unknown token: smux.
NET-SNMP version 5.4.1

How can I get snmpd to work with smux ? Any help would be greatly
appreciated - thanks.

Al

-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://ad.doubleclick.net/clk;164216...et/marketplace
_______________________________________________
Net-snmp-users mailing list
Net-snmp-users@lists.sourceforge.net
Please see the following page to unsubscribe or change other options:
https://lists.sourceforge.net/lists/...net-snmp-users