on CentOS 4.5 (usually), snmpd won't stay running - SNMP

This is a discussion on on CentOS 4.5 (usually), snmpd won't stay running - SNMP ; I have several CentOS machines at different hosting providers. On all of the CentOS 4.5 machines (but usually not on the CentOS 4.4 ones or the CentOS 5 ones), if I install snmp using yum install -y net-snmp (and it ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: on CentOS 4.5 (usually), snmpd won't stay running

  1. on CentOS 4.5 (usually), snmpd won't stay running

    I have several CentOS machines at different hosting providers. On all of
    the CentOS 4.5 machines (but usually not on the CentOS 4.4 ones or the
    CentOS 5 ones), if I install snmp using
    yum install -y net-snmp

    (and it reports no error), I then try to start the snmpd service, but
    immediately after I start it with no error, the service isn't running any
    more:

    [root@D2585 net-snmp-5.4.1]# service snmpd start
    Starting snmpd: [ OK ]
    [root@D2585 net-snmp-5.4.1]# ps auwx | grep snmp
    root 27400 0.0 0.0 4832 632 pts/0 S+ 17:22 0:00 grep snmp
    [root@D2585 net-snmp-5.4.1]#

    Since this happens consistently across the CentOS 4.5 machines (though
    usually not the 4.4's), and these are both straightforward steps that
    shouldn't cause anything to go wrong, I'm at a loss to explain the
    results. Anybody else not at a loss?

    The only two lines that snmpd writes to /var/log/messages are these two,
    indicating no error:
    Feb 2 17:22:20 D2585 snmpd: snmpd startup succeeded
    Feb 2 17:22:20 D2585 snmpd[27396]: NET-SNMP version 5.1.2

    and similarly there is only one line in this file:
    [root@D2585 net-snmp-5.4.1]# cat /var/log/snmpd.log
    NET-SNMP version 5.1.2

    One person suggested running it under strace, which I did, and got this
    output, of which I didn't understand a word, but you might:
    http://www.peacefire.org/strace-snmpd-output.txt

    -Bennett

    bennett@peacefire.org http://www.peacefire.org
    (425) 497 9002


    -------------------------------------------------------------------------
    This SF.net email is sponsored by: Microsoft
    Defy all challenges. Microsoft(R) Visual Studio 2008.
    http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
    _______________________________________________
    Net-snmp-users mailing list
    Net-snmp-users@lists.sourceforge.net
    Please see the following page to unsubscribe or change other options:
    https://lists.sourceforge.net/lists/...net-snmp-users

  2. Re: on CentOS 4.5 (usually), snmpd won't stay running

    I had exactly the same problem with a bunch of legacy CentOS 4 boxes. I've no clue why snmpd was broken. But here's a fix that worked for me and hopefully will help others.

    I'd previously only had the base (net-snmp) and libs (net-snmp-libs). To fix I installed all the libs and utils. Suspect the devel pkg was the key but can't say for sure which it was. Here is what I've got running now:

    # rpm -qa | grep snmp
    net-snmp-5.1.2-11.el4_6.11.2
    net-snmp-libs-5.1.2-11.el4_6.11.2
    net-snmp-utils-5.1.2-11.el4_6.11.2
    net-snmp-devel-5.1.2-11.el4_6.11.2
    net-snmp-perl-5.1.2-11.el4_6.11.2
    # service start snmpd
    Starting snmpd: [ OK ]
    # service start snmptrapd
    Starting snmptrapd: [ OK ]
    # ps -A | grep snmp
    9480 ? 00:00:00 snmpd
    9515 ? 00:00:00 snmptrapd

    HTH

+ Reply to Thread