--===============1316993968==
Content-Type: multipart/alternative;
boundary="----=_Part_16404_32409702.1200937109894"

------=_Part_16404_32409702.1200937109894
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Thanks, I tried your suggestion, and it turned out that it was working since
the beginning but my mibs values were readable only using the private
community. Do you know how I give read access to public community to my
dinamically loaded module????

Alejandro


On Jan 10, 2008 6:55 PM, Alejandro Islas wrote:

> Hi, I have a problem trying to dinamically load a private mib into
> On 11/01/2008, Alejandro Islas wrote:
> > Hi, I have a problem trying to dinamically load a private mib into
> > NET-SNMP version 5.2.1.2.

>
> > -I used the dlmod token to include both my modules name and the full
> > pathname.
> > However, after re launching the agent, if I used the snmpwalk command I
> > noticed that my mib wasn't loaded and of course if I specifically ask
> > for one of my mib variables,I receive an END OF MIB response.

>
> I'd suggest that you start by compiling your module into the agent
> directly
> (i.e. not using dlmod), and make sure that it works correctly that way
> first.
> Once you've confirmed that the module is working, *then* try via dlmod.
> The same module code should work unchanged, regardless of the
> way the module is loaded.
>
> It's always worth simplifying the framework as much as possible
> when debugging a problem.
>
> Dave


------=_Part_16404_32409702.1200937109894
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Thanks, I tried your suggestion, and it turned out that it was working since the beginning but my mibs values were  readable only using the private community. Do you know how I give read access to public community to  my dinamically loaded module????


Alejandro


On Jan 10, 2008 6:55 PM, Alejandro Islas <alex.islas@gmail.com> wrote:

Hi, I have a problem trying to dinamically load a private mib into

On 11/01/2008, Alejandro Islas <alex.islas@gmail.com> wrote:
> Hi, I have a problem trying to dinamically load a private mib into
>  NET-SNMP version
5.2.1.2.

>  -I used the dlmod token to include both my modules name and the full
>  pathname.
>  However, after re launching the agent, if I used the snmpwalk command I

>  noticed that my mib wasn't loaded and of course if I specifically ask
>  for one of my mib variables,I receive an END OF MIB response.

I'd suggest that you start by compiling your module into the agent directly

(i.e. not using dlmod), and make sure that it works correctly that way first.
Once you've confirmed that the module is working, *then* try via dlmod.
The same module code should work unchanged, regardless of the

way the module is loaded.

It's always worth simplifying the framework as much as possible
when debugging a problem.

Dave




------=_Part_16404_32409702.1200937109894--


--===============1316993968==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
--===============1316993968==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
Net-snmp-coders mailing list
Net-snmp-coders@lists.sourceforge.net
https://lists.sourceforge.net/lists/...et-snmp-coders

--===============1316993968==--