We run 5.4 on many of our servers without problem, however a couple of
our servers are debian, and run 5.2.3.

Is it a known problem that there is a memory leak in 5.2.3 ?

Here you can see it slowly consuming more memory...

srv-17:~# ps aux | grep [s]nmp
snmp 16795 0.0 2.2 7100 4396 ...

# date && ps aux | grep [s]nmp
Mon Nov 19 12:02:57 UTC 2007
snmp 16795 0.0 2.3 7356 4648 ...

srv-17:~# date && ps aux | grep [s]nmp
Mon Nov 19 12:55:56 UTC 2007
snmp 16795 0.0 2.7 8260 5500 ...

srv-17:~# date && ps aux | grep [s]nmp
Mon Nov 19 12:57:23 UTC 2007
snmp 16795 0.0 2.8 8260 5532 ...



config:

# cat /etc/snmp/snmpd.conf
com2sec mgmt x.x.x.x public
group MyROGroup v2c mgmt
view all included .1 80
access MyROGroup "" any noauth exact all none none
agentaddress x.x.x.x
disk /



On a different debian server,...

# ps aux | grep [s]nmp
snmp 32097 0.0 21.1 94764 28060

.... 30 minutes or so ...

# ps aux | grep [s]nmp
snmp 32097 0.0 22.8 96952 30252


Is this perhaps something that should be reported to debian such that
they can backport a fix you guys have done?


--

Ian P. Christian ~ pookey.co.uk

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
Net-snmp-users mailing list
Net-snmp-users@lists.sourceforge.net
Please see the following page to unsubscribe or change other options:
https://lists.sourceforge.net/lists/...net-snmp-users