Re:mib2c - SNMP

This is a discussion on Re:mib2c - SNMP ; --===============1167832405== Content-Type: multipart/alternative; boundary="_a68dcccf-1e73-44e7-a11b-d74b90f3397d_" --_a68dcccf-1e73-44e7-a11b-d74b90f3397d_ Content-Type: text/plain; charset="gb2312" Content-Transfer-Encoding: 8bit >I installed perl and net-snmp how did you install the perl module? in fact,there is a simple way to install the perl module. please try as follows: ../configure --with-perl-modules Best ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Re:mib2c

  1. Re:mib2c

    --===============1167832405==
    Content-Type: multipart/alternative;
    boundary="_a68dcccf-1e73-44e7-a11b-d74b90f3397d_"

    --_a68dcccf-1e73-44e7-a11b-d74b90f3397d_
    Content-Type: text/plain; charset="gb2312"
    Content-Transfer-Encoding: 8bit

    >I installed perl and net-snmp


    how did you install the perl module?

    in fact,there is a simple way to install the perl module.
    please try as follows:

    ../configure --with-perl-modules


    Best wishes

    ------------original message--------------------
    Hi all,
    I installed perl and net-snmp, while doing mib2c for code generation, I got the error like


    # perl mib2c ssg

    ERROR: You don't have the SNMP perl module installed. Please obtain
    this by getting the latest source release of the net-snmp toolkit from
    http://www.net-snmp.org/download/ . Once you download the source and
    unpack it, the perl module is contained in the perl/SNMP directory.
    See the README file there for instructions.

    # pwd
    /usr/local/src/net-snmp-5.3.0.1/local

    # which perl
    /usr/local/bin/perl

    # perl -v
    This is perl, v5.8.8 built for sun4-solaris

    I need to do anything else.
    Pls give me a suggestion.

    Thanks
    Theja.
    __________________________________________________ _______________
    中国十大热门旅游景点
    http://search.msn.com/results.aspx?q...h-CN&form=QBRE
    --_a68dcccf-1e73-44e7-a11b-d74b90f3397d_
    Content-Type: text/html; charset="gb2312"
    Content-Transfer-Encoding: 8bit





    >I installed perl and net-snmp

     

    how did you install the perl module?

     

    in fact,there is a simple way to install the perl module.

    please try as follows:

     

    ./configure --with-perl-modules

     

     

    Best wishes

     

    ------------original message--------------------

    Hi all,

           I installed perl and net-snmp, while doing mib2c for code generation, I got the error like


     


    # perl mib2c ssg


     


    ERROR: You don't have the SNMP perl module installed.  Please obtain


    this by getting the latest source release of the net-snmp toolkit from


    http://www.net-snmp.org/download/ .  Once you download the source and


    unpack it, the perl module is contained in the perl/SNMP directory.


    See the README file there for instructions.


     


    # pwd


    /usr/local/src/net-snmp-5.3.0.1/local


     


    # which perl


    /usr/local/bin/perl


     


    # perl -v


     This is perl, v5.8.8 built for sun4-solaris


     


    I need to do anything else.


    Pls give me a suggestion.


     


    Thanks


    Theja.



    中国十大热门旅游景点 了解更多信息!

    --_a68dcccf-1e73-44e7-a11b-d74b90f3397d_--


    --===============1167832405==
    Content-Type: text/plain; charset="us-ascii"
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Disposition: inline

    -------------------------------------------------------------------------
    This SF.net email is sponsored by DB2 Express
    Download DB2 Express C - the FREE version of DB2 express and take
    control of your XML. No limits. Just data. Click to get it now.
    http://sourceforge.net/powerbar/db2/
    --===============1167832405==
    Content-Type: text/plain; charset="us-ascii"
    MIME-Version: 1.0
    Content-Transfer-Encoding: 7bit
    Content-Disposition: inline

    _______________________________________________
    Net-snmp-users mailing list
    Net-snmp-users@lists.sourceforge.net
    Please see the following page to unsubscribe or change other options:
    https://lists.sourceforge.net/lists/...net-snmp-users

    --===============1167832405==--


  2. Re: mib2c

    Please try by setting the LD_LIBRARY_PATH as follows

    export LD_LIBRARY_PATH=/usr/local/lib

    I solved this problem in fedora core 6 in this way. Hope this will also solve your problem.

    Thanks,
    Maniraj Patri

  3. Re: mib2c

    Quote Originally Posted by Maniraj Patri View Post
    Please try by setting the LD_LIBRARY_PATH as follows

    export LD_LIBRARY_PATH=/usr/local/lib

    I solved this problem in fedora core 6 in this way. Hope this will also solve your problem.

    Thanks,
    Maniraj Patri
    Thanks Maniraj, your solution did work for me.

+ Reply to Thread