--===============1644243530==
Content-Type: multipart/alternative; boundary="0-832032547-1183648912=:6171"
Content-Transfer-Encoding: 8bit

--0-832032547-1183648912=:6171
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

The ".o" and ".lo" files which were not being deleted (for me) were located in the ".../agent/mibgroup/XXX/ directories. I did not look in the ".libs" directory.

I think the reason why I could not get a clean compile is because these ".o" and ".lo" files were never being deleted when I performed a "make clean". As a result, the code was never being recompiled and I was getting a bunch of linking errors along the way.

Anyway, I currently can get a clean compile when doing the following steps:

1) Perform a fresh install of NetSNMP-v5.4
2) Apply the "Makefile.in" patches which Magnus provided so my environment can link properly
3) Use the folowing "./configure" command (which includes the "--disable-shared" option)

./configure \
--prefix=$(BUILDROOT)/usr/local \
--srcdir=$(BUILDROOT)/netsnmp \
--with-default-snmp-version="3" \
--with-sys-contact="contact" \
--with-sys-location="location" \
--with-logfile="$(BUILDROOT)/netsnmp/var/log/snmpd.log" \
--with-persistent-directory="$(BUILDROOT)/netsnmp/var/net-snmp" \
--disable-embedded-perl \
--disable-shared \
--without-perl-modules \
--host=mipsel-uclibc-linux \
--with-cc=$(CC) \
--with-linkcc=$(CC) \
--with-cflags="-x c" \
--with-ldflags="-x none" \
--with-endianness=little;

4) Perform a "make"


David:
I will get the files you have requested .....



Dave Shield wrote: On 05/07/07, Wes Hardaker wrote:
> Are your .o files you are finding being left in the .libs directories?


Hmmm... yes, that does seem to be happening.
Which is odd, because the "clean" target typically looks like:

clean: cleansubdirs $(OTHERCLEANTODOS)
rm -f core ${OBJS} ${LOBJS} .....
rm -rf .libs

Surely that last command should remove these .o files?

Dave

PS: NeedHelp: If this is what you're seeing, then there's no need
to bother with the log files I asked for.



---------------------------------
Be a better Globetrotter. Get better travel answers from someone who knows.
Yahoo! Answers - Check it out.

---------------------------------
Don't be flakey. Get Yahoo! Mail for Mobile and
always stay connected to friends.
--0-832032547-1183648912=:6171
Content-Type: text/html; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

The ".o" and ".lo" files which were not being deleted (for me) were located in the ".../agent/mibgroup/XXX/ directories.   I did not look in the ".libs" directory. 

I think the reason why I could not get a clean compile is because these ".o" and ".lo" files were never being deleted when I performed a "make clean".   As a result, the code was never being recompiled and I was getting a bunch of linking errors along the way.

Anyway, I currently can get a clean compile when doing the following steps:

1) Perform a fresh install of NetSNMP-v5.4
2) Apply the "Makefile.in" patches which Magnus provided so my environment can link properly
3) Use the folowing "./configure" command (which includes the "--disable-shared" option)

   ./configure \
   --prefix=$(BUILDROOT)/usr/local \
   --srcdir=$(BUILDROOT)/netsnmp \
   --with-default-snmp-version="3" \
  
--with-sys-contact="contact" \
   --with-sys-location="location" \
   --with-logfile="$(BUILDROOT)/netsnmp/var/log/snmpd.log" \
   --with-persistent-directory="$(BUILDROOT)/netsnmp/var/net-snmp" \
   --disable-embedded-perl \
   --disable-shared \
   --without-perl-modules \
   --host=mipsel-uclibc-linux \
   --with-cc=$(CC) \
   --with-linkcc=$(CC) \
   --with-cflags="-x c" \
   --with-ldflags="-x none" \
   --with-endianness=little;

4) Perform a "make"


David:
I will get the files you have requested .....



Dave Shield <D.T.Shield@csc.liv.ac.uk> wrote:
On 05/07/07, Wes Hardaker wrote:
> Are your .o files you are
finding being left in the .libs directories?

Hmmm... yes, that does seem to be happening.
Which is odd, because the "clean" target typically looks like:

clean: cleansubdirs $(OTHERCLEANTODOS)
rm -f core ${OBJS} ${LOBJS} .....
rm -rf .libs

Surely that last command should remove these .o files?

Dave

PS: NeedHelp: If this is what you're seeing, then there's no need
to bother with the log files I asked for.



Be a better Globetrotter. Get better travel answers from someone who knows.
Yahoo! Answers - Check it out.




Don't be flakey. Get Yahoo! Mail for Mobile and
always stay connected to friends.
--0-832032547-1183648912=:6171--


--===============1644243530==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
--===============1644243530==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
Net-snmp-coders mailing list
Net-snmp-coders@lists.sourceforge.net
https://lists.sourceforge.net/lists/...et-snmp-coders

--===============1644243530==--