--===============0560032685==
Content-Type: multipart/alternative; boundary="0-510998613-1179854860=:22146"
Content-Transfer-Encoding: 8bit

--0-510998613-1179854860=:22146
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

** using NetSnmp 5.4

I am trying to learn how to use the snmp.conf file to store some settings for my agent.

Here is the "configure" command I am using for install:

../configure \
--prefix=/export/home/rosent1/snmp/usr/local \
--srcdir=/export/home/rosent1/snmp/net-snmp-5.4 \
--enable-embedded-perl \
--enable-shared \
--with-mib-modules="OC-STB-HOST-MIB"



If I set the MIBS environment variable, then I can start the agent and execute a
"snmpwalk" command and all the row information displays fine.

I am trying to get the "snmpwalk" command to work without setting the MIBS environment variable to "ALL". I thought I could simply do any of the following three things to get my MIB loaded, but none of these things work:

1) Try setting the MIBS environment variable to append the specific MIB to load:

export MIBS=+OC-STB-HOST-MIB

2) Try using the "--with-mibs=+OC-STB-HOST-MIB" option in the configure command

3) Add the following line into the "/export/home/rosent1/snmp/usr/local/share/snmp/snmp.conf" file:

mibs +OC-STB-HOST-MIB


Questions:

1) Why do none of these three alternative methods of loading a MIB file work?

2) If I set the MIBS environment variable to be "ALL" again, then everything works fine. What is going on?




---------------------------------
Get the Yahoo! toolbar and be alerted to new email wherever you're surfing.
--0-510998613-1179854860=:22146
Content-Type: text/html; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

** using NetSnmp 5.4

I am trying to learn how to use the snmp.conf file to store some settings for my agent.

Here is the "configure" command I am using for install:

./configure \
   --prefix=/export/home/rosent1/snmp/usr/local \
   --srcdir=/export/home/rosent1/snmp/net-snmp-5.4 \
   --enable-embedded-perl \
   --enable-shared \
   --with-mib-modules="OC-STB-HOST-MIB"



If I set the MIBS environment variable, then I can start the agent and execute a
"snmpwalk" command and all the row information displays fine.

I am trying to get the "snmpwalk" command to work without setting the MIBS environment variable to "ALL".   I thought I could simply do any of the following three things to get my MIB loaded, but none of these things work:

1) Try setting the MIBS environment variable to append the specific MIB to load:

     
export MIBS=+OC-STB-HOST-MIB

2) Try using the "--with-mibs=+OC-STB-HOST-MIB" option in the configure command

3) Add the following line into the "/export/home/rosent1/snmp/usr/local/share/snmp/snmp.conf"   file:

      mibs  +OC-STB-HOST-MIB

      
Questions:

1) Why do none of these three alternative methods of loading a MIB file work?

2) If I set the MIBS environment variable to be "ALL" again, then everything works fine.    What is going on?




Get the Yahoo! toolbar and be alerted to new email wherever you're surfing.
--0-510998613-1179854860=:22146--


--===============0560032685==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
--===============0560032685==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
Net-snmp-coders mailing list
Net-snmp-coders@lists.sourceforge.net
https://lists.sourceforge.net/lists/...et-snmp-coders

--===============0560032685==--