Wes Hardaker wrote:
> Update of /cvsroot/net-snmp/net-snmp
> In directory sc8-pr-cvs7.sourceforge.net:/tmp/cvs-serv29848
>
> Modified Files:
> configure configure.in acconfig.h
> Log Message:
> make configure bail when embedded perl function can not be found ; fix the fact that 3 functions are needed not 2 and work around autoconf upper-case only defines that causes the existing broken-perl problem; NEWS - perl: fix the 'broken perl' issue with embedded perl


You seem to have introduced an additional check not mentioned here (but
we talked about it earlier in another thread). Here's what I currently
get for my nightly build on Linux:

configure: error: Perl was compiled with cc but you are using gcc which
likely will not work for embedded perl support.

Now, please note that people will get this error for a default build
(plain "./configure --with-defaults") on e.g. SuSE Linux 10.1! Just the
fact that Perl's compiler ("perl -V:cc" says cc='cc') is/was *named*
differently (at Perl compile time) than configure's default choice
("gcc") shouldn't break our build per se. These are still the same
compilers (GNU cc)! We need a more sophisticated test that really checks
whether both compilers are of the same "type" (especially GNU vs. non-GNU).


+Thomas

--
Thomas Anders (thomas.anders at blue-cable.de)

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=...057&dat=121642
_______________________________________________
Net-snmp-coders mailing list
Net-snmp-coders@lists.sourceforge.net
https://lists.sourceforge.net/lists/...et-snmp-coders