Win98 and lunux samba server - SMB

This is a discussion on Win98 and lunux samba server - SMB ; I have a problem when I try to log in from a Win 98 system to a samba Server. If I log is as Root I can Map the drive's on the samba server And everything works well. But if ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Win98 and lunux samba server

  1. Win98 and lunux samba server

    I have a problem when I try to log in from a Win 98 system to a samba
    Server.
    If I log is as Root I can Map the drive's on the samba server
    And everything works well. But if I try to log in with a user account
    That I made on the server, I try to map the drives and I get a message
    that I have to put a password. When I put a password it still
    don't log in it give's me another message that my password is
    incorrect.
    How can this be :S

    Root woks other users don't!!!!!!!

    Someone please help me fix this problem.

    Thx people


  2. Re: Win98 and lunux samba server

    jowyboy@gmail.com wrote:

    >I have a problem when I try to log in from a Win 98 system to a samba
    >Server.
    >If I log is as Root I can Map the drive's on the samba server
    >And everything works well. But if I try to log in with a user account
    >That I made on the server, I try to map the drives and I get a message
    >that I have to put a password. When I put a password it still
    >don't log in it give's me another message that my password is
    >incorrect.
    >How can this be :S
    >
    >Root woks other users don't!!!!!!!
    >
    >Someone please help me fix this problem.
    >
    >Thx people



    have you added the users to samba?

    http://www.samba.netfirms.com/addusers.htm


    keith
    >



  3. Re: Win98 and lunux samba server

    Yes I aded the users on the samba Server.

    When i log in with the same user on a XP system evrything works thats
    why i dont get it why it dus not work on the 98 system.


  4. Re: Win98 and lunux samba server

    jowyboy@gmail.com wrote:
    > Yes I aded the users on the samba Server.
    >
    > When i log in with the same user on a XP system evrything works thats
    > why i dont get it why it dus not work on the 98 system.
    >

    I am not 100% sure, but you can proof it by yourself .

    Afaik the XP works with encrypted passwords, while win98 does not.
    Very likely your samba is configured with encrypted passwords = yes
    (should be default as well).
    You could switch the configuration to encrypted passwords = no, but you
    have then adjust your XP to provide samba with the plaintext password.
    Required registry entries are delivered with the samba package. Also you
    may have a look at the registry entry "sign or seal".


    --


    Gruss

    Robert

  5. Re: Win98 and lunux samba server

    I tested that all ready and When i Log in on the Win98 system with the
    Root account it works that's wy i dont getit why it dont work! with
    another account ( user account )


  6. Re: Win98 and lunux samba server

    That is bollox. The original version of Win95 came without password
    encryption, but Win95b already had it. I seem to remember that the
    algorithm used is different to the NT/W2K/XP one, but Samba handles
    both. The web page http://home.arcor.de/36bit/samba.html#4.1 is rather
    ancient, but so is what you are using so it should help.

    If all else fails, try setting the debug level to 2 or 3 and see what
    the messages are.


  7. Re: Win98 and lunux samba server

    Wel Thanx You all and Vlad_inhaler ure solution helpt me Really Thx


+ Reply to Thread