Cannot connect to SMB PDC - SMB

This is a discussion on Cannot connect to SMB PDC - SMB ; Hi. I've been reading through most material I can find and have little luck fixing my problem. In my case: Domain: valhala samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) - 192.168.1.88 XP Pro machine: thor Unfortunately, I cannot ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Cannot connect to SMB PDC

  1. Cannot connect to SMB PDC

    Hi. I've been reading through most material I can find and have little luck
    fixing my problem.
    In my case:
    Domain: valhala
    samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) - 192.168.1.88
    XP Pro machine: thor

    Unfortunately, I cannot get thor to log into the domain. Thor can "see" the
    shares and I can swap files etc. when working in "workgroup mode".
    I cannot get it to join the domain when I change the name/domain. I get the
    message:
    "A DOMAIN controller for Valhala could not be contacted".
    I tried to keep things simple and use smbpass and am including my smb.conf.
    I believe I set up the machine accounts and mapped accounts correctly.

    Please help, as I've been toiling with this for some time now.
    [global]
    workgroup = VALHALA
    server string = %h on VALHALA
    netbios name = LOKI
    hosts allow = 192.168.1., 127.
    security = user
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    passwd program = /usr/bin/passwd %u
    local master = yes
    map to guest = Bad User
    username map = /etc/samba/smbusers
    printcap cache time = 750
    printcap name = cups
    add machine script = /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s
    /bin/false %m\$
    add user script = /usr/sbin/useradd -m %u
    delete user script = /usr/sbin/userdel -r %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    add user to group script = /usr/sbin/usermod -C %g %u
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    domain logons = Yes
    os level = 65
    preferred master = Yes
    domain master = Yes
    wins support = Yes
    comment = LOKIDOMAIN
    printer admin = @ntadmin, root, administrator
    cups options = raw
    include = /etc/samba/dhcp.conf
    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    inherit acls = Yes
    browseable = No
    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    create mask = 0640
    directory mask = 0700
    store dos attributes = Yes
    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    create mode = 0664
    directory mode = 0775
    [pdf]
    comment = PDF creator
    path = /var/tmp
    create mask = 0600
    printable = Yes
    print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z
    [printers]
    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    browseable = Yes
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin, root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
    [download]
    comment = Download on Loki
    path = /windows/D/Download/
    read only = No
    [music]
    comment = Music on Loki
    path = /windows/C/Inetpub/wwwroot/Music
    write list = kurt
    guest ok = Yes
    [netlogon]
    comment = Network Logon Service
    path = /var/lib/samba/netlogon
    admin users = root, kurt
    guest ok = Yes
    browseable = No



  2. Re: Cannot connect to SMB PDC


    "Kurt M Peters" wrote in message
    news:19xGd.2222$ef6.1468@trnddc07...
    > Hi. I've been reading through most material I can find and have little
    > luck fixing my problem.
    > In my case:
    > Domain: valhala
    > samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) -
    > 192.168.1.88
    > XP Pro machine: thor
    >
    > Unfortunately, I cannot get thor to log into the domain. Thor can "see"
    > the shares and I can swap files etc. when working in "workgroup mode".
    > I cannot get it to join the domain when I change the name/domain. I get
    > the message:
    > "A DOMAIN controller for Valhala could not be contacted".
    > I tried to keep things simple and use smbpass and am including my
    > smb.conf. I believe I set up the machine accounts and mapped accounts
    > correctly.
    >


    I read somewhere that the workgroup name shouldn't be the same as the domain
    name before you try to join although I've not had troube with this. I also
    found that if I use any of the domain resources before I try the join, it
    fails. So change the workgroup name of the XP system to something different
    (ie: WORKGROUP), restart and try the join right away.

    It that don't work, there may be a problem with your add machine script. Try
    it manually. Comment out the add machine script, restart Samba, add the
    machine account from the command line and try the join again.

    /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s /bin/false -d
    /dev/null thor$

    Be sure that the group "nogroup" exists and that the name has a "$"
    appended. Then try the join.

    If this works, you can debug the add machine script at your leisure.



  3. Re: Cannot connect to SMB PDC

    Thanks for the response, but I don't think that was the problem, as things
    still don't work to make it a PDC.

    I was going from the workgroup (on the winXP machine) of NORSE to domain
    name VALHALA.
    Is there an "easy" way to see if I have the group "NOGROUP"? I checked in
    the /etc/group file and it was listed there.

    this is the error message I got after commenting all of the "automatic"
    lines of add and delete in my smb.conf file and retrying to connect again:
    :::::::::::::::::::::::::::::::::::::::::::::::::: :::
    The domain name valhala might be a NetBIOS domain name. If this is the
    case, verify that the domain name is properly registered with WINS.

    If you are certain that the name is not a NetBIOS domain name, then the
    following information can help you troubleshoot your DNS configuration.

    The following error occurred when DNS was queried for the service location
    (SRV) resource record used to locate a domain controller for domain valhala:

    The error was: "DNS name does not exist."
    (error code 0x0000232B RCODE_NAME_ERROR)

    The query was for the SRV record for _ldap._tcp.dc._msdcs.valhala

    Common causes of this error include the following:

    - The DNS SRV record is not registered in DNS.

    - One or more of the following zones do not include delegation to its child
    zone:

    valhala
    .. (the root zone)

    For information about correcting this problem, click Help.
    :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    When I use PDBEDIT -L, I get my user names:
    root:0:root
    kurt:1000:kurt
    THOR$:1003:
    LOKI$:1006:

    Those names also seem properly in my passwd file in etc/passwd.

    Any other hints?


    "m.marien" wrote in message
    news:10v8ks3k7u21019@corp.supernews.com...
    >
    > "Kurt M Peters" wrote in message
    > news:19xGd.2222$ef6.1468@trnddc07...
    >> Hi. I've been reading through most material I can find and have little
    >> luck fixing my problem.
    >> In my case:
    >> Domain: valhala
    >> samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) -
    >> 192.168.1.88
    >> XP Pro machine: thor
    >>
    >> Unfortunately, I cannot get thor to log into the domain. Thor can "see"
    >> the shares and I can swap files etc. when working in "workgroup mode".
    >> I cannot get it to join the domain when I change the name/domain. I get
    >> the message:
    >> "A DOMAIN controller for Valhala could not be contacted".
    >> I tried to keep things simple and use smbpass and am including my
    >> smb.conf. I believe I set up the machine accounts and mapped accounts
    >> correctly.
    >>

    >
    > I read somewhere that the workgroup name shouldn't be the same as the
    > domain name before you try to join although I've not had troube with this.
    > I also found that if I use any of the domain resources before I try the
    > join, it fails. So change the workgroup name of the XP system to something
    > different (ie: WORKGROUP), restart and try the join right away.
    >
    > It that don't work, there may be a problem with your add machine script.
    > Try it manually. Comment out the add machine script, restart Samba, add
    > the machine account from the command line and try the join again.
    >
    > /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s /bin/false -d
    > /dev/null thor$
    >
    > Be sure that the group "nogroup" exists and that the name has a "$"
    > appended. Then try the join.
    >
    > If this works, you can debug the add machine script at your leisure.
    >
    >




  4. Re: Cannot connect to SMB PDC

    Whenever I've had this type of problem, it's usually related to not using a
    WINS server. You need a WINS server, which can be a separate machine, or you
    can use Samba by setting "wins support = yes". Then, on the client, you also
    need to point it to the WINS server via the TCP/IP parameters of the network
    connection.

    "Kurt M Peters" wrote in message
    news:nPDJd.29155$Os6.27982@trnddc08...
    > Thanks for the response, but I don't think that was the problem, as things
    > still don't work to make it a PDC.
    >
    > I was going from the workgroup (on the winXP machine) of NORSE to domain
    > name VALHALA.
    > Is there an "easy" way to see if I have the group "NOGROUP"? I checked in
    > the /etc/group file and it was listed there.
    >
    > this is the error message I got after commenting all of the "automatic"
    > lines of add and delete in my smb.conf file and retrying to connect again:
    > :::::::::::::::::::::::::::::::::::::::::::::::::: :::
    > The domain name valhala might be a NetBIOS domain name. If this is the
    > case, verify that the domain name is properly registered with WINS.
    >
    > If you are certain that the name is not a NetBIOS domain name, then the
    > following information can help you troubleshoot your DNS configuration.
    >
    > The following error occurred when DNS was queried for the service location
    > (SRV) resource record used to locate a domain controller for domain
    > valhala:
    >
    > The error was: "DNS name does not exist."
    > (error code 0x0000232B RCODE_NAME_ERROR)
    >
    > The query was for the SRV record for _ldap._tcp.dc._msdcs.valhala
    >
    > Common causes of this error include the following:
    >
    > - The DNS SRV record is not registered in DNS.
    >
    > - One or more of the following zones do not include delegation to its
    > child zone:
    >
    > valhala
    > . (the root zone)
    >
    > For information about correcting this problem, click Help.
    > :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    > When I use PDBEDIT -L, I get my user names:
    > root:0:root
    > kurt:1000:kurt
    > THOR$:1003:
    > LOKI$:1006:
    >
    > Those names also seem properly in my passwd file in etc/passwd.
    >
    > Any other hints?
    >
    >
    > "m.marien" wrote in message
    > news:10v8ks3k7u21019@corp.supernews.com...
    >>
    >> "Kurt M Peters" wrote in message
    >> news:19xGd.2222$ef6.1468@trnddc07...
    >>> Hi. I've been reading through most material I can find and have little
    >>> luck fixing my problem.
    >>> In my case:
    >>> Domain: valhala
    >>> samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) -
    >>> 192.168.1.88
    >>> XP Pro machine: thor
    >>>
    >>> Unfortunately, I cannot get thor to log into the domain. Thor can "see"
    >>> the shares and I can swap files etc. when working in "workgroup mode".
    >>> I cannot get it to join the domain when I change the name/domain. I get
    >>> the message:
    >>> "A DOMAIN controller for Valhala could not be contacted".
    >>> I tried to keep things simple and use smbpass and am including my
    >>> smb.conf. I believe I set up the machine accounts and mapped accounts
    >>> correctly.
    >>>

    >>
    >> I read somewhere that the workgroup name shouldn't be the same as the
    >> domain name before you try to join although I've not had troube with
    >> this. I also found that if I use any of the domain resources before I try
    >> the join, it fails. So change the workgroup name of the XP system to
    >> something different (ie: WORKGROUP), restart and try the join right away.
    >>
    >> It that don't work, there may be a problem with your add machine script.
    >> Try it manually. Comment out the add machine script, restart Samba, add
    >> the machine account from the command line and try the join again.
    >>
    >> /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s /bin/false -d
    >> /dev/null thor$
    >>
    >> Be sure that the group "nogroup" exists and that the name has a "$"
    >> appended. Then try the join.
    >>
    >> If this works, you can debug the add machine script at your leisure.
    >>
    >>

    >
    >




  5. Re: Cannot connect to SMB PDC

    In the first message, I show that wins support = yes. I also made sure my
    "WINS order" in the advanced button had the "LOKI" IP address.
    Do you know how to check to make sure the appropriate ports are open in
    the Suse 9.2 Firewall? I'm pretty sure they are, but just in case, what
    ports should be open, as well?


    Kurt
    "punk-tilous" wrote in message
    news:mM8Kd.6742$Uz6.6456@news.cpqcorp.net...
    > Whenever I've had this type of problem, it's usually related to not using
    > a WINS server. You need a WINS server, which can be a separate machine, or
    > you can use Samba by setting "wins support = yes". Then, on the client,
    > you also need to point it to the WINS server via the TCP/IP parameters of
    > the network connection.
    >
    > "Kurt M Peters" wrote in message
    > news:nPDJd.29155$Os6.27982@trnddc08...
    >> Thanks for the response, but I don't think that was the problem, as
    >> things still don't work to make it a PDC.
    >>
    >> I was going from the workgroup (on the winXP machine) of NORSE to domain
    >> name VALHALA.
    >> Is there an "easy" way to see if I have the group "NOGROUP"? I checked in
    >> the /etc/group file and it was listed there.
    >>
    >> this is the error message I got after commenting all of the "automatic"
    >> lines of add and delete in my smb.conf file and retrying to connect
    >> again:
    >> :::::::::::::::::::::::::::::::::::::::::::::::::: :::
    >> The domain name valhala might be a NetBIOS domain name. If this is the
    >> case, verify that the domain name is properly registered with WINS.
    >>
    >> If you are certain that the name is not a NetBIOS domain name, then the
    >> following information can help you troubleshoot your DNS configuration.
    >>
    >> The following error occurred when DNS was queried for the service
    >> location (SRV) resource record used to locate a domain controller for
    >> domain valhala:
    >>
    >> The error was: "DNS name does not exist."
    >> (error code 0x0000232B RCODE_NAME_ERROR)
    >>
    >> The query was for the SRV record for _ldap._tcp.dc._msdcs.valhala
    >>
    >> Common causes of this error include the following:
    >>
    >> - The DNS SRV record is not registered in DNS.
    >>
    >> - One or more of the following zones do not include delegation to its
    >> child zone:
    >>
    >> valhala
    >> . (the root zone)
    >>
    >> For information about correcting this problem, click Help.
    >> :::::::::::::::::::::::::::::::::::::::::::::::::: ::::::::::::
    >> When I use PDBEDIT -L, I get my user names:
    >> root:0:root
    >> kurt:1000:kurt
    >> THOR$:1003:
    >> LOKI$:1006:
    >>
    >> Those names also seem properly in my passwd file in etc/passwd.
    >>
    >> Any other hints?
    >>
    >>
    >> "m.marien" wrote in message
    >> news:10v8ks3k7u21019@corp.supernews.com...
    >>>
    >>> "Kurt M Peters" wrote in message
    >>> news:19xGd.2222$ef6.1468@trnddc07...
    >>>> Hi. I've been reading through most material I can find and have little
    >>>> luck fixing my problem.
    >>>> In my case:
    >>>> Domain: valhala
    >>>> samba (PDC) machine: loki (Suse 9.2 smbclient ver 3.0.9-2.1) -
    >>>> 192.168.1.88
    >>>> XP Pro machine: thor
    >>>>
    >>>> Unfortunately, I cannot get thor to log into the domain. Thor can
    >>>> "see" the shares and I can swap files etc. when working in "workgroup
    >>>> mode".
    >>>> I cannot get it to join the domain when I change the name/domain. I get
    >>>> the message:
    >>>> "A DOMAIN controller for Valhala could not be contacted".
    >>>> I tried to keep things simple and use smbpass and am including my
    >>>> smb.conf. I believe I set up the machine accounts and mapped accounts
    >>>> correctly.
    >>>>
    >>>
    >>> I read somewhere that the workgroup name shouldn't be the same as the
    >>> domain name before you try to join although I've not had troube with
    >>> this. I also found that if I use any of the domain resources before I
    >>> try the join, it fails. So change the workgroup name of the XP system to
    >>> something different (ie: WORKGROUP), restart and try the join right
    >>> away.
    >>>
    >>> It that don't work, there may be a problem with your add machine script.
    >>> Try it manually. Comment out the add machine script, restart Samba, add
    >>> the machine account from the command line and try the join again.
    >>>
    >>> /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s /bin/false -d
    >>> /dev/null thor$
    >>>
    >>> Be sure that the group "nogroup" exists and that the name has a "$"
    >>> appended. Then try the join.
    >>>
    >>> If this works, you can debug the add machine script at your leisure.
    >>>
    >>>

    >>
    >>

    >
    >




  6. Re: Cannot connect to SMB PDC


    t@msn.com wrote:
    > >>>> "A DOMAIN controller for Valhala could not be contacted".
    > >>>> I tried to keep things simple and use smbpass and am including my
    > >>>> smb.conf. I believe I set up the machine accounts and mapped accounts
    > >>>> correctly.
    > >>>>
    > >>>
    > >>> I read somewhere that the workgroup name shouldn't be the same as the
    > >>> domain name before you try to join although I've not had troube with
    > >>> this. I also found that if I use any of the domain resources before I
    > >>> try the join, it fails. So change the workgroup name of the XP system to
    > >>> something different (ie: WORKGROUP), restart and try the join right
    > >>> away.
    > >>>
    > >>> It that don't work, there may be a problem with your add machine script.
    > >>> Try it manually. Comment out the add machine script, restart Samba, add
    > >>> the machine account from the command line and try the join again.
    > >>>
    > >>> /usr/sbin/useradd -g nogroup -c "NT Machine Account" -s /bin/false -d
    > >>> /dev/null thor$
    > >>>
    > >>> Be sure that the group "nogroup" exists and that the name has a "$"
    > >>> appended. Then try the join.
    > >>>
    > >>> If this works, you can debug the add machine script at your leisure.
    > >>>
    > >>>
    > >>
    > >>

    > >
    > >


    Thanks!

    amado_smith@skyeggo.com


+ Reply to Thread