SMBCLIENT to XP = GOOD, NAUTILUS TO XP = BAD - SMB

This is a discussion on SMBCLIENT to XP = GOOD, NAUTILUS TO XP = BAD - SMB ; I'm using Red Hat 9, Gnome 2.2.1, samba 2.2.7a.-7.9.0 If I use smbclient to connect to the XP machine, no problems. I can 'get' files and put. No problems. When I try to use Nautilus to connect to XP: smb:\\\ ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: SMBCLIENT to XP = GOOD, NAUTILUS TO XP = BAD

  1. SMBCLIENT to XP = GOOD, NAUTILUS TO XP = BAD

    I'm using Red Hat 9, Gnome 2.2.1, samba 2.2.7a.-7.9.0

    If I use smbclient to connect to the XP machine, no problems. I can
    'get' files and put. No problems.

    When I try to use Nautilus to connect to XP: smb:\\\\ directory>

    I either get the message "You do not have the permissions necessary to
    view the contents of ".

    or, I see the files but cannot copy files to or from XP.

    I have an account on Redhat with the same name as on XP. The XP
    account is an Admin account. SMBUSERS file is in sync with the user
    names between Linux and XP. In addition, the directory and file
    permissions on XP are set to allow this account full access on XP.

    From XP to Linux, no problems. I can map drives.

    There's probably more information needed, but if any of you have
    experienced this or similar, your help would be appreciated.

    Thanks,

    Ed

  2. Re: SMBCLIENT to XP = GOOD, NAUTILUS TO XP = BAD

    I failed to mention that I can only connect to XP via the IP. I cannot
    use the Netbios name for either smbclient or Nautilus. When
    connectiing via a Nautilus window, I can use the IP, then it asks for
    login credentials to the XP machine, then I'm presented a window of
    file which I cannot copy to Linux. It simply keeps asking me to logon,
    then after a couple of logins, nothing. No copy, no "you're not
    authorized" message, nothing. Maddening!

    I've had a Suse 9 installation, what do they do right?

    Thanks,

    Ed

    On Wed, 05 May 2004 06:31:00 GMT, forte agent
    wrote:

    >I'm using Red Hat 9, Gnome 2.2.1, samba 2.2.7a.-7.9.0
    >
    >If I use smbclient to connect to the XP machine, no problems. I can
    >'get' files and put. No problems.
    >
    >When I try to use Nautilus to connect to XP: smb:\\\\ >directory>
    >
    >I either get the message "You do not have the permissions necessary to
    >view the contents of ".
    >
    >or, I see the files but cannot copy files to or from XP.
    >
    >I have an account on Redhat with the same name as on XP. The XP
    >account is an Admin account. SMBUSERS file is in sync with the user
    >names between Linux and XP. In addition, the directory and file
    >permissions on XP are set to allow this account full access on XP.
    >
    >From XP to Linux, no problems. I can map drives.
    >
    >There's probably more information needed, but if any of you have
    >experienced this or similar, your help would be appreciated.
    >
    >Thanks,
    >
    >Ed



+ Reply to Thread