netbrain@netbrain:~$ smbclient -U netbrain //192.168.0.1/
Password:
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

as you can see im having som difficulties connecting with linux to samba
3.0 server running PDC. alltough the win2k machines can connect quite easy.

#at the bottom you can find my somewhat messed up smb.conf#

so when im trying to run cupsaddsmb -a then offcourse this isn't working
cuz, i get the NT_STATUS_BAD_NETWORK_NAME error which i don't really know
what mean.

so is there anybody out there having the same problem or knows anything
about this issue. then help is REALLY appriciated!.

thanks again.

[global]
netbios name = NETWEB
workgroup = DEBIAN
passdb backend = tdbsam
os level = 33
preferred master = yes
domain master = yes
local master = yes
security = user
domain logons = yes
logon path = \\%L\profiles\%U
logon drive = H:
logon home = \\%L\%U
logon script = logon.cmd
log level = 2

add user script = /usr/sbin/useradd -d /home/%u -g 201 -c "Domain Account
%u" -m %u

add machine script = /usr/sbin/useradd -g 201 -d /dev/null -c "Domain
Machine Trust Account %m" -s /bin/false %m$ && \
/usr/bin/passwd -l %m$ && \
/usr/bin/smbpasswd -a -m %m

printing = cups
printcap = cups
pam password change = yes
unix password sync = yes

[NETLOGON]
path = /var/lib/samba/netlogon
read only = yes
write list = @admins
browsable = no

[profiles]
path = /var/lib/samba/profiles
read only = no
create mask = 0600
directory mask = 0700
browsable = no

[homes]
comment = home directories
read only = No
create mask = 0750
browseable = no
volume = HOME

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /etc/samba/drivers
guest ok = Yes