Samba and XPPro - SMB

This is a discussion on Samba and XPPro - SMB ; Hi, I am having a problem connecting my WinXPPro clients to my Samba logon server. I can logon locally to the XP machines, and when I open the samba fileserver, it requests a password and then i can see the ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Samba and XPPro

  1. Samba and XPPro

    Hi,
    I am having a problem connecting my WinXPPro clients to my Samba logon
    server.
    I can logon locally to the XP machines, and when I open the samba
    fileserver, it requests a password and then i can see the correct shares.
    When I try to logon to the domain, I get a message either saying...DOMAIN is
    not available...or cannot connect to DOMAIN.
    Here is a copy of the smb.conf
    Hope someone can help..ive been trying to figure this out for a week or so

    # Global parameters
    [global]
    workgroup = DOMAIN
    Netbios name = logonserver
    encrypt passwords = Yes
    ; this tells Samba that security level must be set to user
    security = user

    ;Samba is the domain and local master browser.
    os level = 65
    preferred master = yes
    domain master = yes
    local master = yes

    logon path =
    logon script = logon.bat
    logon drive = h:
    logon home = \\logonserver\%u

    ;neccessary share for domain controller
    [netlogon]
    ; comment = Network Logon Service
    path = /home/samba/netlogon
    guest ok = yes
    writable = no
    share modes = no

    [homes]
    read only = no
    browseable = no

    [Shared]
    path = /home/shared
    browseable = yes
    read only = no



  2. Re: Samba and XPPro

    In article , "Dean M \(SkyNet
    \)" says...
    > Hi,
    > I am having a problem connecting my WinXPPro clients to my Samba logon
    > server.
    > I can logon locally to the XP machines, and when I open the samba
    > fileserver, it requests a password and then i can see the correct shares.
    > When I try to logon to the domain, I get a message either saying...DOMAIN is
    > not available...or cannot connect to DOMAIN.
    > Here is a copy of the smb.conf
    > Hope someone can help..ive been trying to figure this out for a week or so

    Have you appled the signorseal patch to the XP pc??

    If not there is a link to the patch here on my web site
    http://www.samba.netfirms.com/faq.htm
    --
    Regards,
    Mark

    Samba Setup Guide: www.samba.netfirms.com
    My gpg public key: www.samba.netfirms.com/gnupg/gpg_public.asc

  3. Re: Samba and XPPro

    Yep, have requiresigorseal set to 0




    "Mark" wrote in message
    news:MPG.1a119ef03e63fbf098977a@192.168.0.203...
    > In article , "Dean M \(SkyNet
    > \)" says...
    > > Hi,
    > > I am having a problem connecting my WinXPPro clients to my Samba logon
    > > server.
    > > I can logon locally to the XP machines, and when I open the samba
    > > fileserver, it requests a password and then i can see the correct

    shares.
    > > When I try to logon to the domain, I get a message either

    saying...DOMAIN is
    > > not available...or cannot connect to DOMAIN.
    > > Here is a copy of the smb.conf
    > > Hope someone can help..ive been trying to figure this out for a week or

    so
    > Have you appled the signorseal patch to the XP pc??
    >
    > If not there is a link to the patch here on my web site
    > http://www.samba.netfirms.com/faq.htm
    > --
    > Regards,
    > Mark
    >
    > Samba Setup Guide: www.samba.netfirms.com
    > My gpg public key: www.samba.netfirms.com/gnupg/gpg_public.asc




  4. Re: Samba and XPPro

    Im not sure if this is related, but I am getting these messages in my nmbd
    logs:
    [2003/11/05 08:52:15, 0]
    nmbd/nmbd_incomingrequests.crocess_name_refresh_request(183)
    process_name_refresh_request: unicast name registration request received
    for name COMPAQ01<00> from IP 192.168.0.50 on subnet UNICAST_SUBNET.
    [2003/11/05 08:52:15, 0]
    nmbd/nmbd_incomingrequests.crocess_name_refresh_request(184)
    Error - should be sent to WINS server


    "Mark" wrote in message
    news:MPG.1a119ef03e63fbf098977a@192.168.0.203...
    > In article , "Dean M \(SkyNet
    > \)" says...
    > > Hi,
    > > I am having a problem connecting my WinXPPro clients to my Samba logon
    > > server.
    > > I can logon locally to the XP machines, and when I open the samba
    > > fileserver, it requests a password and then i can see the correct

    shares.
    > > When I try to logon to the domain, I get a message either

    saying...DOMAIN is
    > > not available...or cannot connect to DOMAIN.
    > > Here is a copy of the smb.conf
    > > Hope someone can help..ive been trying to figure this out for a week or

    so
    > Have you appled the signorseal patch to the XP pc??
    >
    > If not there is a link to the patch here on my web site
    > http://www.samba.netfirms.com/faq.htm
    > --
    > Regards,
    > Mark
    >
    > Samba Setup Guide: www.samba.netfirms.com
    > My gpg public key: www.samba.netfirms.com/gnupg/gpg_public.asc




  5. Re: Samba and XPPro


    "Dean M (SkyNet)" wrote in message
    news:ccJpb.661$xm.32121@nasal.pacific.net.au...
    > Hi,
    > I am having a problem connecting my WinXPPro clients to my Samba logon
    > server.
    > I can logon locally to the XP machines, and when I open the samba
    > fileserver, it requests a password and then i can see the correct shares.
    > When I try to logon to the domain, I get a message either saying...DOMAIN

    is
    > not available...or cannot connect to DOMAIN.
    > Here is a copy of the smb.conf
    > Hope someone can help..ive been trying to figure this out for a week or so
    >
    > # Global parameters
    > [global]
    > workgroup = DOMAIN
    > Netbios name = logonserver
    > encrypt passwords = Yes
    > ; this tells Samba that security level must be set to user
    > security = user
    >
    > ;Samba is the domain and local master browser.
    > os level = 65
    > preferred master = yes
    > domain master = yes
    > local master = yes
    >

    How about:

    domain logons = Yes

    > logon path =
    > logon script = logon.bat
    > logon drive = h:
    > logon home = \\logonserver\%u
    >
    > ;neccessary share for domain controller
    > [netlogon]
    > ; comment = Network Logon Service
    > path = /home/samba/netlogon
    > guest ok = yes
    > writable = no
    > share modes = no
    >
    > [homes]
    > read only = no
    > browseable = no
    >
    > [Shared]
    > path = /home/shared
    > browseable = yes
    > read only = no
    >
    >




+ Reply to Thread