I have a Windows 2000 Server (SP4) running Active Directory, the
workstations have Windows XP installed.
Now I want to join a RedHat 9 to the Active Directory with the use of Samba
Here is what I did and what my situation is:

Network Setup:

INTERNET ----- REDHAT 9 PC ------- SWITCH ------ Windows 2000 Active
Directory (SP4)
(Config as router) | |
(Config as ADC & DNS Server)
WinXP1 WinXP2

Network Settings:

RedHat 9 (eth0) : DHCP (for internet connection)
RedHat 9 (eth1) : Fiexed IP (
Windows 2000 Server: Fixed IP (
Windows XP Workstations: DHCP (distributed by dhcp server configured on w2k)

Active Directory Domain DNS: goldeneye.be
Active Directory NETBIOS name: goldeneye_thuis
RedHat 9 Netbios name: ICARUS
Windows 2000 Server netbios name: GOLDENEYE

Now the Linux Pc is able to join the Acitve Directory via Samba 3.0 and the
use of kerebos.
I tested the join via the 'NET ADS TESTJOIN' command and the response is
I also tried to synchronize the time of the linux tot the w2k server time
with the command 'NET TIME SET', it works fine.
Finally I checked the existence of the Linux Account via "Users And
Computers" on my windows 2000 server machine and overhere also, everyting is
fine (operating system = samba 3.0 it says)

Due the linux pc is joined to the active directory, I can't see it in my
Also when I type the dos command net view from any windows pc in my network
the "ICARUS" (linux pc) just won't show up.

Configuration files:

******** /etc/samba/smb.conf *********
# Global Definitions
netbios name = ICARUS
server string = "Icarus Internet Server"

# Active Directory Settings
security = ADS
encrypt passwords = yes

# Shares
path = /
public = yes
writable = yes

********* /etc/krb5.conf **********
default_realm = GOLDENEYE.BE

kdc = goldeneye.goldeneye.be:88

.goldeneye.be = GOLDENEYE.BE
goldeneye.be = GOLDENEYE.BE

************** /etc/hosts********************
# Do not remove the following line, or various programs
# that require network functionality will fail. ICARUS localhost.localdomain localhost ICARUS icarus.goldeneye.be

***** /etc/resolv.conf******
search goldeneye.be
domain goldeneye.be

Any solutions to this problem ??