(Rolf Unger) wrote in message news:<>...
> Hi everybody,
> i'm running samba version 2.2.3 on a Debian Linux-Box.
> [ ... ]
> Okay, I would always have the option to upgrade my NT-machine to
> Win2k, but I rather prefer to find some solution on the samba
> server for that.
> My NT-version is 4.0 Service-Pack 5.

Hm, I did now a test from a NT-Box with Service-Pack 6.
The result is the same: I can only login to a Samba share if I use
the same user with that I'm currently locally logged in the
WinNT session.

Maybe I should also mention, that there is no Primary Domain Controller
in the network.