Unable to browse network - SMB

This is a discussion on Unable to browse network - SMB ; Please help. I have searched far and wide for a resolution. I have a samba server (latest release via redhat updates) with two win xp workstations. Workstation A has no problems accessing the network. It can see all pc's on ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Unable to browse network

  1. Unable to browse network

    Please help. I have searched far and wide for a resolution.


    I have a samba server (latest release via redhat updates) with two win
    xp workstations. Workstation A has no problems accessing the network.
    It can see all pc's on but lan cannot access workstation B.
    Workstation B cannot access the workgroup. Workstation B has been
    formatted twice in 3 days and works fine until I connect it to the LAN
    at work. When I get home "network path not found". Something is
    happening when I connect to the other lan that prevents me from
    accessing the samba server when reconnected.



    ---------------------------------- smbd.log -------------------------
    [2003/07/18 00:15:13, 0] lib/access.c:check_access(333)
    Denied connection from (192.168.2.101)

    -----------------------------------------------------------------------------

    Thanks, Jon

  2. Re: Unable to browse network

    Samba 2.2.7a

    -----------------------smb.conf-------------------------------------------------------

    [global]
    workgroup = XXXXXXX
    netbios name = XXXXXX
    server string = XXXXX
    interfaces = ethX
    encrypt passwords = Yes
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n
    *passwd:*all*authentication*tokens*updated*success fully*
    username map = /etc/samba/smbusers
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    wins support = Yes
    hosts allow = 192.168.2.
    printing = cups

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [ftp]
    path = /var/ftp
    force user = root
    force group = root
    read only = No
    force create mode = 0755
    ------------------------------------------------------------------------------------------------------------------
    As you can see from my config file I have wins enabled which seems to
    make it work, but it's a work around...not a fix.

    Like I said it worked fine until I connected to my corp lan.

    After doing a tcpdump with smb off it wold appear that one or both XP
    boxes are not hearing broadcasts. Both are trying to become master
    browser and are not responding to name queries. So perhaps this issue
    is better suited to another group. If you have any ideas they will be
    appreciated, but I will continue to look elsewhere.

    Thanks, Jon


    On Sat, 19 Jul 2003 17:52:04 GMT, Rob MacGregor
    wrote:

    >Jon wrote:
    >> ---------------------------------- smbd.log -------------------------
    >> [2003/07/18 00:15:13, 0] lib/access.c:check_access(333)
    >> Denied connection from (192.168.2.101)
    >>
    >> -----------------------------------------------------------------------------

    >
    >What's in your smb.conf - looks like you've got it set to not allow
    >access from 192.168.2.0/24.
    >
    >Posting your actual version of samba would be a help too - not everybody
    >runs RedHat and RedHat don't necessarily run the very latest version.
    >
    >Finally - IPs of everything involved?



+ Reply to Thread