Errors joining samba PDC domain - SMB

This is a discussion on Errors joining samba PDC domain - SMB ; Greets everyone- I have seen this question asked a number of times on the lists, but I haven't found a solution that has worked for me yet. I have created a samba PDC, but when I try to join the ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Errors joining samba PDC domain

  1. Errors joining samba PDC domain

    Greets everyone-

    I have seen this question asked a number of times on the lists, but I
    haven't found a solution that has worked for me yet. I have created a
    samba PDC, but when I try to join the domain, I get the following
    error "No mapping between account names and security IDs was done.".
    The PDC is running samba 2.2.8a with openldap. I seem to be able to
    authenticate vs ldap just fine, but I can't get the win2k clients to
    join the domain.

    So far, I have done/verified the following as possible solutions from
    other postings:

    - smbpasswd -e root
    smbpasswd -e administrator
    smbpasswd -a root
    smbpasswd -a administrator

    - touch /usr/local/samba/private/smbpasswd
    chmod go-rwx /usr/local/samba/private/smbpasswd

    - updated to the latest 2.2 branch from cvs

    - ran find / -name samba (to make sure I only had one installation).

    - ensured there was a machine$ account created for the client in ldap

    The main thing that seems to be very wrong, is that
    /usr/local/samba/private/smbpasswd remains empty and doesn't seem to
    update. Aside from that, even turning up the debugging seems to show
    very little out of the ordinary. I can include portions (or all) of
    my smb.conf or output from various logs, however I didn't want to make
    this post any longer than it needed to be.

    Any help would be *greatly* appreciated!

    -=Vaccine

  2. Re: Errors joining samba PDC domain

    Vaccine wrote:
    > I have seen this question asked a number of times on the lists, but I
    > haven't found a solution that has worked for me yet. I have created a
    > samba PDC, but when I try to join the domain, I get the following
    > error "No mapping between account names and security IDs was done.".
    > The PDC is running samba 2.2.8a with openldap. I seem to be able to
    > authenticate vs ldap just fine, but I can't get the win2k clients to
    > join the domain.


    Did you follow the PDC HowTo?

    > - ensured there was a machine$ account created for the client in ldap


    What about creating one in the smbpasswd file? See the PDC HowTo
    document for details.

    --
    Rob MacGregor (BOFH) Oh my God! They killed init! You bastards!
    The light at the end of the tunnel is an oncoming dragon.


  3. Re: Errors joining samba PDC domain

    Vaccine wrote:
    > Any other suggestions?


    I suppose I'd suggest you try getting it working without LDAP first.
    Basically, simplify your configuration, it'll make diagnosis easier.

    --
    Rob MacGregor (BOFH) Oh my God! They killed init! You bastards!
    The light at the end of the tunnel is an oncoming dragon.


+ Reply to Thread