Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1 - Slackware

This is a discussion on Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1 - Slackware ; Posting for info as someone else is sure to want to build Gimp 2.6.0: Dependencies that needed to be built for slack 12.1: babl 0.0.22 Not part of slack gegl 0.0.18 Not part of slack intltool 0.40.4 Not part of ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

  1. Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    Posting for info as someone else is sure to want to build Gimp 2.6.0:

    Dependencies that needed to be built for slack 12.1:

    babl 0.0.22 Not part of slack
    gegl 0.0.18 Not part of slack
    intltool 0.40.4 Not part of slack
    glib 2.81.1 Upgrade see [1]

    [1] removed pre-existing glib with pkgtool and built with:
    ../configure --prefix=/usr ; make ; make install
    Ran ldconfig and rebooted - not sure that those steps are essential though,
    I was only trying to sort out some problems with gimp's ./configure

    From memory the others were all the standard
    ../configure ; make ; make install
    The above versions are not the minimum needed, but rather the most current.

    With the above ./configure for Gimp 2.6.0 should be sucessful.

    However, on running make it bangs out with the message below, not sure why.

    BTW - sorry, not made any slack-builds of the above, not quite tried that
    step, probably ought to learn how.

    Pete

    Last output from running make in gimp 2.6.0, any ideas?

    ----------------------------------------------------------------------
    Libraries have been installed in:
    /usr/local/lib

    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the `-LLIBDIR'
    flag during linking and do at least one of the following:
    - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
    - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
    - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
    - have your system administrator add LIBDIR to `/etc/ld.so.conf'

    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ----------------------------------------------------------------------
    test -z "/usr/local/include/gimp-2.0/libgimpmodule" || /usr/bin/mkdir -p "/usr/local/include/gimp-2.0/libgimpmodule"
    /usr/bin/ginstall -c -m
    644 'gimpmoduletypes.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmoduletypes.h'
    /usr/bin/ginstall -c -m
    644 'gimpmodule.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmodule.h'
    /usr/bin/ginstall -c -m
    644 'gimpmoduledb.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmoduledb.h'
    make[2]: Leaving directory `/usr/src/gimp-2.6.0/libgimpmodule'
    make[1]: Leaving directory `/usr/src/gimp-2.6.0/libgimpmodule'
    Making install in libgimpthumb
    make[1]: Entering directory `/usr/src/gimp-2.6.0/libgimpthumb'
    make[2]: Entering directory `/usr/src/gimp-2.6.0/libgimpthumb'
    test -z "/usr/local/lib" || /usr/bin/mkdir -p "/usr/local/lib"
    /bin/sh ../libtool --mode=install /usr/bin/ginstall -c 'libgimpthumb-2.0.la' '/usr/local/lib/libgimpthumb-2.0.la'
    /usr/bin/ginstall -c .libs/libgimpthumb-2.0.so.0.600.0 /usr/local/lib/libgimpthumb-2.0.so.0.600.0
    (cd /usr/local/lib && { ln -s -f libgimpthumb-2.0.so.0.600.0
    libgimpthumb-2.0.so.0 || { rm -f libgimpthumb-2.0.so.0 && ln -s
    libgimpthumb-2.0.so.0.600.0 libgimpthumb-2.0.so.0; }; })
    (cd /usr/local/lib && { ln -s -f libgimpthumb-2.0.so.0.600.0
    libgimpthumb-2.0.so || { rm -f libgimpthumb-2.0.so && ln -s
    libgimpthumb-2.0.so.0.600.0 libgimpthumb-2.0.so; }; })
    /usr/bin/ginstall -c .libs/libgimpthumb-2.0.lai /usr/local/lib/libgimpthumb-2.0.la
    /usr/bin/ginstall: cannot stat `.libs/libgimpthumb-2.0.lai': No such file or
    directory
    make[2]: *** [install-libLTLIBRARIES] Error 1
    make[2]: Leaving directory `/usr/src/gimp-2.6.0/libgimpthumb'
    make[1]: *** [install-am] Error 2
    make[1]: Leaving directory `/usr/src/gimp-2.6.0/libgimpthumb'
    make: *** [install-recursive] Error 1





    --
    http://www.petezilla.co.uk

  2. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    On 2008-10-02, Peter Chant wrote:
    > Posting for info as someone else is sure to want to build Gimp 2.6.0:
    >
    > Dependencies that needed to be built for slack 12.1:
    >
    > babl 0.0.22 Not part of slack
    > gegl 0.0.18 Not part of slack
    > intltool 0.40.4 Not part of slack
    > glib 2.81.1 Upgrade see [1]



    You're going to find this easier on -current, as it already has a new
    enough glib and added intltool.


    > From memory the others were all the standard
    > ./configure ; make ; make install
    > The above versions are not the minimum needed, but rather the most current.
    >
    > With the above ./configure for Gimp 2.6.0 should be sucessful.



    Somewhere in the release notes (iirc) it mentions that you need
    to explicitly disable gvfs if you don't have it, and you don't,
    because it's only in gtk 2.14.x


    > However, on running make it bangs out with the message below, not sure why.
    >
    > BTW - sorry, not made any slack-builds of the above, not quite tried that
    > step, probably ought to learn how.



    I've got this done and working on -current, but until I know whether
    or not Pat's going to push it into -current, I'm going to sit on them
    for now.


    > Last output from running make in gimp 2.6.0, any ideas?
    >
    > ----------------------------------------------------------------------
    > Libraries have been installed in:
    > /usr/local/lib
    >
    > If you ever happen to want to link against installed libraries
    > in a given directory, LIBDIR, you must either use libtool, and
    > specify the full pathname of the library, or use the `-LLIBDIR'
    > flag during linking and do at least one of the following:
    > - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    > during execution
    > - add LIBDIR to the `LD_RUN_PATH' environment variable
    > during linking
    > - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
    > - have your system administrator add LIBDIR to `/etc/ld.so.conf'
    >
    > See any operating system documentation about shared libraries for
    > more information, such as the ld(1) and ld.so(8) manual pages.
    > ----------------------------------------------------------------------
    > test -z "/usr/local/include/gimp-2.0/libgimpmodule" || /usr/bin/mkdir -p "/usr/local/include/gimp-2.0/libgimpmodule"
    > /usr/bin/ginstall -c -m
    > 644 'gimpmoduletypes.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmoduletypes.h'
    > /usr/bin/ginstall -c -m
    > 644 'gimpmodule.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmodule.h'
    > /usr/bin/ginstall -c -m
    > 644 'gimpmoduledb.h' '/usr/local/include/gimp-2.0/libgimpmodule/gimpmoduledb.h'
    > make[2]: Leaving directory `/usr/src/gimp-2.6.0/libgimpmodule'
    > make[1]: Leaving directory `/usr/src/gimp-2.6.0/libgimpmodule'
    > Making install in libgimpthumb
    > make[1]: Entering directory `/usr/src/gimp-2.6.0/libgimpthumb'
    > make[2]: Entering directory `/usr/src/gimp-2.6.0/libgimpthumb'
    > test -z "/usr/local/lib" || /usr/bin/mkdir -p "/usr/local/lib"
    > /bin/sh ../libtool --mode=install /usr/bin/ginstall -c 'libgimpthumb-2.0.la' '/usr/local/lib/libgimpthumb-2.0.la'
    > /usr/bin/ginstall -c .libs/libgimpthumb-2.0.so.0.600.0 /usr/local/lib/libgimpthumb-2.0.so.0.600.0
    > (cd /usr/local/lib && { ln -s -f libgimpthumb-2.0.so.0.600.0
    > libgimpthumb-2.0.so.0 || { rm -f libgimpthumb-2.0.so.0 && ln -s
    > libgimpthumb-2.0.so.0.600.0 libgimpthumb-2.0.so.0; }; })
    > (cd /usr/local/lib && { ln -s -f libgimpthumb-2.0.so.0.600.0
    > libgimpthumb-2.0.so || { rm -f libgimpthumb-2.0.so && ln -s
    > libgimpthumb-2.0.so.0.600.0 libgimpthumb-2.0.so; }; })
    > /usr/bin/ginstall -c .libs/libgimpthumb-2.0.lai /usr/local/lib/libgimpthumb-2.0.la
    > /usr/bin/ginstall: cannot stat `.libs/libgimpthumb-2.0.lai': No such file or
    > directory
    > make[2]: *** [install-libLTLIBRARIES] Error 1
    > make[2]: Leaving directory `/usr/src/gimp-2.6.0/libgimpthumb'
    > make[1]: *** [install-am] Error 2
    > make[1]: Leaving directory `/usr/src/gimp-2.6.0/libgimpthumb'
    > make: *** [install-recursive] Error 1



    Hrm, no idea; I haven't seen that.

    You are going to run across this one though:
    http://bugzilla.gnome.org/show_bug.cgi?id=554785

    I scratched my head a bit on it - the missing errno.h include
    relatively easy to spot, but the wrong "filename" as opposed
    to "tmpname" didn't jump out at me until later. It seems that
    the gimp devs were so enamored with the new gvfs functionality
    that they didn't bother to test whether the old code still worked
    after their changes for the new stuff. I noticed that the fallback
    wget uri handler also fails if you disable libcurl, and I intend to
    go back and work out a patch for it too, but I have more important
    things to do right now :-)

    -RW

  3. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    On 2008-10-03, Robby Workman wrote:
    >
    > Somewhere in the release notes (iirc) it mentions that you need
    > to explicitly disable gvfs if you don't have it, and you don't,
    > because it's only in gtk 2.14.x



    Okay, part of that is wrong. gvfs is not part of gtk, but either
    way, it's not in Slackware. Furthermore, it's not in consideration
    in the near future.


    > I've got this done and working on -current, but until I know whether
    > or not Pat's going to push it into -current, I'm going to sit on them
    > for now.



    Probably Slackware will stay with the 2.4.x series of gimp for a bit,
    so build babl, gegl, and gimp (in that order) from here:
    http://rlworkman.net/slackbuilds/
    Note that these are only tested on -current -- whether they'll work
    as is on 12.0 is unknown.


    > You are going to run across this one though:
    > http://bugzilla.gnome.org/show_bug.cgi?id=554785



    This is fixed in svn, as well as another one I found in the wget
    backend (but it had already been fixed upstream).

    -RW

  4. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    Robby Workman wrote:


    >> You are going to run across this one though:
    >> http://bugzilla.gnome.org/show_bug.cgi?id=554785

    >
    >
    > This is fixed in svn, as well as another one I found in the wget
    > backend (but it had already been fixed upstream).


    Robbie,

    thanks for posts. I'm just (ought to have left already!) going away for
    this weekend, I'll revisit this when I get back.

    I beleive that they've finally gone beyond 8 bit per channel (24 bit) colour
    in gimp which is of interest to me. One of the few reasons for me running
    XP on another machine is to keep a 10 year old copy of Photoshop 5LE
    running for this very reason.

    Thanks,

    Pete


    --
    http://www.petezilla.co.uk

  5. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    Peter Chant wrote:


    > I beleive that they've finally gone beyond 8 bit per channel (24 bit)
    > colour
    > in gimp which is of interest to me. One of the few reasons for me running
    > XP on another machine is to keep a 10 year old copy of Photoshop 5LE
    > running for this very reason.


    Hmm, quick install on another OS. Loaded up a 16 bit per channel image and
    it converted it to 8 bit on loading. I'll have to have a longer play. A
    shame if its not over >8 bit. It did look rather slick though.

    Pete

    --
    http://www.petezilla.co.uk

  6. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    Peter Chant wrote:

    > Hmm, quick install on another OS. Loaded up a 16 bit per channel image
    > and
    > it converted it to 8 bit on loading. I'll have to have a longer play. A
    > shame if its not over >8 bit. It did look rather slick though.


    Update, apparently it is in there but you need to enable it. Not tried yet.

    --
    http://www.petezilla.co.uk

  7. Re: Gimp 2.6.0 - Almost But Not Quite Built in Slack 12.1

    Peter Chant wrote:
    >Peter Chant wrote:
    >
    >> Hmm, quick install on another OS. Loaded up a 16 bit per channel image
    >> and
    >> it converted it to 8 bit on loading. I'll have to have a longer play. A
    >> shame if its not over >8 bit. It did look rather slick though.

    >
    >Update, apparently it is in there but you need to enable it. Not tried yet.


    It uses 32 bit floating point arithmetic internally, but
    it cannot load a 16 bit depth image file.

    --
    Floyd L. Davidson
    Ukpeagvik (Barrow, Alaska) floyd@apaflo.com

+ Reply to Thread