Strange Xterm font behaviour - Slackware

This is a discussion on Strange Xterm font behaviour - Slackware ; After I upgrading ghostscript fonts in Slackware 12.0 my xterms are now inserting a single space between all letters when ..Xresources tells it to use a specific font (i.e. Helvetica, Times etc.). When no font is requested, the xterm displays ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Strange Xterm font behaviour

  1. Strange Xterm font behaviour

    After I upgrading ghostscript fonts in Slackware 12.0 my xterms
    are now inserting a single space between all letters when
    ..Xresources tells it to use a specific font (i.e. Helvetica,
    Times etc.). When no font is requested, the xterm displays text
    as normal, with no inserted blank spaces. Other terminal
    emulators such konsole are working without problems.

    There seems to have been some initial problems with the
    ghostscript font upgrade in Slackware 12.0. After upgrading, gv
    was getting a "ERROR: /invalidfont in findfont" error. This was
    corrected with:

    upgradepkg --reinstall ap/ghostscript-fonts-std-8.11-noarch-1.tgz

    as the upgrade from 11.0 to 12.0 appears to have removed some
    files. It was after this fix that I started having problems with
    xterm.

    Any ideas as to what may be causing this problem? I am tempted
    to just move to konsole (which I am using now), but it would be
    nice to sort out this problem.

    Cheers,
    Simon

  2. Re: Strange Xterm font behaviour

    sim...@nospam.com wrote:
    > After I upgrading ghostscript fonts in Slackware 12.0 my xterms
    > are now inserting a single space between all letters when
    > .Xresources tells it to use a specific font (i.e. Helvetica,
    > Times etc.). When no font is requested, the xterm displays text
    > as normal, with no inserted blank spaces. Other terminal
    > emulators such konsole are working without problems.


    Perhaps it is resolving to a font which contains some characters which
    are not single-width.
    I seem to recall some other issue a while back - it would help to know
    what version of
    xterm is in Slackware 12.0

    --
    Thomas E. Dickey
    http://invisible-island.net
    ftp://invisible-island.net

  3. Re: Strange Xterm font behaviour

    dickey wrote:
    > sim...@nospam.com wrote:
    >> After I upgrading ghostscript fonts in Slackware 12.0 my xterms
    >> are now inserting a single space between all letters when
    >> .Xresources tells it to use a specific font (i.e. Helvetica,
    >> Times etc.). When no font is requested, the xterm displays text
    >> as normal, with no inserted blank spaces. Other terminal
    >> emulators such konsole are working without problems.

    >
    > Perhaps it is resolving to a font which contains some characters which
    > are not single-width.
    > I seem to recall some other issue a while back - it would help to know
    > what version of
    > xterm is in Slackware 12.0
    >


    Slackware 12.0 uses Xterm 224.

    (I am now happily using konsole, and will probably not switch
    back; still this is strange behaviour).

    -Simon

  4. Re: Strange Xterm font behaviour

    After uprading to Slak 12.1, I had the same problem. But I was
    able to fix it by changing the layout of .Xresources. I changed
    the way I entered values to this, and it worked perfectly:

    *VT100*faceName: Helvetcia
    *VT100*faceSize: 18
    *VT100*background: black
    *VT100*foreground: white

    -Simon

+ Reply to Thread