libjemalloc.so error on Firefox - Slackware

This is a discussion on libjemalloc.so error on Firefox - Slackware ; Trying to run Firefox 3rc02 on Slack 10 and getting the following error when I try to run it: ../firefox ../firefox-bin: error while loading shared libraries: libjemalloc.so: \ cannot handle TLS data I tried googling that but only 4 matchs ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: libjemalloc.so error on Firefox

  1. libjemalloc.so error on Firefox


    Trying to run Firefox 3rc02 on Slack 10 and getting the following
    error when I try to run it:
    ../firefox
    ../firefox-bin: error while loading shared libraries: libjemalloc.so: \
    cannot handle TLS data

    I tried googling that but only 4 matchs come up and not one of them is
    helping at all. Anyone run into this problem and have a fix for it?
    I would like to be able to try a version of flash newer than version 7
    without it crashing down like the Berlin Wall and am hopping that FF3
    could help with that.


    --
    =()==()==()==()==()- http://fauxascii.com
    \ \ \ \ \ \ ASCII artist
    :F_P:-O- -O- -O- -O- -O- -O- -O- Get your ASCII Art T-Shirt:
    http://www.keystroketshirts.com/asci...i-fullView.php

  2. Re: libjemalloc.so error on Firefox

    On 2008-06-06, Faux_Pseudo wrote:
    >
    > Trying to run Firefox 3rc02 on Slack 10 and getting the following
    > error when I try to run it:
    > ./firefox
    > ./firefox-bin: error while loading shared libraries: libjemalloc.so: \
    > cannot handle TLS data
    >
    > I tried googling that but only 4 matchs come up and not one of them is
    > helping at all. Anyone run into this problem and have a fix for it?
    > I would like to be able to try a version of flash newer than version 7
    > without it crashing down like the Berlin Wall and am hopping that FF3
    > could help with that.



    I think you're going to need at least Slackware 11.0, as glibc in it
    was built with NPTL, which you seem to need.

    -RW

+ Reply to Thread