Ekiga VOIP error: sndrv_pcm_hw_params - Slackware

This is a discussion on Ekiga VOIP error: sndrv_pcm_hw_params - Slackware ; I just installed Slackware 12.0 and most recent Gnome Slackbuild v2.20.3. Goal is to use Ekiga VOIP software. Sound card (Ensoniq ES1371) and webcam (USB_PWC) seem to otherwise work fine, but Ekiga is crashing. I keep getting this error: sndrv_pcm_hw_params: ...

+ Reply to Thread
Results 1 to 9 of 9

Thread: Ekiga VOIP error: sndrv_pcm_hw_params

  1. Ekiga VOIP error: sndrv_pcm_hw_params


    I just installed Slackware 12.0 and most recent
    Gnome Slackbuild v2.20.3. Goal is to use Ekiga VOIP
    software. Sound card (Ensoniq ES1371) and webcam (USB_PWC)
    seem to otherwise work fine, but Ekiga is crashing. I keep
    getting this error:

    sndrv_pcm_hw_params: Assertion `err >= 0' failed

    A search indicates this error pops up with several Linux
    distros with Skype and Gizmo, in addition to Ekiga. I am
    not finding a solution. Anyone know how to solve this?

    Dee


  2. Re: Ekiga VOIP error: sndrv_pcm_hw_params

    Dominic-Luc Webb wrote:
    > I just installed Slackware 12.0 and most recent
    > Gnome Slackbuild v2.20.3. Goal is to use Ekiga VOIP
    > software. Sound card (Ensoniq ES1371) and webcam (USB_PWC)
    > seem to otherwise work fine, but Ekiga is crashing. I keep
    > getting this error:
    >
    > sndrv_pcm_hw_params: Assertion `err >= 0' failed
    >
    > A search indicates this error pops up with several Linux
    > distros with Skype and Gizmo, in addition to Ekiga. I am
    > not finding a solution. Anyone know how to solve this?
    >
    > Dee
    >


    Have you properly configured your audio device (in Edit -> Preferences
    -> devices -> audio devices). The ekiga I am using is the one I have
    submitted in www.slackbuids.org (this is a build independant of Gnome).

    Olive

  3. Re: Ekiga VOIP error: sndrv_pcm_hw_params

    Olive wrote:
    > Dominic-Luc Webb wrote:
    >> I just installed Slackware 12.0 and most recent
    >> Gnome Slackbuild v2.20.3. Goal is to use Ekiga VOIP
    >> software. Sound card (Ensoniq ES1371) and webcam (USB_PWC)
    >> seem to otherwise work fine, but Ekiga is crashing. I keep
    >> getting this error:
    >>
    >> sndrv_pcm_hw_params: Assertion `err >= 0' failed
    >>
    >> A search indicates this error pops up with several Linux
    >> distros with Skype and Gizmo, in addition to Ekiga. I am
    >> not finding a solution. Anyone know how to solve this?
    >>
    >> Dee
    >>

    >
    > Have you properly configured your audio device (in Edit -> Preferences
    > -> devices -> audio devices). The ekiga I am using is the one I have
    > submitted in www.slackbuids.org (this is a build independant of Gnome).


    (it was www.slackbuilds.org sorry...)

    Olive

  4. Re: Ekiga VOIP error: sndrv_pcm_hw_params



    > Have you properly configured your audio device (in Edit -> Preferences
    > -> devices -> audio devices). The ekiga I am using is the one I have
    > submitted in www.slackbuids.org (this is a build independant of Gnome).
    >
    > Olive


    Thanks for your response. Yes, I am quite sure I set this properly.
    I did not know your build existed. Nice! I might not have installed
    Gnome in its entirety if I know about this. I should at least look
    for this and try.

    Dee


  5. Re: Ekiga VOIP error: sndrv_pcm_hw_params


    On Mon, 3 Mar 2008, Olive wrote:
    >
    > (it was www.slackbuilds.org sorry...)
    >
    > Olive


    I went here and all I found was a file clearly indicating it
    was Ekiga, but was actually just an ASCII file pointing to
    some website. Anyway, this may be besides that point. I
    suspect that even your build might end up giving the same
    problem anyway. From what I can find so far, this looks like
    a kernel configuration issue or maybe a bug that needs to be
    fixed by those writing drivers. I would most be interested
    in hearing from someone who has encountered this problem
    and figured out how to fix it. Have you encountered this
    yourself or maybe have some idea where it is coming from?

    Dee


  6. Re: Ekiga VOIP error: sndrv_pcm_hw_params


    Specifically, I have found this, thanks to GSB users group:
    https://bugtrack.alsa-project.org/al...ew.php?id=2601 and
    http://www.pulseaudio.org/ticket/23.

    These patches can be found there, but not sure if this
    should fix my problem???

    pcm_pulse.patch [^] (441 bytes) 2007-11-08 18:16
    alsa-pulse.patch [^] (819 bytes) 2008-02-21 17:08

    Dee


  7. Re: Ekiga VOIP error: sndrv_pcm_hw_params

    Dominic-Luc Webb wrote:
    > On Mon, 3 Mar 2008, Olive wrote:
    >> (it was www.slackbuilds.org sorry...)
    >>
    >> Olive

    >
    > I went here and all I found was a file clearly indicating it
    > was Ekiga,


    This site only provide build scripts. You have to download the source
    (mentioned in the .info file; this file can be sourced so you can easily
    write a script that automate the process) and launch xxx.SlackBuild to
    build the package (dependencies are indicated in the README file: in the
    case of ekiga it is opal and pwlib).

    but was actually just an ASCII file pointing to
    > some website. Anyway, this may be besides that point. I
    > suspect that even your build might end up giving the same
    > problem anyway. From what I can find so far, this looks like
    > a kernel configuration issue or maybe a bug that needs to be
    > fixed by those writing drivers. I would most be interested
    > in hearing from someone who has encountered this problem
    > and figured out how to fix it. Have you encountered this
    > yourself or maybe have some idea where it is coming from?


    I have not experienced it but I would try the following in order to
    debug it. Can you play sound files with aplay (try aplay .wav)
    and can you record something from the micro with arecord? These tests
    should tell you if the problem come from the kernel/hardware or not.

    What have you configured in audio devices of ekiga? What are the options
    available? If aplay works; try to use ALSA as the audio plugin and your
    specific card in Audio Devices (I can choose between Default and HDA
    Intel: my sound card; do not use the default but your specific sound card).

    In case ekiga is misconfigured; try to delete its configuration file
    (the non gnome build store it in ~/.config/ekiga but I beleive the Gnome
    build use gconf).

    Olive

  8. Re: Ekiga VOIP error: sndrv_pcm_hw_params


    On Tue, 4 Mar 2008, Olive wrote:
    > I have not experienced it but I would try the following in order to
    > debug it. Can you play sound files with aplay (try aplay .wav)
    > and can you record something from the micro with arecord? These tests
    > should tell you if the problem come from the kernel/hardware or not.
    >
    > What have you configured in audio devices of ekiga? What are the options
    > available? If aplay works; try to use ALSA as the audio plugin and your
    > specific card in Audio Devices (I can choose between Default and HDA
    > Intel: my sound card; do not use the default but your specific sound card).
    >
    > In case ekiga is misconfigured; try to delete its configuration file
    > (the non gnome build store it in ~/.config/ekiga but I beleive the Gnome
    > build use gconf).
    >
    > Olive


    Hi again!

    I'll check again. I did mention in my original post that the
    sound card and webcam otherwise work fine.... There is a mixer
    called alsamixer that seems to work fine to control sound. It
    has not yet crashed or given any problems, but I could try
    using it more often and see if it ever happens. Thus far the
    only crashes have occurred when running Ekiga, and these crop
    up rather quickly, with the error mentioned on the subject line
    of this thread.

    I'll hunt for the config file. Thanks.

    Dee


  9. Re: Ekiga VOIP error: sndrv_pcm_hw_params


    This problem seems to be a bug in ALSA driver or
    ALSA-lib. I have submitted the following bug report:

    https://bugtrack.alsa-project.org/al...ew.php?id=3825

    Dee



+ Reply to Thread