No /sbin/init found on rootdev - Slackware

This is a discussion on No /sbin/init found on rootdev - Slackware ; I have Slackware-current in my box, whit the last upgrades installed (Sun Feb 24 15:15:40). Since the new mkinitrd I canīt start Slackware, I get the nest error messages: -Command failed: dm_task_set_name: Device /dev/mapper/crytroot not found -mount: mounting /dev/mapper//dev/mapper/cryptroot on ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: No /sbin/init found on rootdev

  1. No /sbin/init found on rootdev

    I have Slackware-current in my box, whit the last upgrades installed (Sun
    Feb 24 15:15:40).
    Since the new mkinitrd I canīt start Slackware, I get the nest error
    messages:

    -Command failed: dm_task_set_name: Device /dev/mapper/crytroot not found
    -mount: mounting /dev/mapper//dev/mapper/cryptroot on /mnt failed: No such
    file or directory
    -ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.

    Any idea ?

    Sorry for my english.

    Juan




  2. Re: No /sbin/init found on rootdev

    On Feb 26, 1:17 pm, "Juan MŠ Santiago Burruchaga"
    wrote:
    > I have Slackware-current in my box, whit the last upgrades installed (Sun
    > Feb 24 15:15:40).
    > Since the new mkinitrd I canīt start Slackware, I get the nest error
    > messages:
    >
    > -Command failed: dm_task_set_name: Device /dev/mapper/crytroot not found
    > -mount: mounting /dev/mapper//dev/mapper/cryptroot on /mnt failed: No such
    > file or directory
    > -ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
    >
    > Any idea ?
    >
    > Sorry for my english.
    >
    > Juan


    did you do this?
    Sat Feb 23 14:00:46 CST 2008 a/mkinitrd-1.3.1-i486-2.tgz:
    Make sure to copy both devices and symlinks to /dev in the initrd.

+ Reply to Thread